# Table of Contents

**Chapter 1: Introduction** ................................................................. 7

About the Content Manager ................................................................. 8
   Overview .................................................................................. 8
   Content Manager within the Envinsa Framework ....................... 9
   Content Manager Users ......................................................... 9

Content Manager Features ................................................................. 9
   Data Organization .................................................................. 9
   Enterprises and Domains ....................................................... 10
   Wizards .............................................................................. 10
   Toolbar and Buttons .......................................................... 10
   Data Querying ...................................................................... 11
   Security .............................................................................. 11
   Batch Geocoding .................................................................. 11
   Multiple Document Interface (MDI) .................................... 12

About the Content Manager Interface .................................................. 12
   Navigation Panel ............................................................... 12
   Information Panel ............................................................. 13
   Toolbars ........................................................................... 13
   Menus ............................................................................... 15

Installation and Configuration .............................................................. 17

**Chapter 2: Getting Started with the Content Manager** ......................... 18

Understanding Enterprises and Domains ............................................... 19
   Understanding Enterprises .................................................. 19
   Understanding Domains ...................................................... 19

Starting the Content Manager .............................................................. 20
   Logging In ........................................................................ 21
   Opening the Sample Domain ............................................ 21

Planning Your Content Management Structure .................................... 22

Setting Up Enterprises and Domains ..................................................... 23
   Creating a New Enterprise ................................................... 23
   Creating a New Domain ....................................................... 24
   Copying a Domain .............................................................. 25
   De-registering a Domain ...................................................... 27
   Registering a Domain ........................................................ 28
   Opening a Domain .............................................................. 30
   Switching Domains ............................................................ 30
   Deleting a Domain .............................................................. 31
# Content Manager Guide Table of Contents

## Chapter 4: Creating Resources Using Advanced Techniques
- **Getting Started** .................................................. 48
- **Creating a Data Source (Advanced)** .......................... 49
- **Examples of Setting Up Data Sources** ....................... 53
  - Setting up a TAB Data Source .................................. 53
  - Setting up an Oracle Data Source Using the Oracle JDBC Driver .............................................. 54
  - Setting up a SQL Server Data Source Using the MicroSoft SQL Server JDBC Driver ............. 55
  - Setting up a Generic JDBC XY Data Source .................. 56
- **Creating a Data Content (Advanced)** .......................... 58
  - Ad Hoc Content ................................................... 62
- **Creating a Data Adapter (Advanced)** .......................... 63
- **Exposing Your Data Through WFS** ........................... 66
- **Copying Resources** .............................................. 75
  - Copying a Resource ............................................... 75
  - Editing a Resource in an External Editor .................... 76
- **Closing a Domain** ................................................ 31
- **Saving Your Changes** .......................................... 31
- **Creating User Accounts** ....................................... 32

## Chapter 5: Querying Your Data
- **Introduction to Data Querying** ................................. 78
  - Types of Filters .................................................. 78
  - Direct Query ...................................................... 78
  - Setting Up a Filter ............................................... 79
  - Populating a Filter ............................................... 79
- **Creating a Filter** ................................................ 79
  - Creating a Static Filter ......................................... 80
  - Creating a Dynamic Filter ..................................... 82
- **Modifying a Filter** ............................................. 83
  - Adding Operators to a Filter .................................. 83
- **Creating a Dynamic Filter** ..................................... 82
- **Creating a Static Filter** ........................................ 80
- **Adding Operators to a Filter** ................................ 83
- **Creating a Filter** ................................................ 79
- **Modifying a Filter** ............................................. 83
- **Creating User Accounts** ....................................... 32
- **Chapter 5: Querying Your Data** ................................. 77
- **Chapter 4: Creating Resources Using Advanced Techniques** .................................................. 48
- **Chapter 3: Creating Resources Using Wizards** ................................. 33
- **Chapter 2: Creating Resources Using Wizards** .......................... 32
- **Chapter 1: Creating Resources Using Wizards** ........................ 31
- **Creating Resources Using Wizards** .............................. 30
- **Using the Data Content Wizard** ................................ 40
- **Creating a Data Source from a DBMS** ........................ 38
- **Creating a Data Source from a File** .......................... 37
- **Creating a Data Source (Advanced)** .......................... 38
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 37
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 38
- **Creating a Data source Using the MicroSoft SQL Server JDBC Driver** ..................... 39
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 39
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 40
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 41
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 42
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 43
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 44
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 45
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 46
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 47
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 48
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 49
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 50
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 51
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 52
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 53
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 54
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 55
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 56
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 57
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 58
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 59
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 60
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 61
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 62
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 63
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 64
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 65
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 66
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 67
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 68
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 69
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 70
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 71
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 72
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 73
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 74
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 75
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 76
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 77
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 78
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 79
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 80
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 81
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 82
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 83
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 84
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 85
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 86
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 87
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 88
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 89
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 90
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 91
- **Creating a Data Source Using the MicroSoft SQL Server JDBC Driver** ..................... 92
- **Creating a Data Source Using the Microsoft SQL Server JDBC Driver** ............................. 93
- **Creating a Data Source Using the Oracle JDBC Driver** .................................................. 94
Chapter 6: Remote Access ................................................................. 99
Remote Access ............................................................... 100
Using a Remote Domain in a Local Content Manager ..................... 101
Using a Remote Content Manager ............................................. 102
Remote Directory Access ......................................................... 102
Configuring Directories to be Remotely Accessible ......................... 103
Directory Permissions .............................................................. 103
Data Uploading ........................................................................ 104
Chapter 7: Data Security .............................................................. 106
Understanding Domain Access Privileges ..................................... 107
Understanding User Roles .......................................................... 107
Understanding User Account Permissions by Domain ..................... 107
Accessing Domains by User Account For Web Services .................. 109
Understanding Resource Access Privileges .................................. 110
Resource Owner ....................................................................... 110
Rules for Setting Up Access Rights to Resources ............................ 111
Understanding User Account Access Rights by Domain .................. 111
Assigning Resource Access Rights ............................................. 113
Chapter 8: Creating a Catalog ......................................................... 115
Understanding Catalogs ............................................................. 116
Managing Your Content ........................................................... 116
Understanding Catalogs ............................................................. 116
Understanding Categories .......................................................... 117
Understanding Contents ............................................................. 117
Planning Your Catalog Structure ................................................ 117
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan the Catalog</td>
<td>117</td>
</tr>
<tr>
<td>Create the Catalog Hierarchy</td>
<td>118</td>
</tr>
<tr>
<td>Creating a Catalog</td>
<td>118</td>
</tr>
<tr>
<td>Creating a Category</td>
<td>119</td>
</tr>
<tr>
<td>Creating a Reference to a Content</td>
<td>120</td>
</tr>
<tr>
<td>Appendix A: Migrating From a Previous Version of Envinsa</td>
<td>122</td>
</tr>
<tr>
<td>Deploying Envinsa Version 4.0 Content Manager</td>
<td>123</td>
</tr>
<tr>
<td>Understanding Domains</td>
<td>123</td>
</tr>
<tr>
<td>Migrating Your 3.0 Domains to 4.0</td>
<td>123</td>
</tr>
<tr>
<td>Mapping of Previous Terms</td>
<td>124</td>
</tr>
</tbody>
</table>
Welcome to the Content Manager Guide. This guide provides information about storing, organizing, and securing your data within the MapInfo® Envinsa™ Location Platform. It is written specifically for the Administrators managing data used by Envinsa Web Services.

In this section:

- About the Content Manager ......................... 8
- Content Manager Features ............................ 9
- About the Content Manager Interface ............... 12
- Installation and Configuration ....................... 17
About the Content Manager

This section gives background and context to the role the Content Manager plays in the Envinsa Location Platform. It answers some basic questions to help you get familiar with what you can do with the Content Manager (CMC).

Overview

The Content Manager is a central point where all your organization’s data and metadata can be loaded, updated, and defined. It provides an easy way to visually organize your source data and present it to end users. The focus is on the information provided in the data rather than the structure, storage, or databases tables of the Data Source itself.

Content Manager Framework

The Content Manager provides the mechanism to allow you to set up connections to your data using MapInfo’s Data Access Component (DAC). This source data can be in databases such as Oracle, and SQL Server that are supported by the Envinsa Location Platform, or as dynamic Data Sources such as a dynamic Point of Interest (POI) data that are fed live over the Internet.

Connections to any source data you set up are listed in the Data Sources area of a Domain. If the source data is dynamic, or in a format not supported by the Envinsa Location Platform, any connections set up to this data are listed in the Data Adapters section of the Domain.

Once you have set up connections to your Data Sources, you can set up Contents. Contents allow services to focus on the information in the Data Source, rather than the Data Source itself. They provide a view of the Data Sources that can be useful to a variety of users. For example, you can create one Content specifically for an application that requires only three attributes of the ten available in a particular Data Source. The same Data Source can then be used to create another Content for a different user who requires all ten data attributes. Contents permit the Data Sources to be used as efficiently as possible by all end users.
As you set up Contents based on the various Data Sources in your company, you can create references to them that can be organized into a directory-like hierarchical structure of Catalogs and Categories. This enables users to quickly and easily find the information they need, and also allows a Content to be referenced several times in different places in the Catalog. This directory of Catalogs and Contents can be created in the Catalogs section of the Domain.

**Content Manager within the Envinsa Framework**

By setting up your data using the Content Manager, you enable Envinsa Web Services to access the data. All the Web services have access to the same Content Manager Domains. This means that if one service, such as the Web Feature Service, makes updates to the data, all the other services will see this change.

As the diagram in the previous section shows; Data Sources, Contents, Data Adapters, and Catalogs are all created in a Domain. Domains represent groupings of data within Enterprises that are set up by your Envinsa Administrator. Enterprises represent a group of users, such as an organization or company, and provide a way of assigning users access only to certain information. This keeps information secure, and accessible only by those who have been explicitly assigned to it. Any number of Domains can be set up within Enterprises to further group types of information together. For example, Domains may be created for each department in an organization, or for each team working on a different project. How these Enterprises and Domains are set up will be unique for your organization, but it requires significant planning between both the Content Manager Administrator and the Envinsa Administrator to ensure users have access to the correct information. For more information on Enterprises and Domains, refer to *Getting Started with the Content Manager in Chapter 2 on page 18*.

**Content Manager Users**

The Content Manager is aimed primarily at a data manager, Geographical Information System (GIS) administrator, or database administrator who has the task of managing the data to be used in Envinsa.

**Content Manager Features**

This section outlines Content Manager's main features and highlights the major improvements, modifications, and updates for this release.

**Data Organization**

The Content Manager lets you organize your data by creating Domains, Contents, Catalogs, Categories, and references to Contents. These are all ways of showing the structure and relationships within your data.

This organization of data makes information easy to find, and the visual representation is helpful when planning data structure changes or modifications in your company.
Enterprises and Domains

The Content Manager uses the concepts of Enterprises and Domains. When a user account is created in Enterprise Manager, it is assigned to a specific Enterprise. This lets users access Domains within that specific Enterprise only. Users only have access to the information within the Enterprise to which they belong. The Administrator has access to all the information in all Enterprises.

Domains are created within Enterprises to further organize information into groupings. For example, each Enterprise may require several sub-groups such as Sales, Marketing, and Accounting departments. Each of these departments could be represented by different Domains. Different user accounts have different access to Domains depending on their account privileges.

Enterprises and Domains are discussed fully in Chapter 2: Getting Started with the Content Manager.

Wizards

This version provides four wizards to set up Data Sources, Contents, Data Adapters, and to transfer data to a remote Domain conveniently and easily. The wizards are particularly useful to new users when starting out with the Content Manager. When you are more familiar with the interface, buttons are provided for the quick creation of these resources. The wizards provide step-by-step instructions to guide you through the process of setting up the following resources:

- **Data Source** – This wizard creates a Data Source by providing a name, type, and location of the Data Source in either a file or DBMS format.
- **Content** – This wizard creates a Content by creating a name for the Content, selecting a Data Source, defining the attributes, spatial column, coordinate systems, and optionally creating a filter.
- **Data Adapter** – This wizard creates a Data Adapter by defining a name, selecting a data content, and the type and location of the Data Source to be used.
- **Data Transfer** – This wizard allows users to upload customer data to the remote server with which the Console is connected.

Note: The Data Transfer Wizard only works with a Content Manager connected to a remote server or a remote Domain registered with a local Content Manager.

Instructions on how to use the Data Source, Content, and Data Adapter Wizards are provided in Chapter 3: Creating Resources Using Wizards. Instructions on using the Data Transfer Wizard are provided in Data Uploading in Chapter 6 on page 104.

Toolbar and Buttons

Toolbars can be used to access frequently used tools. Buttons are provided for commonly used tasks such as creating new Contents, Data Sources, Data Adapters, and filters. You can use these buttons when you are familiar with the Content Manager functionality to quickly and easily create new resources. It is recommended that you use the wizards when first performing those functions with the Content Manager.
Data Querying

Queries are used to retrieve data that satisfies specific conditions. For example, all restaurants that are Chinese. You can query data by using SQL queries that are supported by the underlying data source or by using filters defined in the Content Manager. SQL queries are made directly to the data source and filter out values to satisfy specific conditions. Content Manager lets you define filters (Dynamic and Static).

- **Filters, either static or dynamic.** These filters are always applied to the data content. For example you may have a table of data that has information for all the major cities in the United States but you are only interested in values in the city of Chicago. You would set up a static filter on the Content to show only the Chicago values. A dynamic filter is pre-defined and is invoked by name at runtime. Dynamic filters contain parameters that can only be evaluated at run time. The underlying Data Source is not modified.

- **Direct Query** – This is a SQL query that can be applied to the data content. This type of query allows more flexibility than the standard filters. SQL queries are only supported for RDBMS sources such as Oracle or SQLServer. The SQL syntax used depends on the syntax used by the underlying data source. See the appropriate product documentation for details on the SQL syntax supported.

All of these concepts are discussed in Chapter 5: Querying Your Data.

Security

An important feature in Content Manager is the ability to grant or deny access to certain resources within a Domain. Used in conjunction with the user account roles, created using the Enterprise Manager, you can control who has access to certain Enterprises and Domains, and the individual resources within those Domains.

Not all information should be accessible by everyone within the same organization. For example, an organization may have personnel records and development records. A Domain may contain both sets of records. Human resources personnel would be granted access to the Personnel Content, while development personnel would be granted to the Development Project Content. The Personnel Data Source could be the basis for different Contents. A high-level manager can have access to a Content that includes all the records, while lower-level managers are given access to a Content that is filtered to contain only those records for the personnel that are direct reports. Therefore it is vital that the Content Manager supports different privilege roles to access data within an organization.

Security features and procedures are discussed fully in Chapter 7: Data Security.

Batch Geocoding

The Content Manager allows you to add geographic references (Latitude/Longitude) to data in Contents. Addition of this information allows Contents to be queried and filtered spatially. A Content with such information can answer questions such as: “Show me all the customers within 10 miles of a given location.”

For this reason, the Content Manager has batch geocoding functionality to perform geocoding on any tables or databases that are missing an x,y column, or to update existing geocoded tables.

Batch geocoding is discussed fully in the Batch Geocoding Guide.
Multiple Document Interface (MDI)

This functionality allows one or more Domains to be opened at one time. The Domains are displayed as separate sessions, but you may switch between any of the Domains you currently have open to compare Domains and to copy and paste resources.

About the Content Manager Interface

The Content Manager has a rich user interface, allowing you to perform many actions through buttons and menus. You can browse resources in the Navigation Panel, and edit resources in the Information Panel. This section provides an overview of the Content Manager’s panels, toolbars, and menus.

Content Manager: Navigation and Information Panels

Navigation Panel

This tree-like structure on the left-hand side of the Content Manager lets you browse through the Data Sources, Contents, and Data Adapters in a Domain, and organize the Domain’s resources into Catalogs. The previous illustration uses the Sample Domain provided with the Content Manager to illustrate the different pieces that make up the navigation tree.
The top level of the panel is the Domain. This is the top level of information within a particular Enterprise. The Domain has four different sections:

- **Data Sources** – This lists the Data Sources you have set up using the Content Manager. You must set up Data Sources before setting up any Contents. Refer to *Workflow for Creating Resources in Chapter 3 on page 35*.

- **Contents** – This lists the Contents you have created using the Content Manager. Contents are based on an underlying Data Source, so you must have created a Data Source before you can create a Content. Refer to *Using the Data Content Wizard in Chapter 3 on page 40*.

- **Data Adapters** – This lists any Data Adapters you have set up to translate any Data Sources not supported by the Envinsa Location Platform. Refer to *Using the Data Adapter Wizard in Chapter 3 on page 44*.

- **Catalogs** – This is where you create references to any Contents you have created to organize them into Catalogs. You do not create any Contents in this area, but simply organize the Contents you have already created into a logical, hierarchical structure. The Catalogs are used to make Contents easy to find, and applicable to services with different data structure requirements. Refer to *Chapter 8: Creating a Catalog*.

**Information Panel**

This area displays information about the Contents, Data Sources, and Data Adapters you have already created and set up. You can use the information displayed in this area to verify how you set up these resources, or to edit and update them once they are created. This area displays all the information about the resources. In the previous illustration, the Alberta Landmark Content is selected in the Navigation Panel, and the information about it displays in the Information panel.

**Toolbars**

The Content Manager toolbar provides tools for creating resources and filters, performing batch geocoding, and managing data security.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Open Domain]</td>
<td>Open Domain</td>
<td>Open an existing Domain.</td>
</tr>
<tr>
<td>![Close Domain]</td>
<td>Close Domain</td>
<td>Close the current Domain.</td>
</tr>
<tr>
<td>![Save Resource]</td>
<td>Save Resource</td>
<td>Save the current resource.</td>
</tr>
<tr>
<td>![Save All Resources]</td>
<td>Save All Resources</td>
<td>Save all the resources in the current Domain that were edited during the session.</td>
</tr>
<tr>
<td>![Cut]</td>
<td>Cut</td>
<td>Remove a resource from the Domain and places it on the clipboard.</td>
</tr>
<tr>
<td>![Copy]</td>
<td>Copy</td>
<td>Make a copy of a resource in the Domain and place it on the clipboard.</td>
</tr>
<tr>
<td>Button</td>
<td>Name</td>
<td>Function</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Paste</td>
<td>Add the copied resource to the new location.</td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Undo the last action performed. (Not implemented in this release.)</td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Redo the action just undone (Not implemented in this release.)</td>
<td></td>
</tr>
<tr>
<td>New Catalog</td>
<td>Create a new Catalog in the Catalogs section of the Navigation Panel.</td>
<td></td>
</tr>
<tr>
<td>New Category</td>
<td>Create a new Category within a Catalog in the Catalogs section of the Navigation Panel.</td>
<td></td>
</tr>
<tr>
<td>New Content</td>
<td>Create a new Content in the Contents section of the Navigation Panel.</td>
<td></td>
</tr>
<tr>
<td>New Data Source</td>
<td>Create a new Data Source in the Data Sources section of the Navigation Panel.</td>
<td></td>
</tr>
<tr>
<td>New Data Adapter</td>
<td>Create a new Data Adapter in the Data Adapter section of the Navigation Panel.</td>
<td></td>
</tr>
<tr>
<td>New Static Filter</td>
<td>Apply a new Static filter to a Content. This button is only active when you are able to create a static filter.</td>
<td></td>
</tr>
<tr>
<td>New Dynamic Filter</td>
<td>Apply a new Dynamic filter to a Content or Data Adapter. This button is only active when you are able to create a dynamic filter.</td>
<td></td>
</tr>
<tr>
<td>Edit Filter</td>
<td>Edit an existing filter on a Content or Data Adapter. This button is only active when a filter is selected.</td>
<td></td>
</tr>
<tr>
<td>Validate Filter</td>
<td>Check the logic of a filter structure. This button is only active when a filter is selected.</td>
<td></td>
</tr>
<tr>
<td>Batch Geocode</td>
<td>Launch the Batch Geocoding interface. This button is only active if a Content has been selected in the Contents section.</td>
<td></td>
</tr>
<tr>
<td>Access Control</td>
<td>Launch the Access Control dialog box that enables you to grant or deny permissions to a resource.</td>
<td></td>
</tr>
<tr>
<td>Content Search</td>
<td>Launch the Content Search Utility. This button is only active if a Content has been selected in the Contents section.</td>
<td></td>
</tr>
<tr>
<td>Refresh</td>
<td>Refresh a resource definition overwriting any previously unsaved changes. This button is only active if a resource is selected.</td>
<td></td>
</tr>
</tbody>
</table>
Menus

The menus provide a quick access point to all of the Content Manager’s functionality. Some features accessible from the menus are particularly useful, such as the New Content, Data Source, and Data Adapter wizards.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Help</td>
<td>Display the Content Manager version number.</td>
</tr>
</tbody>
</table>

File

<table>
<thead>
<tr>
<th>New</th>
<th>Create a new Domain.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Open an existing Domain.</td>
</tr>
<tr>
<td>Switch Domain</td>
<td>Toggle between open Domains.</td>
</tr>
<tr>
<td>Close</td>
<td>Close the current Domain.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the current resource.</td>
</tr>
<tr>
<td>Save All</td>
<td>Save all changes to all resources.</td>
</tr>
<tr>
<td>Remove</td>
<td>Delete the current open Domain.</td>
</tr>
<tr>
<td>Import</td>
<td>Import a Domain into an empty Domain.</td>
</tr>
<tr>
<td>Export</td>
<td>Export a Domain.</td>
</tr>
<tr>
<td>Register</td>
<td>Register a Domain.</td>
</tr>
<tr>
<td>Recent</td>
<td>Provide a list of recently opened Domains.</td>
</tr>
<tr>
<td>Logout</td>
<td>Log the current user out of the interface.</td>
</tr>
<tr>
<td>Exit</td>
<td>Close the Content Manager.</td>
</tr>
</tbody>
</table>

Edit

<table>
<thead>
<tr>
<th>Undo</th>
<th>Undo the last action. (Not implemented in this release)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redo</td>
<td>Redo the last action. (Not implemented in this release)</td>
</tr>
<tr>
<td>Cut</td>
<td>Remove a resource.</td>
</tr>
<tr>
<td>Copy</td>
<td>Make a copy of a resource.</td>
</tr>
<tr>
<td>Paste</td>
<td>Add a copied resource to a new location.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refresh a resource definition overwriting any previously unsaved changes.</td>
</tr>
<tr>
<td>Delete</td>
<td>Permanently remove a resource.</td>
</tr>
<tr>
<td>Rename</td>
<td>Give a new name to a resource.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Change Owner</strong></td>
<td>Make someone else the owner of a resource.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td>Optionally display the New, Tools, or Filter buttons. Choose to show or hide the toolbar menu.</td>
</tr>
<tr>
<td><strong>Content</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Create a new Content. This is only active when a Data Source has been created.</td>
</tr>
<tr>
<td><strong>Catalog</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Create a new Catalog.</td>
</tr>
<tr>
<td>Add Category</td>
<td>Add a Category to a Catalog. This is only active when a Catalog has been created and the Catalogs section of the Navigation Panel is active.</td>
</tr>
<tr>
<td>Add Content</td>
<td>Add a referenced Content to a Catalog or Category. This is only active when a Catalog has been created and the Catalogs section of the Navigation Panel is active.</td>
</tr>
<tr>
<td><strong>Data Source</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Create a new Data Source.</td>
</tr>
<tr>
<td><strong>Data Adapter</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Create a new Data Adapter.</td>
</tr>
<tr>
<td><strong>Filter</strong></td>
<td></td>
</tr>
<tr>
<td>New</td>
<td>Add a Static or Dynamic filter to a Content.</td>
</tr>
<tr>
<td>Add Operator</td>
<td>Add an operator to an existing filter.</td>
</tr>
<tr>
<td>Edit</td>
<td>Make changes to an existing filter.</td>
</tr>
<tr>
<td>Validate</td>
<td>Check that the syntax in a filter is correct.</td>
</tr>
<tr>
<td><strong>Tools</strong></td>
<td></td>
</tr>
<tr>
<td>Wizards</td>
<td>Access the Data Source, Content, Data Adapter, and Data Transfer wizards.</td>
</tr>
<tr>
<td>Batch Geocode</td>
<td>Launch the Batch Geocode functionality.</td>
</tr>
<tr>
<td>Access Control</td>
<td>Grant or deny access to a resource.</td>
</tr>
<tr>
<td>DAC Configure</td>
<td>Show configurations of the current Domain for accessing data. User cannot load an external configuration in this release.</td>
</tr>
<tr>
<td>Content Search</td>
<td>Launch the Content Search Utility.</td>
</tr>
<tr>
<td>Option</td>
<td>Change preferences in the Console.</td>
</tr>
<tr>
<td><strong>Help</strong></td>
<td></td>
</tr>
</tbody>
</table>
Installation and Configuration

The Content Manager is automatically installed with those Web Services that require data access, such as the Directory, Presentation, and Web Feature Services. By default, its Domain location is resources\CMC where Web Services are installed. For example, C:\MapInfo\resources\CMC. However, the Domain may differ if an alternate location was specified during installation. Please refer to your Envinsa Location Platform Install Guide for details on how to install Web Services, and for information on how to configure the Content Manager.

Refer to Chapter 2: Getting Started with the Content Manager, for information on how to get started once the Content Manager is installed and configured.

Note: If you have a version of the Content Manager from Envinsa 3.0 and are performing an upgrade, be sure to read Appendix A: Migrating From a Previous Version of Envinsa for important installation information.
Getting Started with the Content Manager

This section describes how to get started. It outlines the tasks you will need to perform when first working with the Content Manager.

In this section:

- Understanding Enterprises and Domains .......... 19
- Starting the Content Manager .................... 20
- Planning Your Content Management Structure ....... 22
- Setting Up Enterprises and Domains ............... 23
- Creating User Accounts ............................ 32
Understanding Enterprises and Domains

This chapter outlines how to get started with the Content Manager. It discusses how to start the Console and open the default Domain, and how to organize your data for a company solution. For this you need to fully understand the concepts of Enterprises and Domains, which are the fundamentals of data organization in the Content Manager.

Understanding Enterprises

You may want to set up groups of users who have access to certain Data Sources. You may not want the users in these groups to have access to the information in other groups. To do this, the Envinsa Location Platform uses the concept of Enterprises. When a user account is created, it is prefixed with a token that assigns that user rights to a particular Enterprise. This allows users to access the information only within the Enterprise to which they have been assigned.

If you want to group your users in this way, so they have rights only to specific Enterprises of data, you need to consult with your Envinsa Administrator. You need to work with the Envinsa Administrator to decide how many Enterprises you need to create, and which users need to be assigned to them before you start working with the Content Manager. The Envinsa Administrator can then create the user accounts according to the plan you created, so that the data in your organization remains protected and accessible only to those users who are specifically entitled to use it.

Understanding Domains

A Domain is a repository that hosts all the Content Manager information. It is the highest level of the tree-like structure that logically groups an organization’s data. It is composed of resources stored on a file system, as XML files, or on an LDAP server as small pieces of XML strings.

Domains belong to an Enterprise. The following diagram represents the relationship between an Enterprise and any number of Domains within it.

![Relationship Between Domains within an Enterprise](image)

Domains are all given a unique name in the scope of an Enterprise and all Domains are accessible using this name when they are registered with the Content Manager.
Depending on the account privileges a user has, they may or may not be able to access different Domains. The only person who can access all Domains in any Enterprise is the Administrator. In most cases the user can only access Domains to which they were assigned within the Enterprise when their user account was created in the Enterprise Manager.

Multiple Domains can be created so that you can organize data for different groups or departments. For example, different departments in an organization may use different Domains; Accounting may have one Domain, and Sales another depending on how the Enterprise is structured.

Starting the Content Manager

To start the Content Manager, run the Content Manager start up script located in the CMC folder where Envinsa is installed. For example, C:\MapInfo\resources\CMC. The startup script is called cmcmanager.bat for Windows, or cmcmanager.sh for UNIX. The Content Manager Login window displays.

Note: If you have migrated to Envinsa 4.0 from 3.0, refer to Appendix A: Migrating From a Previous Version of Envinsa for important information about using Contents and Catalogs from 3.0 with this new version.
Logging In

This section assumes you are the Administrator and have read Chapter 1: Introduction, which is important to fully understand all the concepts behind the Content Manager. The Administrator role has access to all the user accounts, data, and Contents.

The first time you use the Content Manager, you are asked for the Content Manager Server location, and its username and password. Choose either Local or find the URL for a remote Content Manager. If you choose Local, the username and password must be one that is already established and propagated to the Content Manager. If you choose a remote Content Manager, the username and password must be established for that remote instance. For more information about the remote capabilities of the Content Manager, refer to Chapter 6: Remote Access. Once a correct username and password has been entered, the main Content Manager displays.

Other users with different privileges may also log in to the Content Manager, but they must first have a User Account created for them in Enterprise Manager. Refer to Creating User Accounts on page 32 for more information.

Opening the Sample Domain

You are provided with a sample Domain, called SampleDomain, in the PUBLIC Enterprise. This Enterprise is PUBLIC so that all users, whether or not they belong to an Enterprise, have access to this Domain.

Once you have opened this sample Domain, and become familiar with its functionality, you can create new Domains for specific Enterprises to organize your data.

To open the sample Domain:

1. Open the PUBLIC Enterprise.
   Click File > Open. The Open Domain dialog box displays.

   ![Open Domain Dialog Box]

2. Select the Sample Domain.
Choose the PUBLIC Enterprise and SampleDomain from the Domain list. The SampleDomain opens in the Content Manager. You will see a list of sample metadata to work with in the Navigation Panel as illustrated here:

**Navigation Panel: sampleDomain**

### Planning Your Content Management Structure

Before you actually start using the Content Manager you should decide how you want to organize and structure your data. You need to decide:

- How many Domains you need to create, and which Enterprises they belong to. Refer to Setting Up Enterprises and Domains on page 23.
- Which people in the organization need a user account and what type of role they should have. Refer to Understanding Domain Access Privileges in Chapter 7 on page 107.
- What, and how much, information specific users can access. Refer to Understanding Resource Access Privileges in Chapter 7 on page 110 for more detailed information.
- Which Data Sources, Data Adapters, and Contents you want to create. Refer to Chapter 3: Creating Resources Using Wizards and Chapter 4: Creating Resources Using Advanced Techniques.
- How you want to organize your resources in a Catalog. Refer to Chapter 8: Creating a Catalog.

**Note:** If you are migrating from Envinsa 3.0, ensure you read Appendix A: Migrating From a Previous Version of Envinsa thoroughly before starting to use the new version.
It is recommended you discuss how Content Manager is set up with the various groups in the organization who will be accessing it. This ensures the requirements specific to your organization are met adequately.

Setting Up Enterprises and Domains

When you have decided how many Enterprises and Domains you need to set up in your organization, you can start to create them. This section outlines the following tasks:

- Creating a New Enterprise
- Creating a New Domain
- Copying a Domain
- De-registering a Domain
- Registering a Domain
- Opening a Domain
- Deleting a Domain
- Closing a Domain
- Saving Your Changes

Creating a New Enterprise

You can create a new Enterprise when you are creating a new Domain. The Enterprise is created by assigning to it the Domain you want to create. When a Domain belongs to an Enterprise, all users (apart from the Administrator) that are not part of that Enterprise are denied access.

**Note:** Only users who have Administrator privileges may create a new Enterprise.

To create a new Enterprise:

2. Enter the name of the Enterprise in the textbox.
3. Continue to fill in the rest of the fields to create a new Domain as outlined in the following section Creating a New Domain on page 24.

**Note:** You can only create an Enterprise when you are creating a Domain.
Creating a New Domain

This section describes how to create a new Domain. If you create a Domain, you become the owner of the Domain, which allows certain privileges as described in Understanding User Roles in Chapter 7 on page 107.

When creating a new Domain, the Enterprise to which a user belongs is assigned all the Domains created by that user. For example, if the user belongs to MyEnterprise1, and has the username User1, then all the Domains created by User1 are assigned to MyEnterprise1. If the user has a user role of Administrator, the Enterprise of the new Domain can be PUBLIC or the one assigned to the user.

**Note:** Only users with Administrator or Data Administrator accounts may create a new Domain.


   ![New Domain Dialog Box](image)

2. Enter the URI.

   This is the location of the new Domain. By default this is a file folder, as shown in the example, but LDAP may also be used.

   For a file folder, use the Browse button (…) and navigate to the directory in which you want to store the folder for the Domain. Type the name of the folder where the Domain is to be created, at the end of the pathname. This action creates the directory that holds the Domain files. See the following example:

   ![Domain Directory Selection](image)

   **Domain Directory Selection**

   The name of the Domain can include any printable characters except: comma (,), forward slash (/), backward slash (/), colon (:), semicolon (;), equals (=), period (.), or quotation marks ("").
If you are using an LDAP URI, you need to supply the following connection information:

- LDAP server name and port number. For example, server name LOCALHOST and port number 389.
- Parent directory in which the new directory is to be created, specified after "o=". This directory must already exist and its type must be "o" (an organization). For example:
  o=envinsa.com
  Where the directory name is envinsa.com.
- Name of the Domain to be created specified after "ou=" (organization unit). For example:
  ou=Domain1
  This creates a new LDAP Domain.
- Login name and password used to connect to the LDAP server.

3. Select an Enterprise.
   Choose an Enterprise from the drop-down list. By default the Enterprise displayed is the one to which you were assigned when your user account was created in Enterprise Manager (as described in Creating User Accounts on page 32). Choose to create the Domain in your own Enterprise, or make it PUBLIC.

   If you are the Administrator, you can create a new Enterprise as described in Creating a New Enterprise on page 23.

   Note: If you do not specify an Enterprise, the Domain is created as public, which lets any user to open it. (The Enterprise is set to PUBLIC, a reserved name of a universally available Enterprise.)

4. Provide a meaningful name for the new Domain.
   The name must be unique.

   Note: The name of the Domain can include any printable characters except: comma (,), forward slash (/), backward slash (/), colon (:), semicolon (;), equals (=), period (.), or quotation marks (").

5. Create the new Domain.
   Click OK. The new Domain is created in the location and Enterprise you specified. The Content Manager automatically registers the new Domain to make it available to services. If you are creating a file-based Domain, a new directory is created in the specified location and filled with appropriate subdirectories to store the Domain’s resources.

   The new Domain is opened automatically after it is created.

Copying a Domain

This section describes how to copy a Domain by importing it. Importing a Domain is a way of redistributing Domains you already have set up within your organization. You can make use of Domains other people have already created, and allow them to make use of Domains you have created. For example, you can copy a Domain from one location on a file system to another location on an LDAP server. You can also use this method to change the owner of a Domain.

In addition to importing a whole Domain, you can also import individual resources. Refer to Copying Resources in Chapter 4 on page 75.
Importing a Domain requires that you first export the Domain you want to copy.

**Exporting a Domain**

To export a Domain:

1. Open the Domain you want to export.
2. Choose File > Export.
   A browse window displays and lets you create a file to export the Domain information.
3. Save the Domain.
   Browse to the location you want to save the Domain. Enter a file name for the Domain. For example, sampleDomain. Click Open.
   A dialog box appears showing that the export has been successful:

   ![Export Domain Message Box](image)

   Click OK to close the message box. The Domain has now been exported and can be imported into a different Domain.

**Importing a Domain**

To import a Domain:

1. Create a new Domain.
   Refer to [Creating a New Domain on page 24](#) for details. The Domain opens automatically in the Content Manager.

   **Note:** This Domain must be empty. If the Domain contains resources, the import operation fails.
2. Choose File > Import.
   A browse window displays.

![Import a Domain Dialog Box]

3. Browse to the XML file you created when exporting the Domain. Click Open.
   A dialog box appears showing that the import was successful:

![Import Domain Dialog Box]

Click OK. The Domain is populated with the imported Domain resources.

De-registering a Domain

After you have created a Domain, it is automatically registered so that it becomes available to all services. At some point, you may want to work on a Domain and do not want services to access it while you are updating it. For example, when setting up a Domain and its Contents. You would de-register the Domain and register it only when it is set up correctly. To take a Domain offline, you need to de-register it. Once a Domain is de-registered, it can no longer be accessed by the Content Manager until it is registered again.

**Note:** Only users with an Administrator account may de-register a Domain. The Data Administrator of an Enterprise may de-register a Domain that belongs to the same Enterprise. If the Domain is PUBLIC, only the Data Administrator who owns the Domain can de-register it.

To de-register a Domain:

1. Choose File > Register. The Domain Register dialog box displays.
2. Select the Enterprise.
   Choose the Enterprise that contains the Domain you want to de-register. After selecting the Enterprise, all the registered Domains within that Enterprise are listed with their corresponding version, name, and URI.
3. De-register the Domain(s).
Domain Register Dialog Box

Highlight the Domain you want to de-register. Click Deregister to de-register it. The de-registered Domain is no longer displayed in the list.

Click Close when done.

Registering a Domain

To make a Domain available in the Content Manager and to any services, you need to register it. You also need to register any Domains you want to migrate from the Envinsa 3.0 Content Manager. Refer to Appendix A: Migrating From a Previous Version of Envinsa for more information on how to do this.

Only users with an Administrator account may register a Domain. The Data Administrator of an Enterprise may register a Domain that belongs to the same Enterprise. If the Domain is PUBLIC, only the Data Administrator who owns the Domain can register it.
To register a Domain:

1. Choose File > Register. The Domain Register dialog box displays.

![Domain Register Dialog Box](image1)

2. Select the Enterprise.
   Choose the Enterprise that contains the Domain you want to register. After selecting the Enterprise, all the previously registered Domains within that Enterprise are listed with their corresponding version, name, and URI.

3. Register the Domain(s).
   Click Register. The Register Domain dialog box displays.

![Register Domain Dialog Box](image2)

You can register Domains from a local or remote Content Manager.

If the Content Manager is on a local server, browse to the location of the Domain directory you want to register on your file system, or enter the LDAP URI. If there are multiple Domains you want to register in a directory, you can browse to the top of the directory and click the Find button. This scans for any unregistered Domains within that URI. If any Domains are found, the OK button is enabled.

If the Content Manager is on a remote server, specify the remote URL of the Content Manager and click the Find button. All the available Domains are then listed and can be registered. You may be asked to be authenticated with a username/password combination.

**Note:** If you are working from a remote Content Manager, only Domains remote to the Console can be registered. Domains that are local to the Content Manager can only be registered from the local machine where the Console resides.
Click OK to register the Domains.

4. Specify a default Domain (optional).
An Enterprise can have one default Domain only. The default Domain is the one to which any resources (Contents, Data Sources, or Data Adapters) you query are assigned unless you explicitly specify a different Domain. Once a default Domain has been defined it cannot be returned to an empty value, it can only be changed to a different default Domain.
Click Close when done.

5. Change the Domain name (optional).
The Domain name can be changed by double clicking on the Domain name column and typing in the new name. Only an Administrator or Data Administrator with write privileges can change the Domain name.

Opening a Domain
This section describes how to open a Domain in the Content Manager.

**Note:** The Administrator has privileges to open any Domain in any Enterprise. Other users can open any PUBLIC Domains, and Domains in any Enterprises to which they belong.

To open a Domain:

1. Choose File > Open (Ctrl-O). The Open Domain dialog box displays.

![Open Domain Dialog Box]

2. Select the Domain to Open.
Choose the Enterprise that contains the Domain you want to open. All the registered Domains within that Enterprise are listed.
By default, the Enterprise you have permissions to, and its default Domain, are automatically selected.

3. Open the Domain.
Click Open. The current Domain displays in the Console title panel.

Switching Domains
You can have multiple Domains open at one time to copy and paste Contents, Data Sources, and Data Adapters between them, or to work on several Domains in one session. To do this, use the Switch feature:

1. Choose File > Switch.
All open Domains are listed, and the Domain currently displayed is marked with a check symbol.
2. Select the Domain you want switch to from the list. The other Domain opens and its path displays in the title panel of the Console.

Deleting a Domain

Deleting a Domain permanently removes it from the disk.

Only users with an Administrator account can delete a Domain. The Data Administrator of an Enterprise may delete a Domain that belongs to the same Enterprise. If the Domain is PUBLIC, only the Data Administrator who owns the Domain can delete it.

To delete a Domain:

1. Make the Domain you want to delete active in the Content Manager. The Content Manager only deletes the Domain that is currently displayed in the Content Manager. If you have multiple Domains open at a time, ensure that the correct one is in focus. Refer to Switching Domains on page 30 for information on how to change the focus between Domains.
2. Choose File > Remove. The current Domain is deleted permanently from the disk.

Closing a Domain

To close a Domain:

1. Switch to the Domain you want to close. Refer to Switching Domains on page 30.
2. Choose File > Close (Ctrl-F4).
3. Save your changes.

If you made changes to the Domain during the session, you are prompted to save them.

The current Domain is closed.

Saving Your Changes

You can save changes to an individual resource, or save all the changes to the Domain in a session. To do this, you use the Save and Save All functionality.

Save Changes to a Resource

To save the changes to a single resource you have modified, choose File > Save, or simply click the Save button.
Save Changes to a Domain
To save all the changes you have made to the Domains you have open, choose File > Save All, or click the Save All button.

Creating User Accounts

Any user wanting to access the Content Manager must have an account. This account is created using the Enterprise Manager security features. Please see your Envinsa Administrator, or refer to the Administration Guide for details on how to create a new user account, or modify an existing account.

There are four types of Content Manager users that can be created using the Enterprise Manager for use in the Content Manager. These are:

- Administrator (example: admin)
- Data Administrator (example: MapInfo.admin)
- User (example: MapInfo.john)
- Guest (example: MapInfo.guest)

Note: User accounts use the format of EnterpriseName.Username.

For more details on what role these users play in the Content Manager, refer to Understanding User Roles in Chapter 7 on page 107.
Creating Resources Using Wizards

This section describes how to create new data content, sources, and adapters.

In this section:

- Understanding Resources
- Workflow for Creating Resources
- Using the Data Source Wizard
- Using the Data Content Wizard
- Using the Data Adapter Wizard
Understanding Resources

There are three types of resources that can be defined using the Content Manager: Data Sources, Data Contents, and Data Adapters.

Understanding Data Sources

A Data Source is metadata that contains information about the source of data that can be directly accessed by a Content. A Data Source provides a way to retrieve and connect to a data repository, such as a database or a TAB file. A Data Source can actually be any source so long as there is a data provider to access that data, such as a Web page. However, you may need to set up a Data Adapter to convert this Data Source into a format supported by the Envinsa Services.

Understanding Contents

A Content is a logical view of data stored in Data Sources, such as Oracle, MapInfo tables, third party systems, or through live feeds. The purpose of a Content is to provide one consistent view of various data formats across all Envinsa services. This allows data consumers, or applications, to focus on the information provided from the data rather than dealing with lower level data access management, such as making connections and queries to get the information they need.

Contents can be organized into a form of a directory called a Catalog with sub-folders called Categories. This organization provides a logical way to navigate the information available to them. Refer to Understanding Catalogs in Chapter 8 on page 116 for more information.

Understanding Data Adapters

A Data Adapter converts external data into the correct format for the Content Manager to use. It is required when an external Data Source is either not supported by, or not accessible by the Envinsa Location Platform. A Data Adapter defines how to feed data from an external source that is remote and unknown, such as a Web server on the Internet.

The data you want to use may not be accessible when it is in a format that is not recognized by the Content Manager, such as an XML file from a Web page. The Data Adapter knows how to convert the information you want and how to get that data into the required format for your data repository.

For example, a customer may have data that resides on a Siebel system that is not directly accessible by the Envinsa Location Platform using the J2EE JDBC interface. In this case, you can set up a custom Data Adapter with special logic to gain access to the Siebel system. The adapter may also translate and transmit data in proprietary Seibel format to the format that Envinsa can work with, such as MapInfo tables, Oracle tables, and SQL Server tables.

Types of data that would use a Data Adapter are dynamic data, such as traffic data feeds or weather providers. An example of how a Data Adapter could be used is for an up-to-the-minute sport Web site giving information about baseball game scores. In this example, the Baseball Score is the data content. You would receive XML updates, parse the data into routines, and translate the information into the required format for the Content. The Data Adapter can translate the data into the form the Baseball Score Content requires for up-to-the-minute scores.
A common use of data that requires an adapter is in routing. If there is a car accident or break-down on a particular road, a dynamic traffic data feed can be processed to provide an alternative route. You can be made aware of the accident and shown the alternative route so you can avoid that area on your journey.

Data adapters may also be useful if you are accessing a database of information you do not want to store in-house. For example, when purchasing various pieces of information as and when you need them rather than purchasing the whole dataset for your organization.

**Workflow for Creating Resources**

The first task in the Content Manager is to create a new Data Source. You can then create new Contents for this source. Once you have the initial Data Source set up, you can create Contents that reference this Data Source, and set up more Data Adapters and Data Sources as and when you need them.

After you have added Data Sources, Contents, and Data Adapters, you can organize the Contents you have created into Catalogs and Categories in a tree structure directory of information. Refer to Chapter 8: Creating a Catalog for information on how to do this.

The following sections highlight the resources you can create in the Content Manager to expose your data. Refer to the individual sections for more detailed information about creating each one.

- Define a Data Source
- Create a Content
- Set up a Data Adapter
- Refresh Resources

**Define a Data Source**

Defining a Data Source is the first operation to perform using the Content Manager. It is the foundation of all the Content Manager functionality.

There are two ways to create a Data Source using the Content Manager interface. Refer to the following sections for further information:

- **Using the Data Source Wizard on page 36** – This section takes you through the steps required to create a Data Source using the wizard. It is recommended you use this option the first time you use the Content Manager.

- **Creating a Data Source (Advanced) in Chapter 4 on page 49** – This section describes creating a Data Source without the help of a wizard. It provides information about all the options available to you to set up a Data Source. This option is recommended for more advanced users.
Create a Content

Once you have defined a Data Source you can set up Contents.

There are two ways to create a Content using the Content Manager. Refer to the following sections for further information:

- **Using the Data Content Wizard on page 40** – This section takes you through the all steps required to create a Content. It is recommended to use this option when starting out with the Content Manager.
- **Creating a Data Content (Advanced) in Chapter 4 on page 58** – This section describes creating a Content without the help of a wizard. It guides you through the all steps and provides information about all your options. This option is recommended for more advanced users.

Set up a Data Adapter

Setting up a Data Adapter requires both a Data Source and a Content be created.

There are two ways to create a Data Adapter using the Content Manager. Refer to the following sections for further information:

- **Using the Data Adapter Wizard on page 44** – This section takes you through the all steps required to create a Data Adapter. It is recommended to use this option when starting out with the Content Manager.
- **Creating a Data Adapter (Advanced) in Chapter 4 on page 63** – This section describes creating a Data Adapter without the help of a wizard. It guides you through the all steps and provides information about all your options. This option is recommended for more advanced users.

Refresh Resources

Once a change is made in a resources (Content, Data Source) it can be discarded by choosing the Refresh option. This feature is also useful to see changes made by another user to one of the resources currently being viewed. Note that Catalogs cannot be refreshed.

There are three ways to trigger a refresh:

- Click on the Refresh button.
- Right-click on a resource and choose Refresh.
- Select Refresh from the Edit menu.

Using the Data Source Wizard

Creating a Data Source is the first task when using the Content Manager. Content Manager is set up so that you must create a Data Source before trying to create Contents or Data Adapters; these options are grayed out in Content Manager until you have created a Data Source.
A Data Source is metadata that contains information about a source of data (such as a TAB file, or an Oracle database) that can be accessed by the Content Manager. Once this initial Data Source is registered, Contents can be created based on that Data Source. For more information on Data Sources and Contents, refer to **Understanding Resources on page 34**.

This section describes how to create a Data Source using the Data Source Wizard. There are up to eight steps in the wizard, depending on the options you choose. It is recommended that you use the wizard when first starting out with the Content Manager. As you become more familiar with Content Manager, optionally choose to create a Data Source without using a wizard to help you. For information on creating a Data Source without using a wizard, refer to **Creating a Data Adapter (Advanced) in Chapter 4 on page 63**.

The wizard provides different options if you are creating a Data Source based on a file Data Source, such as MapInfo TAB files, or a DataBase Management System (DBMS) Data Source, such as Oracle. Follow the instructions for the type of Data Source you want to set up:

- **Creating a Data Source from a File** – This may be a MapInfo Tab File (TAB).
- **Creating a Data Source from a DBMS** – This is for data stored in a DBMS. All major DBMSs are supported, including Oracle and SQL Server.

**Creating a Data Source from a File**

Creating a Data Source from a file involves four steps. To create a Data Source from a file using the wizard:

1. Start the Wizard.
   Select Tools > Wizards > Data Source Wizard.

2. Select the type of Data Source.
   Select File Data Source and click Next.
   Enter the location of the Data Source. The Data Source location is the directory where the files are located.

   ![Data Source Wizard for File: Step 2](Image)

   **Data Source Wizard for File: Step 2**

   Enter the directory path of the TAB files, or Browse to the location of the directory. You only need to browse to the directory level, not to the actual files.

   **Note:** The files must be stored locally.

   Click Next.

3. Enter a name for the Data Source.
Input the name you want to use for the Data Source. This name must be unique. It is recommended you use a name based on the original source data you are using.

**Note:** The name can include any printable characters except: comma (,), forward slash (/), backward slash (/), colon (:), semicolon (;), equals (=), period (.), or quotation marks (").

In this example, the source data is based on World source files. Click Next.

![Data Source Wizard from File: Step 3](image)

4. Test the Data Source.
   Click the Test button to confirm that the Data Source has been set up successfully. If the Data Source is not successfully verified, click Back to review that the location of the Data Source is correct.

5. Finish creating the Data Source.
   Click Finish. The wizard closes, and the new Data Source is added to the list of available Data Sources in the left-hand panel.

![Navigation Panel: New File Data Source](image)

You may now continue to create Contents based on this Data Source. Refer to Using the Data Content Wizard on page 40 for further information on how to do this.

## Creating a Data Source from a DBMS

**Note:** If you are creating a Data Source from a DBMS, note that the database must be case insensitive.

1. Start the Wizard.
   Select Tools > Wizards > Data Source Wizard.

2. Select the type of Data Source.
   Select DBMS Data Source and click Next.

3. Select the database type.
   Choose the type of database your source data is stored in from the list provided. Choose from Oracle, SQL Server, and a Generic JDBC XY format. Click Next.
4. Enter the database name.
   Specify the name of the database instance where the source data is stored in the DBMS. Click Next.

5. Provide connection information.
   Enter the host name, port, user name, and password of the database. Consult your database administrator for the appropriate values for these parameters.

6. Enter the driver class and URL.
   Enter the driver class for the database and the URL for the database. Consult with your database administrator for further information.

7. Specify additional parameters.
   In some cases it is necessary to provide additional parameters to connect to the database. For example, if you are using a custom data provider that requires additional connection parameters, or if you are using a customized JDBC connection. Enter the parameter you need to add, and specify the value from the list of options provided.

8. Enter a name for the Data Source.
   Input the name you want to use for the Data Source. This name must be unique. It is recommended you use a name based on the original source data you are using.
Note: The name can include any printable characters except: comma (,), forward slash (/), backward slash (\), colon (:), semicolon (;), equals (=), period (.), or quotation marks (").

Click Next.

9. Test the Data Source.
Click the Test button to confirm that the Data Source has been set up successfully. If the Data Source is not verified successfully, click Back to review the location of the Data Source.

10. Finish creating the Data Source.
Click Finish. The wizard closes, and the new Data Source is added to the list of available Data Sources in the left-hand panel.

Navigation Panel: New DBMS Data Source
You may now continue to create Contents based on this Data Source. Refer to Using the Data Content Wizard on page 40 for further information on how to do this.

You may want to set up Connection Pool information for your Data Source. Refer to step 7 in Creating a Data Source (Advanced) in Chapter 4 on page 49 for more detailed information.

Using the Data Content Wizard

After you have a Data Source set up with the Content Manager, you can create a Content based on that Data Source. You cannot create a Content without having first created a Data Source.

For a description of a Content, refer to Understanding Resources on page 34.

This section describes how to create a data content using the Create Content Wizard. There are up to 12 steps in the wizard, depending on the options you choose. It is recommended that you use the wizard when first starting out with the Content Manager. As you become more familiar with Content Manager, you can choose to create a Content without using a wizard to help you. For information on creating a Content without using a wizard, refer to Creating a Data Content (Advanced) in Chapter 4 on page 58.

Note: You must have created at least one Data Source to be able to create a Content.

To create a Content using the wizard:

1. Start the Wizard.
   Select Tools > Wizards > Content Wizard to launch the wizard.

2. Select a Data Source.
Content Manager Guide Chapter 3: Creating Resources Using Wizards

Content Wizard: Step 1
Select a Data Source from the list of Data Sources you have previously created. If no Data Source exists for the data content you want to create, click New Data Source. This launches the Data Source Wizard. For information on how to create a new Data Source refer to **Using the Data Source Wizard on page 36**.

Click Next when you have selected the Data Source.

3. Choose a table from which you want to select columns.
Attributes for the Content come from all, or some of, the columns in the table you select in this dialog box. This table comes from the Data Source you previously created.

Click Next.

4. Select columns to use as Content attributes.

Content Wizard: Step 3
The columns from the table you selected in **step 3** are displayed in the left-hand window. Select the columns you want to use in this window and click the right-arrow button (>) to select them to use as Content Attributes in the Content you are creating. Each column you select displays in the right-hand window.

You do not need to select all the columns from the Data Source to create the Content. Select as many as you want to display to users. A Data Source may have many Contents created on it for different users who need to use the data in different ways. One user may require that a Content contains very different information from another Content created on the same source table.
For example, there may be fifty columns in a particular TAB file, but the user only requires four of those columns. You would select only those four columns from the fifty available when you create the Content. The Data Source is not affected.

**Note:** If you have a style column from a TAB file (MI_STYLE), do not include it as an attribute. If you are using x,y columns, do not include these columns as attributes either.

Click Next.

5. Select a spatial column, create a new one, or select to create a non-spatial Content.
This step of the wizard indicates if any columns in the source table can be selected as a geometry column. Choose one of the existing geometry columns to use as a spatial column for the Content, or opt to create a new spatial column using numerical (x,y) columns from the table. If you choose Non-Spatial Content, skip to step 9. Click Next.

6. Select the spatial or geometry column.
In the previous step, if you chose to use an existing geometry column as the spatial column, specify the name of the geometry column you want to use.
If you chose to create a new spatial column, specify the two numerical columns x,y (Longitude/Latitude) columns in the source table to form the spatial column.
Click Next.

7. Specify the coordinate systems.

    ![Image of Content Wizard: Step 6]

    **Content Wizard: Step 6**
    Choose the coordinate system of the column(s) you specified as the spatial column. Optionally, choose a coordinate system for the results of searches performed on the Content. Click Next.

8. Specify a name for the spatial column.
Enter the name you want to use for the spatial column. If you are using an x,y column you must specify the name, if you are using the geometry column, this entry can be left blank indicating that the name remains the same. Click Next.

9. Create a static filter (optional).
This dialog box gives you the option of creating a static filter on the Content you are creating. Creating a static filter is optional. If you choose not to create a static filter now, you can easily create one after you have set up the data content.
For information on static filters, refer to *Introduction to Data Querying in Chapter 5 on page 78.*

Click Next. If you decided to skip creating a static filter, go to step 11. If you chose to create a static filter, continue to the next step.

**10. Define the static filter.**

This dialog box only displays if you chose to create a static filter in the previous step.

![Content Wizard: Step 9](image)

Before creating the static filter, ensure you have referred to the filters section in *Chapter 5: Querying Your Data.* This chapter provides detailed descriptions of the operators you can select, and how they constrain the data.

Select a column on which you want to create the static filter. Select an operator from the list provided, and enter a value to use as the filter criteria. As you choose the columns and operators, a non-editable SQL representation of the expression is constructed in the textbox.

**Note:** While you can create a static filter without using the filter editor, it is recommended that you use the built-in editor as it provides value-type validation.

Click Next.

**11. Enter a name for the Content.**

Input the unique name you want to use for the Content. It may be a descriptive name.

Click Next.

The name can include any printable characters except: comma (,), forward slash (/), backward slash (/), colon (:), semicolon (;), equals (=), period (.), or quotation marks (").

**12. Finish creating the Content.**

Click Finish. The wizard closes, and the new Content is added to the list of available Contents in the left-hand panel.
Using the Data Adapter Wizard

A Data Adapter converts external data into the correct format for the Content Manager to use. It is required when an external Data Source is not supported by the Envinsa Location Platform. A Data Adapter defines how to feed data from an external source that is remote and unknown such as a Web server on the Internet.

For a description of a Data Adapter, refer to Understanding Resources on page 34.

This section describes how to create a Data Adapter using the Create Data Adapter Wizard. There are up to 10 steps in the wizard, depending on the options you choose. It is recommended that you use the wizard when you are first starting out with Content Manager. When you are more familiar with Content Manager, you can create a Data Adapter without using a wizard to help you. For information on creating a Data Adapter without using a wizard, refer to Creating a Data Adapter (Advanced) in Chapter 4 on page 63.

To create a Data Adapter using the wizard:

1. Create a reference to a Content for the Data Adapter to use.
   Before you start to create a Data Adapter, you must ensure you have already created a reference to a Content in a Catalog into which you can import the data from the external Data Source. To create a reference to a Content, refer to Creating a Reference to a Content in Chapter 8 on page 120.

2. Start the Wizard.
   Select Tools > Wizards > Data Adapter Wizard to launch the wizard.
3. Select a Content.
   The Data Adapter you are setting up imports data from the external Data Source you want to use. Select the Content into which you want to import the data from the drop-down list. Click Next.

4. Select the type of data provider for the Data Adapter.
   Choose to use a default data provider, or a user-defined one.

5. Select a Data Source.
   If you are using a default data provider, you need to select a Data Source from the list. If you are using a user-defined data provider, it may or may not be necessary depending on the provider you are using.
   Click Next. If you are using a default data provider, go to step 9. If you are using a user-defined Data Source, go on to the next step.

6. Specify the class name.

7. When using a user-defined data provider, you need to provide the full name of the provider's implementation class and any additional properties the provider may need.

8. Edit the data connection properties.
   You can edit the connection properties by double-clicking in the Value field associated with the property. You should provide a Value for each connection property.
**Note:** In order to test and use the user-defined provider, place the jar file that carries the provider’s implementation into the lib directory of your Content Manager installation (default path is \Envinsa-Installation\DataDomain\CMC\lib) before starting Content Manager. If the file is not present, a ‘Class not found’ exception is returned.

Click Next.

9. Choose the table.
Select the table that contains the source data you want to use. Click Next.

10. Map the attributes.
You need to map attributes from the Data Source you are using with those in the referenced Content, so that data from the Data Source is entered in the correct column in the referenced Content.

Data Source Wizard: Mapping Attributes
Double-click on the Source Attribute fields and select a column from the list provided from the source table you selected in step 9. Click Next.

11. Specify the update frequency.
Choose how often you want the data in the referenced Content to be updated by the Data Source. Choose from milliseconds to years. For example 30 seconds would update the data in the Content every 30 seconds, which might be useful for live traffic feeds. One week would update the data once a week.

Data Source Wizard: Specify the Update Frequency
If you want to update the data each time the Data Adapter starts, select the Update Once checkbox. Click Next.
12. Enter a name for the Data Adapter.
   Input the unique name you want to use for the Data Adapter. It may be a descriptive name that
   provides some information about the underlying Data Source. Click Next.

   **Note:** The name can include any printable characters except: comma (,), forward slash (/),
   backward slash (\), colon (:), semicolon (;), equals (=), period (.), or quotation marks (").

13. Test the connection.
   When you have entered all the information about the Data Adapter, click the Test button. This
   verifies that the connection information to the data provider has been set up successfully.

14. Finish creating the Data Adapter.
   Click Finish. The wizard closes, and the new Data Adapter is added to the list of Data Adapters
   in the left-hand panel.
Creating Resources Using Advanced Techniques

This section describes how to create new data content, sources, and adapters without the use of wizards.

In this section:

- Getting Started ................................................. 49
- Creating a Data Source (Advanced) ...................... 49
- Examples of Setting Up Data Sources .................... 53
- Creating a Data Content (Advanced) ...................... 58
- Creating a Data Adapter (Advanced) ...................... 63
- Exposing Your Data Through WFS ....................... 66
- Copying Resources .......................................... 75
Getting Started

This section provides instructions for advanced users on how to create resources in the Content Manager. If you are just starting out with Content Manager, refer to Chapter 3: Creating Resources Using Wizards, which provides instructions on how to create resources using wizards.

This section provides advanced instructions on the following:

- Creating a Data Source (Advanced)
- Creating a Data Content (Advanced)
- Creating a Data Adapter (Advanced)

For more information that explains these resources, refer to Understanding Resources in Chapter 3 on page 34.

Creating a Data Source (Advanced)

This section describes how to create a Data Source independently of the Data Source Wizard. The wizard provides step-by-step instructions. However as you become more familiar with the Content Manager interface you may want the flexibility of creating a Data Source without using the wizard.

For alternative instructions for setting up a Data Source using the wizard, refer to Using the Data Source Wizard in Chapter 3 on page 36.

To create a Data Source without using the wizard:

1. Highlight the Data Source folder in the left-hand panel.
2. Create the Data Source.
   - There are three ways to create a new Data Source in the Content Manager interface:
     - Click the New Data Source button in the toolbar:
       
       ![New Data Source Button]
     - Choose Data Source > New from the menu.
     - Right-click on the Data Source folder in the left-hand panel and choose New > Data Source.
3. Enter a unique name for the Data Source in the Input dialog box.
   - The Data Source name must be unique to identify it from the other Data Sources in the Domain. Click OK.
   - The new Data Source is added to the list of available Data Sources in the left-hand panel.
4. Define the Data Source.

When you have created a new Data Source, you need to define it in the Information panel in the main area of Content Manager. This is where you can specify the type of the Data Source, the connection parameters, and see an XML view of the Data Source information.

**Information Panel: New Data Source**

There are four main types of information about the Data Source you are creating that you might want to set. Which options you set depends on the specifics of the Data Source you are using:

- **Data Source Description** – This lets you specify a more meaningful description for the Data Source.
- **Resource Tag** – A way to categorize the resources by keyword.
- **Data Source Type** – This specifies the type of Data Source to which you are connecting. This can be a DBMS, such as SQL Server, or a TAB file.
- **Connection Information** – This is where you provide information about how to connect to the Data Source.
- **Connection Pool Information** – Lets you enable a pooling framework for data access component connections.

5. Provide a Description for the Data Source (optional).

The description of a Data Source is where you can enter more detailed and meaningful information about the Data Source you are creating. It can be a short description of the type of information contained in the Data Source. By default the new Data Source has a description of “New Data Source.” Simply type in the description of the Data Source you want.

The example shown here uses the Canadian Landmark Data Source in the SampleDomain provided with Content Manager. In this case the description is:

Canadian Landmark, MapInfo TAB File
This gives information about both the type and name of the Data Source.

6. **Select a Data Source Type.**

   The Data Source can be based on a DBMS or a File connection. Select the type of connection you are using. Notice that the fields in the Connection tab at the bottom of the Information panel change depending on the Data Source type you are using; there are many more fields for a DBMS connection than for a TAB file, and different databases require different connection information.

   Choose from MapInfo TAB file(s) or three database options: Generic XY JDBC, Oracle, and SQL Server. Refer to *Examples of Setting Up Data Sources on page 53* for specific information about setting up Data Sources for these different types of database.

   **Note:** If you select a DBMS as the Data Source type, note that the database must be case insensitive.

7. **Set the connection information in the Connection tab.**

   Once you have selected the type of connection you are using to create the Data Source, you need to fill in all the connection information about it. Complete the following fields:

   - **Database or File URL** – The URL of the file or database of the Data Source you want to use. Enter the directory path of the TAB files, or Browse to the location of the directory stored locally on your machine. You only need to browse to the directory level, not to the actual files.
   
   - **Hostname, host port, database name/SID, username, password, and driver class information** for database connections. Consult your database administrator for appropriate values for these parameters.

8. **Add a Connection Parameter (optional).**

   You may need to set parameters to connect to the Data Source you are creating. This is necessary if you are using a custom data provider that requires additional connection parameters, or if you are using a customized JDBC connection. To do this, click the Add button in the bottom right-hand corner of the Information panel. Input the name of the parameter you want to add and its associated Value. Click OK.

   The new parameter is added to the list of parameters in the Information panel.

9. **Edit the parameter values (optional).**

   If you added a parameter in the previous step, edit the value. To do this, simply double-click the Value field of the parameter to enter the new value you want to assign.

10. **Set the connection pool information.**

    The Connection Pool tab allows Data Access Component (DAC) connections to be cached by a pooling framework. These connections can then be reused by the framework, often saving significant amounts of time usually spent establishing connections to a resource.

    The overhead associated with connections is especially significant for remote database connections to Oracle and SQL Server. Connection times required by the underlying JDBC driver vary, but can form a significant percentage of time when handling a Web Feature Service request.
Connection pooling is supported for all Data Sources, including TAB, or external data providers.

**Information Panel: Connection Pool**

The following points describe the connection pool parameters you can set:

- **Number of Initialized Connections** – This is the number of connections that will be opened by the framework in a given pool when a pool is created. When zero, no connections are created during pool creation.

- **Maximum Number of Connections** – This is the maximum number of connections in the pool. Optionally set this to unlimited connections; doing this grays out the Pool Exhausted Behavior box.

- **Inactive Connection Timeout** – This is the minimum time a connection can be idle before it is eligible for eviction due to idle time. When zero, no connection is dropped from the pool, based on idle time. Optionally set this to Unlimited to keep inactive connections open.

- **Pool Exhausted Behavior** – This controls the behavior when the number of busy connections has reached that set in the Maximum Number of Connections box. Choose from the following options:
  - **FAIL** – This causes an exception to be thrown by the framework if a request for a connection is made when the pool is exhausted.
  - **WAIT** – The allows you to set a maximum time, in seconds, that the framework will wait for a connection when the pool is exhausted. This option is not available when the Maximum Number of Connections is set to Unlimited.

- **Maximum Number of Idle Connections** – Controls the number of connections that can be idle at any time.

- **Eviction Run Frequency** – Sets how long the eviction thread should wait before examining idle connections. When set to zero, no evictions are performed.

- **Never Run** – When enabled no evictions are performed.

11. Test the connection.

When you have entered all the information about the Data Source, click the Test button. This ensures the Data Source can be accessed successfully using the connection information you have supplied. For example, it checks that passwords are correct, and any file system paths actually exist. If the connection test is unsuccessful the test fails. You should check that the information you provided in the fields is accurate.
Note: The Test button does not verify the existence of a specific table that may be the Data Source. This allows an administrator to create the link to the Data Source in the Content Manager and then populate the Data Source using the Data Transfer Wizard (refer to Data Uploading in Chapter 6 on page 104).

12. Save the changes.
   Click Save to complete the changes you have made to the Data Source.

Examples of Setting Up Data Sources

The following examples describe how to set up Data Sources for the following:

- Setting up a TAB Data Source
- Setting up an Oracle Data Source Using the Oracle JDBC Driver
- Setting up a SQL Server Data Source Using the MicroSoft SQL Server JDBC Driver
- Setting up a Generic JDBC XY Data Source

Setting up a TAB Data Source

This example shows how to set up a Data Source for TAB file(s).

1. Select Data Source > New from the main menu.
2. Select TAB as the Data Source Type from the drop-down box.
3. Enter the location of the directory containing the TAB file(s) to connect to in the connection TAB. Alternatively, browse to the folder using the "..." button next to the File URL box.

4. Test the connection using the Test button.

5. Set up the connection pool. Refer to step 10 in Creating a Data Source (Advanced) on page 49.

Setting up an Oracle Data Source Using the Oracle JDBC Driver

This example shows how to set up a Data Source for an Oracle database using the Oracle JDBC driver.

1. Install the Oracle JDBC driver.
   Download the Oracle JDBC driver from http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html. It is recommended that you install the Oracle 9i R2 (or higher) driver. The file is called ojdbc14.jar
   
   Note: If the file is named ojdbc14.zip, merely rename the file to ojdbc14.jar.
   Copy the driver to <Envinsa Install directory>\Envinsa-4.0\DataDomain\CMC\lib and restart the Content Manager.
   The file should also be placed into the CMS\WEB-INF\lib directory of the appropriate Web server in order for the remote login to work with your Oracle Data Source.

2. Select Data Source > New from the main menu.

3. Select Oracle as the Data Source Type from the drop-down box.
   The following default values are populated when a new Oracle Data Source is created.
4. Enter values for Host Name, Host Port, SID, and username and password. Refer to your Oracle administrator for appropriate values for these parameters.

5. The database URL represents the JDBC Connection String that is sent to the underlying JDBC driver. For most purposes you can leave this entry as is. Advanced users can alter the connection string as per Oracle JDBC driver documentation.

6. Test the connection using the Test button.

7. Set up the connection pool. Refer to step 10 in Creating a Data Source (Advanced) on page 49.

**Note:** Do not edit the Driver Class entry. This is the name of the underlying Oracle JDBC driver. The current version of Envinsa is certified with the Oracle JDBC driver (oracle.jdbc.driver.OracleDriver).

---

### Setting up a SQL Server Data Source Using the MicroSoft SQL Server JDBC Driver

This example shows how to set up a Data Source for a SQL Server database using the MicroSoft SQL Server JDBC driver.

1. Install the MicroSoft SQL Server JDBC driver.
   - Copy the drivers to `<Envinsa Install Directory>\resources\CMC\lib` and restart the Content Manager.

2. Select Data Source > New from the main menu.
   - Select SQL Server as the Data Source Type from the drop-down box.
The following default values are populated when a new SQL Server Data Source is created.

3. Enter appropriate values for Host Name, Host Port, SID, and username and password. Refer to your database administrator for appropriate values for the above parameters.

4. The Database URL represents the JDBC Connection String that is sent to the underlying JDBC Driver. For most purposes you can leave this entry as is. Advanced users may alter the connection String as per Microsoft JDBC Driver documentation.

5. Test the connection using the Test button.

6. Set up the connection pool. Refer to step 10 in Creating a Data Source (Advanced) on page 49.

Setting up a Generic JDBC XY Data Source

This Data Source can be used to connect to any JDBC Data source for defining Contents that use Point stored as x,y (Longitude/Latitude) values in JDBC Data sources.

1. Install the JDBC driver.
   Install the appropriate JDBC Driver in the \<Envinsa Install Directory\>\resources\CMC\lib directory.

2. Select Data Source > New from the main menu.

3. Select Generic JDBC XY as the Data Source Type from the drop-down box.
4. Consult the JDBC Driver documentation to enter the JDBC Connection string in the Database URL edit box.

5. Enter the Username and Password as applicable to the Data Source to which you are connecting.

   **Note:** Some JDBC Sources do not require a username or password.

6. The driver class is mandatory for JDBC sources, and represents the name of the Java class that implements the JDBC driver. Consult the JDBC Documentation for the appropriate value.

7. Test the connection using the Test button.

8. Set up the connection pool. Refer to step 10 in Creating a Data Source (Advanced) on page 49.

**Defining Additional Driver Properties for JDBC Sources**

These parameter and value pairs are sent as JDBC Connection properties to the underlying JDBC driver. Refer to your Oracle JDBC Driver documentation for a list of supported connection properties.

For adding connection properties, click Add and enter the Parameter name and value.
Once the parameter names and values have been entered, the values can be edited by clicking on the value box of a property.

Parameters can be deleted by selecting the parameter and clicking Delete.

Creating a Data Content (Advanced)

After you have a Data Source set up with the Content Manager, you can create a Content based on that Data Source. You cannot create a Content without a Data Source.

This section describes how to create a Data Content independently of the Content Wizard. The wizard provides step-by-step instructions. However as you become more familiar with the Content Manager interface, you may want the flexibility of creating a Content without using the wizard.

**Note:** The settings in the Content definition should match the settings of the Data Source on which the Content is based.

For alternative instructions of setting up a Content using the wizard, refer to Using the Data Content Wizard in Chapter 3 on page 40.

To create a Content without using the wizard:

1. Highlight the Contents folder in the left-hand panel.
2. Create the Content.
   
   There are three ways to create a new Content in the Content Manager interface:
   
   - Click the New Content button in the toolbar:

   ![New Content Button](image)

   - Choose Content > New from the menu.
   - Right-click on the Contents folder in the left-hand panel and choose New > Content.
3. Enter the name for the Content in the Input dialog box.
   
   The Content name must be unique to identify it from the other Contents in the Domain. Click OK.

   **Note:** The name can include any printable characters except: comma (,), forward slash (/), backward slash (/), colon (:), semicolon (;), equals (=), period (.), or quotation marks (").

   The new Content is added to the list of available Contents in the left-hand panel.
4. Define the Content.

When you have created a new Content, you need to define it in the Information panel in the main area of Content Manager. This is where you specify how the Content is set up: the Data Source it is based on, the spatial column, and any filters or direct queries to apply to the Content.

<table>
<thead>
<tr>
<th>Resource Name</th>
<th>Alberta Landmarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Type</td>
<td>Data Content</td>
</tr>
<tr>
<td>Full Path</td>
<td>Alberta Landmarks</td>
</tr>
<tr>
<td>Description</td>
<td>Alberta Landmarks</td>
</tr>
<tr>
<td>Resource Tag</td>
<td>Landmarks</td>
</tr>
<tr>
<td>Data Source</td>
<td>Canadian Landmarks</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attribute</th>
<th>SpatialColumn</th>
<th>Filters</th>
<th>Direct Queries</th>
<th>XML View</th>
</tr>
</thead>
<tbody>
<tr>
<td>No.</td>
<td>Name</td>
<td>Type</td>
<td>Primary Key</td>
<td>Source Table</td>
</tr>
<tr>
<td>1</td>
<td>ID</td>
<td>int</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>2</td>
<td>Landmark Name</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>3</td>
<td>Province</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>4</td>
<td>Regional District</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>5</td>
<td>Area Name</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>6</td>
<td>Regional District Code</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>7</td>
<td>Area Code</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>8</td>
<td>Latitude</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>9</td>
<td>Longitude</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
<tr>
<td>10</td>
<td>Landmark Code</td>
<td>string</td>
<td></td>
<td>conradah</td>
</tr>
</tbody>
</table>

Information Panel: New Content

There are seven main types of information you can set for the Content. Depending on your data, you may not need to specify all the available settings.

- Content Description – This allows you to specify a more meaningful description for the Content.
- Resource Tag – A way to categorize the resources by keyword.
• **Data Source** – This is where you specify the Data Source on which you want to create the Content. You must have a Data Source to create a Content.

• **Attributes** – This is the number of columns that will be returned in a search on the Content. For example, a table may have five columns, but only two columns contain relevant information. Remove all the attributes you do not want to use when searching the Content.

• **Spatial Column** – The spatial column may be specified in the source table to allow the Content to be searchable. The Content Manager can also search on non-spatial columns.

• **Filters** – This tab displays any filters that are applied to the Content. You can add a filter to a Content here, or edit an existing one. You may want to set up a filter to search a geographic area for a particular parameter on the fly. For this you would create a spatial dynamic filter.

• **Direct Queries** – Use this area to write a direct query in SQL to query the specific parts of the Content you require. Creating a direct query is much more flexible than constraining your data based on filters.

• **XML View** – This provides a view of the Content definition in XML format.

5. **Provide a description for the Content (optional).**
   The description of a Content is where you can enter more detailed and meaningful information about the Content you are creating. It can be a short description of the type of information contained in the Content. By default, the new Content has a description of “This is a new data content.” Simply type in the description of the Content.
   For example, the DC Child Day Care Services Content provided in the SampleDomain supplied with the Content Manager has the following description:

   Washington DC Area Day Care Services

6. **Provide a Resource Tag.**
   You can categorize the Content by supplying a resource tag. This is a type of keyword that groups data based on the type of information they carry. For example, DC Child Day Care Services is tagged as Child Care, C Landmark is tagged as Landmark, and DC Travel Agencies is tagged as Travel Agency. This method of tagging the resource allows them to be listed easily no matter where they are in the Domain.

7. **Select the Data Source.**
   A Content is based on a specific Data Source. Choose a Data Source you created from the list provided.

8. **Set up a Live Connection (optional).**
   It is recommended, although not required, that you select the Live Connection checkbox in the information panel when you are defining the new Content. Once you select the Live Connection checkbox, the Content Manager sets up an active link with the underlying Data Source on which the Content is based. Once this is connected, the fields in the Information panel are populated from the fields in the tables in the Data Source. If you do not make a live connection you must input the column names from the table manually which creates an opportunity for error.

   The downside to setting up a live connection is that it has the potential to be slow as the Content Manager is linking with the Data Source. This may have some effect on the speed of the Content Manager depending on how your system is set up. For this reason, it is recommended you use a Live Connection only when creating or editing Contents.

9. **Select a table name.**
Choose or enter a table name from the list provided.

If you are using the Live Connection mode, this table name list is populated with the available tables from the Data Source you chose in step 7. The Content attributes in the Attributes tab also change according to the columns in the table you select.

10. Organize the Content attributes.

Select the Attribute tab to display the Content attributes. There are six elements that describe Content attributes:

- **No.** – This is a unique number that indicates the order of the attributes in the Content.
- **Alias** – This is the name of each attribute defined for the Content. This is, by default, the same name as the Source Column in the table on which it is based. However it can be changed to display a different name for the underlying columns without modifying the Data Source. This can be used when the underlying column names are not meaningful to the end user.
  
  In the Manitoba Landmark Content provided in the SampleDomain, the Alias names display the meaning in the information provided in the source columns. For example, Name is the Landmark Name, and the A1_Name is the Province column.

- **Type** – The data type of each attribute in the source table. For example, int, string, and float.
- **Primary Key** – There is only one primary key per Content. This unique identifying key can be specified by selecting the appropriate checkbox. Be sure that this setting is the same in the Data Source.
- **Source Table** – The name of the table being accessed by the Data Source.
- **Source Column** – The name of the columns in the underlying Data Source table.

If you have the Live Connection checkbox selected, all the columns in the underlying source table are listed when the table is selected. It is not necessary to include all the columns from the source table in a Content.

Select an attribute and click Delete to remove it from the Content. Some Data Sources may have many columns of data, but the Content you are creating only requires a few of them. For example, while the World Data Source contains 28 columns, you might only be interested in searching the Content on Literacy and Capital. In this case you could delete all the attributes except these two. The Data Source is not affected.

If the Data Source has many columns and the Content only requires a few, it may be easier to use the Delete All button. This removes all the attributes from the Content. You can then use the Add button to add the attributes you want to use. This adds an empty row to the list.

Update the empty row by selecting the live connection checkbox and choosing a Source Column from the drop-down list. Its type and primary key information are automatically updated. Optionally click on the Alias field to enter a different name for the column.

Some reserved columns, even if they exist in the source table, cannot be selected as attributes to return. This includes MapInfo_ID in a tab file, and the geometry column.

If you want to retrieve all the columns from the source table as attributes:

- **a.** Making sure the Live Connection checkbox is cleared, click Delete All.
- **b.** Check the Live Connection checkbox.

  All the columns are added as attributes.
The attributes can be rearranged in the view. Select an attribute and move it to a new location in the list using the up and down arrows.

11. Specify the spatial column.

Select the SpatialColumn tab to specify your spatial column.

A spatial column contains geometry (or spatial) data, such as points (x,y Column) or objects (Geometry Object). For example, point data might be store locations. Object data may be postal code regions.

There are four elements that make up the SpatialColumn definition:

- **Geometry Type** – The spatial column type. This can be Geometry Object or x,y Column.
- **Geometry Column** – This option is displayed if you specify Geometry Object as the geometry type.
- **x,y Columns** – This option is displayed if you specify x,y Column as the geometry type.
- **Spatial Column Name** – The name of the returned geometry column.
- **Coordinate System** – Displays the source and the returned coordinate systems for the geometry columns.

Select the geometry type of the column that contains spatial information in the Source table. If you are using Live Connection (recommended) the column lists for each geometry type are populated. Select, or enter, the Geometry or X and Y columns from the source table.

The results of any spatial operation will be returned to the column you specify as the spatial column name in the Result section of the panel.

Note: The columns defined as XY columns for the Spatial Column are never returned when performing a search.

Optionally, edit the coordinate systems by clicking Modify. Select a new coordinate system that matches the Data Source from the list provided. If you are using a Live Connection you cannot modify the coordinate system of the Source geometry column, it must be the same as the underlying source table.

Contents are not required to use a spatial column. Check the Non-Spatial Content checkbox.

12. Add a Filter to the Content (optional).

Apply a static or dynamic filter to the Content you have created in the Filters tab. Refer to Creating a Filter in Chapter 5 on page 79 for detailed information on how to do this.

13. Add a Direct Query to the Content (optional).

Create a direct query for the Content you have created in the Direct Queries tab. Refer to Performing Direct Queries in Chapter 5 on page 89 for detailed information on how to do this.

Contents can be edited at any time after they have been created.

**Ad Hoc Content**

An Ad Hoc Content is a Content with no attributes assigned. This is enabled in the Content Manager to allow for Contents where the data attributes are assigned at runtime. An example of this is a Content linked to a Business Objects report. This report is dynamic and does not maintain a fixed set of column items. When the report is generated at runtime the attributes are then available.
To create an Ad Hoc Content follow the normal procedures to create a Content, either using a wizard (refer to Create a Content in Chapter 3 on page 36, or without a wizard (Creating a Data Content (Advanced) on page 58). Once the Content is created, click the Delete All button in the Attribute Tab and save. The Content is now considered Ad Hoc and generates the attributes at runtime.

Creating a Data Adapter (Advanced)

A Data Adapter converts external data into the correct format for Content Manager to use. It is required when an external Data Source is not supported by the Envinsa Location Platform. A Data Adapter defines how to feed data from an external source that is remote and unknown, such as a Web server on the Internet into a Content.

For a description of a Data Adapter, refer to Understanding Resources in Chapter 3 on page 34.

This section describes how to create a Data Adapter independently of the Data Adapter Wizard. The wizard provides step-by-step instructions. However, as you become more familiar with the Content Manager, you may want the flexibility of creating a Data Adapter without using the wizard.

For alternative instructions of setting up a Data Adapter using the wizard, refer to Using the Data Adapter Wizard in Chapter 3 on page 44.

To create a Data Adapter without using the wizard:

1. Create a reference to a Content.
   The Data Adapter requires a reference to a Content to be set up before creating a Data Adapter. This is so that the attribute fields in the Content can be populated with the data provided from the external Data Source. Refer to Creating a Reference to a Content in Chapter 8 on page 120 for procedures on this task.

2. Create the Data Adapter.
   There are three ways to create a new Data Adapter in the Content Manager interface:
   - Click the New Data Adapter button in the toolbar:
     ![New Data Adapter Button]
   - Choose Data Adapter > New from the menu.
   - Right-click on the Data Adapters folder in the left-hand panel and choose New > Data Adapter.

3. Enter the name for the Data Adapter in the Input dialog box.
   The Data Adapter name must be unique to identify it from the other Data Adapters in the Domain. Click OK.
   - The new Data Adapter is added to the list of available Contents in the left-hand panel.

4. Define the Data Adapter.
When you have created a new Data Adapter, you need to define it in the Information panel in the main area of Content Manager. This is the area where you can specify how the Data Adapter is set up: which Content it references, the Data Source it is based on, the spatial column, and any filters to apply to the Content.

**Information Panel: Data Adapter**

There are seven main types of information you can set for the Data Adapter. Depending on your data, you may not need to specify all the available settings.

- **Description** – This allows you to specify a more meaningful name and description for the Data Adapter.
- **Resource Tag** – A way to categorize the resources by keyword.
- **Referenced Content** – The Content you created in a Catalog to store the data provided by the Data Adapter.
- **Data Source** – This is where you specify the Data Source on which you want to create the Data Adapter. You must have a Data Source to create a Data Adapter.
- **Table name** – The table name in the source data you want to use.
- **Attribute Mapping** – Shows how the source columns of the external Data Sources are mapped to columns in the Content you selected.
- **Filters** – Allows you to apply a filter to the data provided by the Data Adapter.
- **Data Provider** – Uses the Data Source information to connect to the external Data Source and retrieve data from it.

Continue to follow the instructions in this section for information about how to define your new Data Adapter in the Information panel.

5. **Provide a Description for the Data Adapter (optional).**

The description of a Data Adapter is where you can enter more detailed and meaningful information about the Data Adapter you are creating. It can be a short description about the Data Source on which the Data Adapter is based. By default, the new Content has a description of “New Data Adapter.” Simply type in the description of the Data Adapter.
For example, the description for the EventsDataAdapter provided in the SampleDomain is:

A sample data adapter that transfers event data from an XML file and inserts it into a MapInfo TAB file

6. Define the Data Provider.
Click the Data Provider tab, and fill in the information necessary to define the data provider. Choose to use a default data provider from the Data Source, or a user-defined one.
If you choose a user-defined data provider, you must provide the class name of the data provider in the User Defined Data Provider Class text field. Click Modify to update this Class information.
Edit the default values for the connection properties by double-clicking a value to edit it.
Specify the frequency by which you want to update the data in the referenced Content. If you select the Only Update Once per Run, the data will only be refreshed each time the Data Adapter starts up. Depending on the type of data you have, you may want the updates to be more or less frequent. The update options range from milliseconds to years.

7. Select the Data Source.
A Data Adapter is based on a specific Data Source. Choose a Data Source you created from the list provided. A Data Source is required when a default data provider is used. If a user-defined data provider is used it may not require any Data Source.

8. Set up a Live Connection (optional).
It is recommended, although not required, that you select the Live Connection checkbox in the information panel when you are defining the new Data Adapter. Once you select the Live Connection checkbox, the Content Manager sets up an active link with the underlying Data Source. Once this is connected, the fields in the Information panel are populated from the fields in the tables in the Data Source. If you do not make a live connection you must input the column names from the table manually which creates an opportunity for error.
The downside to setting up a live connection is that it has the potential to be slow as the Content Manager is linking directly with the Data Source. This may have some effect on the speed of Content Manager depending on how your system is set up. For this reason it is recommended you use a Live Connection only when creating new Data Adapters.

9. Select a table name.
Choose a table name from the list provided. If you are in live connection mode, this list is populated with tables available in the Data Source you picked in the previous step. Notice that the list of source columns in the Attribute Mapping tab changes according to the table structure. This does not happen unless you are in Live Connection mode.

10. Organize the attributes.
Select the Attribute Mapping tab to display the attribute mapping for the Data Adapter. There are six elements that describe attribute mappings:
- **No** – This is a unique number that indicates the order of the attributes in the Content.
- **Alias** – This is the attribute name defined in the referenced content. It is the destination into which the data adapter will import data.

In the EventsDataAdapter provided in the SampleDomain, the Alias names display the meaning in the information provided in the source columns. For example, category1 is the Category name, and the date.from is the Start Date column.
• **Type** – The data type of each attribute in the source table. For example, int, string, and float.

• **Primary Key** – There is only one primary key per Content. This unique identifying key can be specified by selecting the appropriate checkbox to match the setting in the data table.

• **Source Table** – This is the name of the table being accessed by the Data Source.

• **Source Column** – The name of the columns in the underlying Data Source table. The column mapped to an attribute in the referenced Content. The Data Adapter pulls data from this column and puts it into the mapped attribute in the Content.

If you are have the Live Connection checkbox selected, click Add to add an attribute mapping. In the Alias column, specify an attribute from the referenced Content to be updated. In the Source column, specify a source column. If the Live Connection checkbox is checked, both column lists are populated with the values from the source columns. Add all the attributes from the content that you want to update.

11. Add a Filter to the Data Adapter (optional).

You can optionally apply a dynamic filter to the Data Adapter you have created in the Filters tab. Refer to [Creating a Filter in Chapter 5 on page 79](#) for detailed information on how to do this.

---

### Exposing Your Data Through WFS

Envinsa WFS works with the Content Manager to expose your custom data allowing you to access features through the service. To expose your data through the WFS service you must first define a content in the Content Manager making it available to the entire Envinsa Platform. This is done using a combination of the Content Manager console and manual edits to the data. This section explains step-by-step how to define a content using the Content Manager console and how to access the new content using WFS.

Your data can be in any format supported by the Envinsa Platform. For example, a MapInfo TAB file, Oracle DBMS, etc. For illustration purposes, this step-by-step example uses the Envinsa US_CA street data. By default, the street data is deployed with the Envinsa Platform. It is a MapInfo TAB file located in the US_CA/ExtendStreet/ directory under the Envinsa DataDomain directory. The file name for the street data is: wna_xe.tab.

1. **Launch The Content Manager**

   Launch the Content Manager using your administrative username and password. See [Starting the Content Manager in Chapter 2 on page 20](#) for more information on how to start Content Manager.

   In Content Manager, contents (data) are grouped in domains. There is a sample domain created during an Envinsa Platform installation. We will use this sample domain for this example. For the information about how to create a new domain, please refer to [Setting Up Enterprises and Domains in Chapter 2 on page 23](#).

   Once you have Content Manager open, click on File>Open, at the dialog click Open to open the sample domain.

2. **Define The Data Source To Access Your Data**
Use the Data Source Wizard to create a new Data Source. Click on Tools>Wizards>Data Source Wizard from the menu.

Select File Data Source

Browse to your data location. For this example we are using the wna_xe.tab file in the ExtendStreet folder

Give the data source a name. For this example we are using MyDataSource.
Click Next>Finish. Alternatively, you can click on the Test button to verify the data source before saving. Now you will see your newly created datasource in the left-hand side of the console. For this example you will see MyDataSource.

3. Define The Content To Represent Your Data

Use the Content Wizard to create a new Content. Click on Tools>Wizards>Content Wizard from the menu.

Select the datasource name that you create in the previous step from the list. For this example select MyDataSource.
Select your data file from the list. For this example select the wna_xe TAB file.

Select the columns you would like to exposed in the content by moving the columns to the Content Attributes List side. For this example, select all by clicking >>.

Select using an existing geometry column.
Select the geometry column. For this example select the MI_GEOMETRY column.

Define the coordinate system for the geometry column. For this example we are using default settings, do not change the source coordinate system.

Give a unique name to the geometry attribute. For this example we are using GeoLoc.
Skip the filter definition.

Create a name for your new content. For this example we are using MyContent.
Click Next>Finish. Now you will see your newly created content in the left-hand side of the console. For this example you will see MyContent.

4. Define The Category To Expose Your Data

The content can be exposed at any node of a catalog. Please refer to Chapter 8: Creating a Catalog for more information on how to organize your catalogs.
Select Catalog folder in the Domain tree in the left-hand side of the console, Click on Catalog>New from the menu, and provide a name for your catalog. For this example we are using the name Customer Data.
Click Catalog>Add Category… to add a category to your catalog. For this example we added the Extend Street category to our catalog.

Click Catalog>Add Content… to link your content to the newly created category. This allows WFS to access the new content (data). For this example we specify MyContent as the content source and call the new content name in the category Extended Street Content.

Your data is now exposed through the Content Manager to WFS.

5. Access Your Content In WFS
You can now use WFS to access your data. When sending a GetCapabilities request to WFS, you will now see your feature entry in the response. For this example you will see the following in an XML response:

```
<ns4:FeatureType>
  <ns4:Name>PUBLIC;SampleDomain//Customer Data.Extend Street.Extend Street Content</ns4:Name>
  <ns4:Title xsi:type="xsd:string">MyContent</ns4:Title>
  <ns4:Abstract xsi:type="xsd:string">This is a new content</ns4:Abstract>
  <ns4:SRS xsi:type="xsd:string">epsg:4326</ns4:SRS>
```
You can also send a DescribeFeatureType request to WFS using your data. For this example, you can define the content in an XML request similar to the following:

```
<ns4:DescribeFeatureType service="WFS" version="1.0.0" xmlns:ns4="http://www.opengis.net/wfs">
  <ns4:TypeName>PUBLIC;SampleDomain///Customer Data.Extend Street.Extend Street Content</ns4:TypeName>
```

## Copying Resources

The Content Manager allows you to cut, copy, and paste resources within Content Manager and also to external text and XML editors.

**Note:** When copying a resource into an external application, it is pasted as XML.

### Copying a Resource

To make a copy of a resource you have already created, do the following:

1. Highlight the resource in the Navigation Panel and copy it.
   
   Copy can be performed by doing one of the following:
   
   - Clicking the Copy button on the toolbar.
   - Using Ctrl-C on your keyboard.
   - Selecting Copy from the Edit menu.
   - Right-clicking on the item and choosing Copy.

2. Paste the resource into the same Domain or switch to another Domain.
   
   Paste can be performed by doing one of the following:
   
   - Clicking the Paste button on the toolbar.
   - Using Ctrl-V on your keyboard.
   - Selecting Paste from the Edit menu.
   - Right-clicking on the item and choosing Paste.

If you already have a resource with the same name, the newly pasted resource is called Copy of Resource. If no other resource has the same name, it is copied into the new Domain with no name change.
Note: You are prohibited from pasting a resource into an area where it is unsuitable. For example, pasting a Data Source into the Contents section. The Content Manager beeps when such an operation is attempted.

Editing a Resource in an External Editor

To edit a resource as XML, do the following:

1. Highlight the resource in the Navigation Panel and copy it using one of the standard Copy methods.
2. Paste the resource into a text editor such as Notepad.

   XML Filter Definition: Notepad

3. Edit the resource and save it in the text editor.
4. Copy the entire XML definition from the text editor.
5. Select the section in the Domain where you want to add the resource (for example, Contents for an edited Content definition).
6. Paste the edited resource using Ctrl-V on your keyboard.

Note: The new resource must have a different defined name than any resources within that Domain and section of Domain.

The resource is added to the Domain in the location suitable to the resource you are pasting. For example a Data Adapter is pasted to the Data Adapters folder.
This section describes how to create and apply filters for your data content.

In this section:

- Introduction to Data Querying ........................................ 78
- Creating a Filter ......................................................... 79
- Modifying a Filter ....................................................... 83
- Testing Filters ............................................................ 87
- Importing and Exporting Filters from XML ......................... 88
- Performing Direct Queries ............................................. 89
- Searching Through Content ........................................... 91
- Understanding Operators ............................................... 92
- Example of How to Create a Complex Static Filter ............... 96
Introduction to Data Querying

Querying your data is a way of constraining your data so that only certain features are returned, or a subset of the source data is used, according to the conditions that you apply. For example, you could set up a query to retrieve only those records that are in New York City from a Content that contains data from a variety of cities in the world. The queries you use can be set up to be as simple or as complex as you require.

As the filter is independent of the Data Source, you apply the filter to Contents and Data Adapters set up in Content Manager without modifying the underlying Data Source.

There are two ways to query your data:

- **Filter** – These use predefined operators and expressions to add constraints to your data contents. Filters work with the already-defined spatial column, attributes, and filters to filter your data.

- **Direct Query** – A direct query allows you to constrain your data content by writing a SQL expression. This may provide a more flexible way to constrain your data if the conditions are complex.
  
  **Note:** You can only use one of the query methods at a time. You cannot combine a filter with a direct query.

Types of Filters

There are two main types of filters that you can set up in the Content Manager:

- **Static Filter** – A static filter is one that can be set up to contain a criterion that is always applied when the Content is searched. It cannot be turned off.
  
  For example, you may have some source data that has information for all the States in the United States, but you only want to use records from New York for all searches. If you set up the static filter so the value for City = ‘New York’, every time this Content is searched only those records that have cities defined as New York are returned.

- **Dynamic Filter** – A dynamic filter provides the flexibility to filter on a name parameter. You can set up the filter with parameters as names. These names are then applied with values on the fly. Essentially a dynamic filter is like a template. Parameters of a filter template hold the name of the variable that is replaced with a real value at runtime.
  
  For example, City = [Parameter:city]. You can query the Content by passing the value of parameter “city” and “New York”.

  A dynamic filter is applied only when specifically referenced.

Direct Query

If you want to create a filter that gives you more control over the data query, Content Manager provides direct query capabilities. This is a raw SQL statement that can be written freeform and applied to a Content. This provides increased flexibility and allows you to have a greater control over the data query, but is more complex to create. For further information on creating direct queries refer to **Performing Direct Queries on page 89**.
Setting Up a Filter

The basic workflow for creating a filter is as follows:

1. Create an empty filter on a Content or Data Adapter. Refer to Creating a Filter on page 79 for more information.
2. Populate the filter with various operators to set it up for your specific requirements. Refer to Modifying a Filter on page 83.

Populating a Filter

Once you have created a filter, various operators can be added to make the filter meet your requirements. This section provides an overview of these operators, and they are discussed fully in Understanding Operators on page 92.

Spatial Operators

A spatial filter has a spatial operator – an operator that applies to spatial data, such as overlap and contain. Refer to Spatial Operators on page 92 for more detailed information.

Logical Operators

Logical filters are the combination of other filters using logical operators like AND, NOT, or OR. Refer to Logical Operators on page 94 for more detailed information.

Currently, logical filters cannot contain spatial filters.

Comparison Operators

This is a simple attribute filter that makes a comparison. For example =, <>, or >. Refer to Comparison Operators on page 96 for more information.

Creating a Filter

This section describes the basic method of creating a filter on a Content or Data Adapter. After creating a filter, you can edit the filter to add operators to make it fit your requirements. To create a filter:

1. Select a Content or Data Adapter.
   Browse to the Content or Data Adapter to which you want to add a filter in the Domain tree, and select it.
2. Click the Filter tab in the Information panel.
3. Create a filter.
Refer to Creating a Static Filter on page 80, or Creating a Dynamic Filter on page 82 for further information on creating these filters.

Note: We recommend that you check the Live Connection check box whenever creating a filter.

Creating a Static Filter

When a Content has been selected from the treeview and the Filters tab has been selected, the buttons and menu items to allow you to create a new filter are enabled.

Note: At this time only one static filter can be created for each Content.

1. Create a new static filter for the Content.
There are three ways to create a new static filter in the interface:

• Click the New Static Filter button in the toolbar.

New Static Filter Button
• Choose Filter > New > Static from the menu.
• Right-click on the Filters node in the Filter tab and choose New > Static Filter.
2. Select an operator for the filter in the New Static Filter dialog box and click OK to select it.

New Static Filter Dialog Box

The basic static filter is created with the default attribute name of attributeValue1.

Information Panel: New Static Filter

3. Modify the filter.

You can do this by changing the operator, data type, value, or attribute name. Refer to Modifying a Filter on page 83 for further information.
Creating a Dynamic Filter

When a Content, or Data Adapter, has been selected from the treeview and the Filters tab has been selected, the buttons and menu items to allow you to create a new filter are enabled.

1. Create a new dynamic filter for the Content or Data Adapter.
   There are three ways to create a new dynamic filter in the interface:
   • Click the New Dynamic Filter button in the toolbar.
   • Choose Filter > New > Dynamic from the menu.
   • Right-click on the Filters node in the Filter tab and choose New > Dynamic Filter.

2. Provide a name for the filter.
   Select an operator for the new filter in the New Dynamic Filter dialog box and click OK to select it.

The basic dynamic filter is created with the default values.
3. Modify the filter.
   You can do this by changing the operator, values, or attribute name. Refer to Modifying a Filter on page 83 for further information.

Modifying a Filter

Once you have created a new filter for a Content or Data Adapter, you need to modify the filter to have it suit your needs.

Adding Operators to a Filter

Once you have created the basic shell for the dynamic or static filter, you can add other operators to it.

To add operators to a filter:

1. Select the Content or Data Adapter that has the filter you want to populate.
2. Click the Filters tab and select the filter you created.
3. Highlight the Operator that already exists in the filter, and right-click.
4. Choose Filter > Add Operator, or select Add from the popup menu and choose the Operator you want to add.
Filter Popup Menu: Add an Operator

The operator is added to the filter at a level below the operator initially selected.

Only those operators you are permitted to add are selectable. If you see some operators are grayed out, this means they cannot logically be added to a filter at that level.

Rules for Adding Operators

There are several rules in logic that should be considered when setting up a filter. The Content Manager only displays permissible options in the menu and grays out operators and filters that cannot be added, where appropriate.

• Only one spatial operator is permissible in a dynamic filter.
• If you have a logical operator in a filter, a spatial operator cannot be added.
• ADD and OR operators must have more than one operand.
• The NOT operator can only have one operand.

Data Type Validation

The Filter dialog box enforces correct data types are input into the value field. By default every field is defined as a string. However, by choosing a different data type in the pick list you can ensure that the values entered match the field type. The data types available are:

• boolean
• date
• double
• int
• string

If you enter a value that does not match the data type defined for the field, an error message box displays.

Note: Some data types are not supported for certain operations. For example a boolean data type is not available for a LIKE operation. An error message box displays when the Filter dialog box is used incorrectly.

If you would like to specify a NULL value in the field, you need to choose NULL from the pull-down menu. If you type the string “NULL” in the field, it is interpreted as the string rather than the value.
Including an Input as a Parameter

When defining simple filters, you can specify that a value is used as a parameter, rather than an actual value. To do this, check the ‘As Parameter’ check box next to the value field and then type a name for the parameter in the value field. When users are using this filter they can specify any valid value at runtime.

At any time, a parameterized value can be reverted back to an actual value by unchecking the ‘As Parameter’ check box. Any parameter can be used more than once. All parameters must have be named with a unique name, unless it is a duplicate. The same parameter can be repeated any number of times inside of a filter. For example, the following expression could be created using one parameter: FirstName="Param Name".

Editing a Filter

When you have created a filter, you can edit parts of it at any time.

To edit a filter:

1. Select the Content or Data Adapter which has the filter you want to edit.
2. Click the Filters tab and select the expression part of the filter you want to edit.
3. Edit the filter.

   There are three ways to edit the filter in the interface:
   • Click the Edit filters button in the toolbar.
   • Choose Filter > Edit from the menu.
   • Right-click on the expression part of the Filter and choose Edit.

   ![Edit Filter Button]

   This displays an Edit Simple Filter dialog box that lets you select different column names, operators, and values for the expression.

   If you have the Live Connection checkbox selected, the column information from the Content will be displayed in the drop-down lists.
4. Change the options as required and click OK when done.
   The Edit Simple Filter dialog box changes depending on the type of filter you are editing. The filters based on spatial operators (Overlap, Nearest, Distance, and Contains) are created using default values. The Edit Simple Filter dialog box for these expressions allows you to change options such as the distance, units of measurement, and numbers of candidates returned.

5. Click the Validate button to verify the changes you made to the filter.

Validate Button

The Validate Filter dialog box displays and provides the status of the filter.

Validate Filter Dialog Box

If this is not OK, go back and correct the filter.

Removing Operators from a Filter

To remove operators from a filter:

1. Select the Content or Data Adapter that has the filter you want to edit.
2. Click the Filters tab and select the filter you created.
3. Highlight the Operator you want to delete and right-click, or choose Edit > Delete from the main menu.
4. Select Delete from the popup menu.
   The operator, and everything beneath it, is removed from the filter.

Deleting a Filter

To delete a filter:

1. Select the Content or Data Adapter which has the filter you want to edit.
2. Click the Filters tab and select the filter you want to delete.
3. Right-click on the Filter and choose Delete.
   The filter is removed from the Content.
Renaming a Filter

To rename a filter:

1. Select the Content or Data Adapter which has the filter you want to rename.
2. Click the Filters tab and select the filter you want to rename.
3. Right-click on the Filter and choose Rename.
4. Enter the new name of the filter.

Only Dynamic filters can be renamed. Static filters do not have a name.

Testing Filters

The Content Manager provides a Content Search utility that lets you test if a filter returns correct information. Refer to Searching Through Content on page 91 for more information about using this search utility.

Using the Search Utility to Test a Filter

To test a filter:

1. Select the Content in which to search.
2. Start the Content Search Utility.
   There are two ways to do this:
   • Click Search Content.
   • Choose Content Search from the Tools menu.
   The Search dialog box displays.
3. Choose a filter from the pull-down lists.
4. If necessary, fill in any requested dynamic values.
5. Choose whether or not to return geometries and specify a maximum number of candidates to return.
6. Click Search to start the process.
   If the maximum amount of candidates specified is reached a message displays in the status line, which reads:
   The maximum number of 100 candidates is reached.

Once the utility has successfully performed the search, you can click Close to close the Search utility. The data listed is not useful other than to see if your filter is returning the desired results.
Importing and Exporting Filters from XML

The Content Manager offers the functionality to import and export filters from XML. This makes copying and editing filters very straightforward.

Exporting a Filter in XML

To export a filter you have already created in a Content, do the following:

1. Highlight the filter, or a component of the filter, in the Filter tab.
2. Copy the filter.
   
   There are four ways to copy the filter in the interface:
   • Clicking the Copy icon on the toolbar.
   • Right-click on the filter and choose Copy.
   • Choose Copy from the Edit menu.
   • Use Ctrl-C on your keyboard.
3. Open an external text editor such as Notepad.
4. Paste the filter into the text editor.
   
   This displays the filter in XML format. You can optionally edit the XML to change the filter.
5. Save the text file. For example, filter.txt.

Importing a Filter from XML

To import a filter you have exported to XML and already saved as a text file, do the following:

1. Open the filter XML definition file you created previously in the text editor.
2. Copy the entire XML definition from the text editor.
3. Select the Content to which you want to add the filter.
4. Highlight the place in the filter where you want to paste the imported filter.
5. Paste the filter (Ctrl-V).
   
   The filter is added to the Content at the level you highlighted.
Performing Direct Queries

Direct queries provide the data administrator with an easy way to define queries using Structured Query Language (SQL). This makes it possible to take advantage of the full flexibility of this robust query language. You can predefine a number of named queries and store them with a Content. Subsequent searches can be performed on the Content using a specific query.

Like dynamic filters, a direct query has a name as well as parameters.

Direct queries are Data Source specific. You may not be able to run the same query in Data Sources for different databases such as Oracle and SQL Server.

Creating a Direct Query

To create a direct query:

1. Click on the Content in the treeview to which you want to add a direct query.
2. Select the Direct Queries tab.
3. Click Add in the bottom of the panel. The Input dialog box displays.
4. Enter a unique name for the direct query, and click OK. The new direct query displays in the Information panel.
5. Enter the SQL statement in the Query area of the Information panel. Optionally provide additional information about the query you are creating in the Description tab.
Adding a Parameter

When you are creating or modifying a direct query, you might want to add a parameter. A parameter acts as a token, allowing the user to change the value for that token when they run the query. For example, rather than specifying that the Naics value to be searched for is always 624410, it could be replaced with a parameter so that the Naics value can be changed at runtime.

To add a parameter to a direct query:

1. Highlight the direct query to which you want to add the parameter.
2. Add the parameter.

   There are two ways to add the parameter:
   - Click the Add button next to the Parameter drop-down list.
   - Write the parameter in the Query tab, highlight it, and click Add.

3. Use a parameter in the query.

   To use a parameter, put the cursor in the place you want to add the parameter, select one from the list and click Paste.

   The new parameter is pasted into the query at the location you specified and displayed in bold blue text in the query statement.
Removing a Parameter

To remove a parameter from the list:

1. Select the parameter you want to remove from the list.
2. Click Remove.

3. The parameter is deleted from the direct query, and the parameter in the query string changes back to display in a normal font.

Searching Through Content

The Content Manager is capable of searching Contents. This capability allows users to use Content Manager to do a search against a selected Content in the active Domain. This is useful for testing filters, finding a particular record in a Content, or validating Geocode results.

To use the search utility:

1. Select a Content to search.
2. Launch the Content Search Utility by clicking the Content Search button or by selecting Content Search from the Tool menu.
3. Select a filter to use for the search.
   The filters listed can be one of the following:
   - Spatial filter – Lists all the spatial filters defined in the Content.
   - Attribute filter – Lists all the attribute filters defined in the Content.
   - Direct query – Lists all the direct queries defined in the Content.
4. Set the filter parameters (if applicable).
   If the filter to be applied has parameters defined, values need to be assigned for each parameter in order to apply the filter. Use the parameter editor in the upper right of the Search dialog box. If the parameter type is a geometry, a special editor displays allowing GML input to describe the geometry.
5. Specify the maximum number of results to be displayed based on the attributes of the Content.
   **Note:** By default the search function returns the first 100 results. This default value can be changed in the MaxCandidates of search field in the Preferences dialog box (accessible by clicking Options in the Tools menu).
6. Click the Search button to begin the search.
   **Note:** If a Content had changed since it was last loaded, those changes are not recognized by the filter and do not show up in any searches.
Understanding Operators

Once you have created a filter, it can be modified to add or change operators to make the filter meet your requirements. The following sections describe the differences between the different types of operators.

- **Spatial Operators**
- **Logical Operators**
- **Comparison Operators**

**Spatial Operators**

Spatial operators include Contains, Nearest, Overlap, and Distance.

**Contains**

Use the Contains operator to find all the geometry objects within a data content that lie within another specified geometry. Boundaries can touch, but the inner object cannot have any points outside the containing boundary.

For example, you want to identify the postal boundaries within your target market area. The delivery area would be the input geometry and the source geometry would be the postal boundaries in your Data Source. In this illustrated example, only three postal boundaries are returned.

![Contains](image)

**Nearest**

Use the Nearest operator to find a specified number of geographies in the Data Source closest to another specified geometry. If you specify the number of nearest candidates as 2, then only the two closest matches are found, even if the distance value you specify encompasses many more candidates.

For example, you want to find the three closest customers to your store within a 2 kilometer search radius. The store is the input geometry, the distance value to search within is 2, and the number of matches to find is 3. The source geometry is the customer locations in your Data Source.
The Nearest operator takes multiple parameters for distance. If the number of matches is not found within the first distance setting, the search is repeated for the second distance setting, and so on until the indicated amount of results is attained or the maximum of the specified distances is reached. This allows a level of efficiency in searching multiple distances. We recommend that you apply distance values that are appropriate to the number of nearest candidates for which you are filtering. The larger the distance value, the more processing time is required.

If no distance parameters are provided the Nearest search is performed using the default recursive values.

**Overlap**

Two geometries are overlapping when the areas represented by these geometries overlap. Use the Overlap operator to find the geometry in the Data Source that lies within or overlaps a given geometry. Boundaries can touch to be considered overlapping.

For example, you want to identify the postal boundaries that overlap your target market area. You would supply your delivery area as the input geometry. The source geometry is the postal boundaries in your Data Source. In this illustrated example, 14 postal boundaries are returned.

**Distance**

Use the Distance operator to find the geometry in the Content that lies within a specified distance from a given geometry. Boundaries can touch and overlap the distance boundary.

For example, you want to identify postal boundaries within a 60 kilometer radius of a store. The store is the input geometry, and the distance value to search within is 60. The source geometry is the postal boundaries in your Data Source. In this illustrated example, 14 postal boundaries are returned.
Logical Operators

Logical operators are AND, OR, and NOT. They can be combined to create combinations of conditions in a filter.

A logical operator has a parent node (logical operator node) and one or more child nodes. One way of looking at how logical operators are constructed is through a tree view.

\[(\text{A = B}) \text{ or } (\text{C <> D}) \text{ and } (\text{E} \text{ in } (\text{F , G}))\]

Tree Representation of a Logical Expression

The leaf nodes of the tree are simple expressions with one operator that are building blocks making up the logical expression. A simple expression is composed of a parent node (arithmetic operator node), a left child node (operand), and one or more right child nodes (value or parameter nodes). A simple expression does not contain any children.

Example of a Logical Expression

For example, a logical expression is \(\text{NAME = 'John'} \text{ AND AGE > 30}\). Logical operators allow cascading, or nested, conditions. The nesting determines the order in which expressions are evaluated. The innermost condition (leaf) that has no children is evaluated first.

The following expression is illustrated as a tree with nodes:

\[
\text{AGE=30 AND (Name like 'john' OR Name like 'Jill')}\]
The following is an example of what this logical filter looks like when created in the Filter tab of the Content Manager interface.

For an example of how to generate this logical filter, refer to Example of How to Create a Complex Static Filter on page 96.

**AND**

The AND condition allows you to create an expression based on two or more conditions being met. The AND condition requires that each condition is met for the entry to be included in the result set. For example:

- \( \text{AND}(\text{TRUE}, \text{TRUE}) \) equals TRUE
- \( \text{AND}(\text{TRUE}, \text{FALSE}) \) equals FALSE

The following example filters records that are PC manufacturers located in Manchester.

- \( \text{City} = 'Manchester' \text{ AND } \text{Type} = 'PC Manufacturer' \)

**OR**

The OR condition allows you to create an expression where records are returned when any one of the conditions are met. The OR condition requires that any of the conditions be must be met for the record to be included in the result set. For example:

- \( \text{OR}(\text{TRUE}, \text{FALSE}) \) equals TRUE

The following example filters records that are in Manchester or Tokyo.
City = ‘Manchester’ OR City = ‘Tokyo’

**NOT**
The NOT condition allows you to create an expression to return records that are not equal to a particular value. For example:

\[
\text{NOT}\left(\text{FALSE}\right) = \text{TRUE}
\]

The following example filters records that are not in Manchester.

\[
\text{NOT City} = \text{‘Manchester’}
\]

**Comparison Operators**
The operators supported in this release are listed in the following table with their supported data types.

Between and Not Between operation includes the lower and upper boundary in the range.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Supported Data Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal</td>
<td>Numeric / String / Date / Boolean</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not Equal</td>
<td>Numeric / String / Date / Boolean</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater Than</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater Than Equal To</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less Than</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less Than Equal To</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>LIKE</td>
<td>For example: Name like ‘joh%’</td>
<td>String</td>
</tr>
<tr>
<td>NOT LIKE</td>
<td>For example: Name not like ‘john’</td>
<td>String</td>
</tr>
<tr>
<td>BETWEEN</td>
<td>For example: AGE between 20 and 30</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>NOT BETWEEN</td>
<td>For example: AGE not between 20 and 30</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>IN</td>
<td>For example: Name in (‘john’, ‘jack’…)</td>
<td>Numeric / String / Date</td>
</tr>
<tr>
<td>NOT IN</td>
<td>For example: Name not in (‘john’, ‘jack’)</td>
<td>Numeric / String / Date</td>
</tr>
</tbody>
</table>

**Example of How to Create a Complex Static Filter**

The following example explains how to create a complex static filter. It uses a logical expression, AND, to produce a logical filter.

1. Select the content to which the filter is going to be added.
2. Create a new, static, filter.
   Choose the Filters tab. Right-click the Filters node and select New > Static Filter.
In the New Static Filter dialog, select the AND operator and click OK. The new AND operator displays:

3. Specify comparison attributes.
   Double-click on the first comparison, attributeName = 'stringValue'. In the Edit Simple Feature dialog, enter the following settings:
   - Column Name: AGE
   - Operator: =
   - Value: 30
   From the Type list choose string.
   Click OK. The first comparison is now set to AGE = "30".
4. Delete the second comparison.
Right-click the second comparison of the AND operator, and select Delete to remove it.

5. Add an OR operator.
Right-click the AND Operator and select Add > Logical > OR. A new OR operator displays:

6. Specify comparison attributes for the OR operator.
Double-click on the comparisons, attributeName = 'stringValue', to modify them. For example:

7. Click Save to save filter settings.
Remote Access

This section discusses accessing Domains from a remote server and managing Domains located on a remote server.

In this section:

- Remote Access .................................................. 100
- Using a Remote Domain in a Local Content Manager ... 101
- Using a Remote Content Manager ......................... 102
- Remote Directory Access .................................. 102
- Data Uploading ................................................. 104
Remote Access

The Content Manager allows administrators to access Domains, Data Sources, Contents, Catalogs, and other named resources from servers that are external to the server on which the information exists. External can signify a different location across a LAN, WAN, or outside the company’s network using the Internet. Users can also use this capability to access Domains and Contents that are remote to their location. These two aspects of the Content Manager functionality are available through a behind-the-scenes service called the Content Management Service (CMS). While this service is not directly available for development access, it is used to provide remote functionality for Content management. Using this capability an administrator can create and define Data Sources, create, define, and remove Contents, and even upload customer data to a remote server. The Content Management Service is automatically included with every installation of the Envinsa Location Platform.

Examples of the use of this capability are:

- An administrator managing the company’s resources contained on a server space leased from a third party provider without having to compromise the security of that server.
- An administrator accessing a Domain from a client site.

The following diagram shows the possible relationships between a user and local and remote Content Management Services.

Possibilities for connections are:

- Local
  - User accesses local Content Manager using Local.
  - User accesses local Content Manager with a local Data Source based on a remote database.
• Remote
  • Local Content Manager accesses a Domain residing on an external Content Manager.
  • User accesses remote Content Manager using URL.

Using a Remote Domain in a Local Content Manager

If another installation of a Content Manager contains a Domain that includes Data Sources, Contents, Catalogs, and other resources, that you can use in a locally installed Console, you can include that Domain in the local Console, rather than needing to perform all the setup and configuration of a duplicate of that Domain. Also using a pre-existing Domain allows access to Data Sources and Contents that may be otherwise inaccessible.

If you want to access a Domain that has been defined on a remote Content Management Service, you need to have login access to that server. The username and password information must be set up in the Enterprise Manager associated with the remote installation. To include a remote Domain in your Content Manager, it must be registered. Follow these steps to register a remote Domain:

1. From the Content Manager, choose Register from the File menu.
2. In the Register Domain dialog box, click the Register button.
3. Type in the URI of the remote Content Management Service in the URI field.
   The URI is in the form of http://<machineName>:<portnumber>/CMS/services/CMS
4. Click Find
   The Connect to URI dialog box displays.
5. Enter your username and password for the remote service and click OK.
   Click the OK button for the resulting message stating that the search may take some time. The register Domain dialog box displays showing any unregistered Domains, allowing you to choose one.
6. Click OK to choose the selected the Domain and make it available to the local Content Manager.
7. Repeat this process for any other Domains that you want to register.
Once a Domain is registered with the Content Manager, it can be opened and operated upon as any other Domain with the exception of any functionality of Data Adapters. It is important to note that a Domain does not have multiple instances, rather the same remote Domain is referenced by both the local and remote Content Managers so that any changes made to the Domain from either location are immediately reflected in both locations.

**Using a Remote Content Manager**

A Content Manager is included on any machine where Envinsa Location Services are installed. The Enterprises, Domains, Contents, and all other resources managed by a Content Manager are either local to, or remote to, where Content Manager in installed.

To access a Content Manager that is installed on a remote server, type in the URL of that server in the Server field of the login screen of the Content Manager. A URL to a remote Content Management Service is in the form of `http://<machineName>:<portnumber>/CMS/services/CMS`. Enter the username and password that applies to that Console and click the Login button. For a fully detailed description of this process refer to Starting the Content Manager in Chapter 2 on page 20.

**Remote Login**

In order to log into a remote console, you need to have a valid username and password on that system. The username and password information must be set up in the Enterprise Manager associated with the remote installation.

**Note:** Any operations involving Data Adapters are not available on a remote basis and an error displays when one of those operations is accessed.

**Remote Directory Access**

When working remotely, you automatically have access to the directories to which you have permission. If you choose a Browse command, you can only browse the directories to which you have permission. All authentication is done on the server by the Content Manager Service. To configure user permissions use the Enterprise Manager. Refer To the Administration Guide for more information.
Configuring Directories to be Remotely Accessible

In order to make directories available for access by remote Content Managers, the Content Management Service needs to be configured using the Enterprise Manager. In the DirectoryManagement settings for the local Content Management Service add a new category for each Enterprise that you want to make available.

Content Manager DirectoryManagement Preferences

In each Enterprise listing, a Main key is provided. Add the path to the directory where remote users can have data available for use with Domains. Use for Domains includes locating data files for Data Sources and Contents, uploading data to existing files, and creating new Domains.

Content Manager Preferences: Key/Value Pair

For more detailed information about service configuration settings in the Enterprise Manager refer to the Administration Guide.

Directory Permissions

The following table shows which user roles have particular permissions

Note: User roles are created and assigned in the Enterprise Manager. Refer To the Administration Guide for more information.

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Envinsa Administrator</th>
<th>Enterprise Administrator</th>
<th>Enterprise User</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read directory</td>
<td>All users having access to a directory have the permission to read and view the contents of a listed directory.</td>
<td>Can create new directories in any directories defined.</td>
<td>Cannot create directories</td>
</tr>
<tr>
<td>Create directory</td>
<td>Can create directories in any directories defined.</td>
<td>Can create new directories in any directories assigned to the Enterprise or PUBLIC.</td>
<td>Cannot create directories</td>
</tr>
</tbody>
</table>
Data Uploading

The Content Manager lets you upload customer data to the server that Content Manager is connected to without accessing the server directly. This data upload capability only works for MapInfo TAB files. This is useful for an Envinsa administrator to place files on a server that they would, otherwise, have no write access to.

Note: The Data transfer utility only works on .TAB files and does not support seamless, non-native, or non-mappable TAB files.

Data uploading is accomplished through the use of a Data Transfer Wizard. To access the Data Transfer Wizard, select Wizard > Data Transfer Wizard from the Tools menu.

follow these steps:

1. Once the Wizard is started the Data Transfer Wizard - Step 1 dialog box displays. Select the Data Source which is to receive the data being uploaded. Click Next.

   Data Transfer Wizard - Step 1

   The Data Transfer Wizard - Step 2 dialog box displays.
Data Transfer Wizard - Step 2

2. Choose the file to upload to the Data Source. You can either type in the full path to the file or use the Browse (…) button to navigate to the file.

The Data Transfer Wizard - Step 3 dialog box displays.

3. Confirm your choices and then click Finish to begin the uploading process.

4. When the uploading process is complete a confirmation alert box displays.

Data Transfer Wizard - Confirmation Box
Data Security

This section describes how to set permissions for controlling and organizing access to data.

In this section:

- Understanding Domain Access Privileges ................. 107
- Understanding Resource Access Privileges .............. 110
- Assigning Resource Access Rights ....................... 113
Understanding Domain Access Privileges

If you want to access the Content Manager, you need an account. This account is created using Enterprise Manager and specifies certain information about the user, including:

- User Name.
- The Enterprise to which the user belongs.
- The user's role such as ordinary Administrator, Data Administrator, or User.

The type of user role assigned to you will depending on the type of access and level of information you require. The next section contains detailed information about specific operations different users can perform.

Understanding User Roles

The Content Manager requires that you have a user account to access Content Manager. The user account is set up to provide users with different needs with different levels of access. The following list outlines the roles that can be created for different users of the Content Manager. Since the Content Manager has no facility to manage roles, all this administration is performed from the Enterprise Manager. Refer To the Envinsa Administration Guide for details on the creation and management of users and user roles.

- **Administrator** – An administrator manages the whole Envinsa deployment environment. This account has all access rights to all Domains created by anyone.
- **Data Administrator** – A data administrator manages the Content for an Enterprise. A data administrator always belongs to an Enterprise.
- **User** – A client who uses the Content Manager data. This user has an account.
- **Guest** – A client who is a guest to the Enterprise and has limited read access to resources.

**Domain Owner**

A Domain owner is a user who owns, and usually creates, a Domain. When a Domain is created, the creator automatically becomes the owner of the Domain.

There are five operations that have different access rights, depending on the role of the user:

- Open – Opening a Domain
- Create – Creating a New Domain
- Remove – Deleting a Domain
- Register – Registering a Domain
- De-register – De-registering a Domain

Understanding User Account Permissions by Domain

There are three different cases where users have different accessibility to these operations in Domains. These are outlined in the following sections.

- Permissions for PUBLIC Domains
- Permissions for Home Enterprise Domains
- Permissions for Non-Home Enterprise Domains
Permissions for PUBLIC Domains

The first case is accessing PUBLIC Domains. Domains that are not explicitly assigned to any 
Enterprise are created as PUBLIC. This means that all users from any Enterprise can open this 
Domain, but some roles have more rights. The following table outlines the rights for each specific role 
when accessing a PUBLIC Domain:

<table>
<thead>
<tr>
<th>Access Role</th>
<th>Open</th>
<th>Create</th>
<th>Remove</th>
<th>Register</th>
<th>De-register</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
</tr>
<tr>
<td>Data Administrator Domain Owner</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
</tr>
<tr>
<td>Data Administrator Not Domain Owner</td>
<td>Allowed</td>
<td>n/a</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
</tr>
<tr>
<td>User/Guest</td>
<td>Allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
</tr>
</tbody>
</table>

Permissions for Home Enterprise Domains

The second case is accessing a Domain where the user is a member of the Enterprise where the 
Domain resides. The following table shows the access rights for each specific role when accessing a 
home Enterprise Domain:

<table>
<thead>
<tr>
<th>Access Role</th>
<th>Open</th>
<th>Create</th>
<th>Remove</th>
<th>Register</th>
<th>De-register</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
</tr>
<tr>
<td>Data Administrator Domain Owner</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
</tr>
<tr>
<td>Data Administrator Not Domain Owner</td>
<td>Allowed</td>
<td>n/a</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
</tr>
<tr>
<td>User/Guest</td>
<td>Allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
</tr>
</tbody>
</table>

Permissions for Non-Home Enterprise Domains

The third case is accessing a Domain where the user is not a member of the Enterprise where the 
Domain resides in other words it is a “non-home Enterprise” Domain. The following table shows the 
access rights for each specific role when accessing a non-home Enterprise Domain:

<table>
<thead>
<tr>
<th>Access Role</th>
<th>Open</th>
<th>Create</th>
<th>Remove</th>
<th>Register</th>
<th>De-register</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
<td>Allowed</td>
</tr>
<tr>
<td>Data Administrator</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
</tr>
</tbody>
</table>
Accessing Domains by User Account For Web Services

This section discusses how Domains are accessible by Web services for different user accounts. It illustrates different accessibility based on the Enterprises and Domains specified. They are organized into sections by user account:

- Accessing a Domain as an Administrator
- Accessing a Domain as a Data Administrator or User

Domain Definitions

The following definitions are used in the tables that describe Domain accessibility by user account.

- **PUBLIC Domain** – A Domain that does not belong to any Enterprise.
- **Default Domain** – A Domain picked when the Domain name is not specified.
- **Default Public Domain** – The default Domain of all PUBLIC Domains
- **Default Enterprise Domain** – The default Domains of the specified Enterprise.

Accessing a Domain as an Administrator

The following table shows the different results that can be returned from different combinations of Enterprise, Domain, and User Enterprise for a user with an Administrator account. For example if you request Domain1 without specifying an Enterprise for it, and you belong to Enterprise1, you will access Domain1 in Enterprise1. If you request any Domain within the PUBLIC Enterprise, the Domain returned will be the default Domain in the PUBLIC Enterprise, no matter which Enterprise you belong to.

<table>
<thead>
<tr>
<th>Requested Enterprise</th>
<th>Requested Domain</th>
<th>User’s Enterprise</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not Specified</td>
<td>Not Specified</td>
<td>Not Specified</td>
<td>PUBLIC:default Domain</td>
</tr>
<tr>
<td>Not Specified</td>
<td>Not Specified</td>
<td>Enterprise1</td>
<td>Enterprise1:default Domain</td>
</tr>
<tr>
<td>Not Specified</td>
<td>Domain1</td>
<td>Not Specified</td>
<td>PUBLIC:Domain1</td>
</tr>
<tr>
<td>Not Specified</td>
<td>Domain1</td>
<td>Enterprise1</td>
<td>Enterprise1:Domain1</td>
</tr>
<tr>
<td>PUBLIC</td>
<td>Not Specified</td>
<td>Any</td>
<td>PUBLIC:default Domain</td>
</tr>
<tr>
<td>PUBLIC</td>
<td>Domain1</td>
<td>Any</td>
<td>PUBLIC:Domain1</td>
</tr>
<tr>
<td>Enterprise1</td>
<td>Domain1</td>
<td>Any</td>
<td>Enterprise1:Domain1</td>
</tr>
</tbody>
</table>
Accessing a Domain as a Data Administrator or User

The following table shows the different results that can be returned from different combinations of Enterprise, Domain, and User Enterprise for a user with a Data Administrator or User account. For example, if you request Domain1 without specifying an Enterprise, and your user account is not assigned to an Enterprise, you will access Domain1 in the PUBLIC Enterprise. If you do not specify a Domain or Enterprise, and your user account is assigned to Enterprise1, you will access a default Domain in Enterprise1.

<table>
<thead>
<tr>
<th>Requested Enterprise</th>
<th>Requested Domain</th>
<th>User's Enterprise</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not Specified</td>
<td>Not Specified</td>
<td>Not Specified</td>
<td>PUBLIC:default Domain</td>
</tr>
<tr>
<td>Not Specified</td>
<td>Not Specified</td>
<td>Enterprise1</td>
<td>Enterprise1:default Domain</td>
</tr>
<tr>
<td>Not Specified</td>
<td>Domain1</td>
<td>Not Specified</td>
<td>PUBLIC:Domain1</td>
</tr>
<tr>
<td>Not Specified</td>
<td>Domain1</td>
<td>Enterprise1</td>
<td>Enterprise1:Domain1</td>
</tr>
<tr>
<td>PUBLIC</td>
<td>Not Specified</td>
<td>Any</td>
<td>PUBLIC:default Domain</td>
</tr>
<tr>
<td>PUBLIC</td>
<td>Domain1</td>
<td>Any</td>
<td>PUBLIC:Domain1</td>
</tr>
<tr>
<td>Enterprise2</td>
<td>Not Specified</td>
<td>Not Specified</td>
<td>Exception:Access Denied</td>
</tr>
<tr>
<td>Enterprise2</td>
<td>Domain1</td>
<td>Not Specified</td>
<td>Exception:Access Denied</td>
</tr>
<tr>
<td>Enterprise2</td>
<td>Domain1</td>
<td>Enterprise1</td>
<td>Exception:Access Denied</td>
</tr>
<tr>
<td>Enterprise1</td>
<td>Domain1</td>
<td>Enterprise1</td>
<td>Enterprise1:Domain1</td>
</tr>
</tbody>
</table>

Understanding Resource Access Privileges

While different account roles have different access privileges to a Domain, users can additionally be granted or denied access to individual resources. In other words, individual users can be assigned rights to each individual resource within a Domain.

For example, while an account with a User role may be able to access a Domain, they may be denied access to specific Contents within that Domain.

There are three levels of access that can be assigned to individual users. These are the right to:

- **Read** – Read the metadata (resource) and source data from the underlying Data Source
- **Write Resource (Write RS)** – Create, remove, or modify a resource.
- **Write Data (Write DS)** – Insert, delete, or modify source data stored in the Data Source.

Resource Owner

A resource owner is a user who owns, and usually creates, a resource. When a resource, such as a Data Source or Content, is created, the creator automatically becomes the owner of the resource. The ownership of the resource can later be changed by an administrator or the current owner.
Note: Only a user with an Administrator or Data Administrator account, or the current resource owner, can change the ownership of a resource.

Rules for Setting Up Access Rights to Resources

Users with different accounts have different access rights to resources. You should ensure that you read these rules thoroughly before assigning access rights for individual users.

- **Administrator and/or Data Administrator** – A user who has an Administrator account, or is a Data Administrator of their Enterprise has all access rights to all resources. The resource owner has the same access as these users on the resources they own.

- **Resource Ownership** – Only a user with an Administrator or Data Administrator account, or the Resource Owner, can change the ownership of a resource.

- **Granting and Revoking Access Rights** – Only a user with an Administrator or Data Administrator account, or the Resource Owner can grant or revoke access rights to a resource. Even if other users have WriteDS/WriteRS rights, they cannot grant or revoke access rights on a resource to anyone.

- **Write Access** – The write access grant overrides read access. For example, if a user has Write Data or Write Resource access to a resource, Read access is automatically granted, no matter how it is defined.

- **Public Access** – Any user whose specific access type has not been defined has implicit public access. If a resource has public access rights (specifically, the group is Everyone) everyone shares the access rights. These access rights can be explicitly granted or denied from the public. If an individual user has different access rights defined, these override the public access.

- **User Access** – A specific type of access to a resource can be explicitly defined for an individual user. Once this access right is defined, it overrides the public access on a resource. For example, if Everyone has write access to a resource, and an individual user is denied all access, any user except that specific user can see the resource.

If the required access right is not defined, even though other types of access rights are defined for the same user, implicit public access applies.

Understanding User Account Access Rights by Domain

An individual user’s resource access rights can be set using the rules provided in the previous section. However, the rights an individual user has are also based on their rights within a Domain. There are three different cases where users can have different accessibility to resources. These are shown in the following three sections:

- **Resource Access Level Control within Public Domains**
- **Resource Access Level Control within Home Domains**
- **Resource Access Level Control within Non-Home Domains**

The tables in the following sections show how users with different access roles can Read a resource, Create a resource, Modify a resource, Remove a resource, Insert data, Update data, and Delete data. In addition, the tables show the type of accessibility these users have. If the field is marked with a checkbox, this shows that the user has the right to perform the operation. If the field is marked with Read, Write Resource (WriteRS), or Write Data Source (WriteDS) this shows that the user has access depending on how these particular access rights are set.
Users with an Administrator role have absolute access rights to any resources in the Domain. Users
with a Data Administrator role have absolute access rights to any resources in any Domain that
belongs to the same Enterprise as the user, or any PUBLIC Domain of which the user is the owner.
The resource owner also has absolute access rights to the resources they own.

Resource Access Level Control within Public Domains

The first case is accessing PUBLIC Domains. The following table provides a quick reference to check
the permissions to perform various operations for different user accounts within a PUBLIC Domain.

<table>
<thead>
<tr>
<th>Access Role</th>
<th>Read Resource</th>
<th>Create Resource</th>
<th>Modify Resource</th>
<th>Remove Resource</th>
<th>Insert Data</th>
<th>Update Data</th>
<th>Delete Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Data Administrator</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Domain Owner</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Administrator</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Not Domain Owner</td>
<td>Read</td>
<td>n/a</td>
<td>WriteRS</td>
<td>WriteRS</td>
<td>WriteDS</td>
<td>WriteDS</td>
<td>WriteDS</td>
</tr>
<tr>
<td>User</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Owner</td>
<td>✓</td>
<td>WriteDS (parent)</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Not Resource Owner</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Resource Access Level Control within Home Domains

The second case is assessing a Domain where the user is a member of the Enterprise where the
resource resides. The following table shows the access rights for each specific role at the resource
level when accessing a home Enterprise Domain.

<table>
<thead>
<tr>
<th>Access Role</th>
<th>Read Resource</th>
<th>Create Resource</th>
<th>Modify Resource</th>
<th>Remove Resource</th>
<th>Insert Data</th>
<th>Update Data</th>
<th>Delete Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Data Administrator</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>User</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Read</td>
<td>WriteRS (parent)</td>
<td>WriteRS</td>
<td>WriteRS</td>
<td>WriteDS</td>
<td>WriteDS</td>
<td>WriteDS</td>
<td>WriteDS</td>
</tr>
</tbody>
</table>

Resource Access Level Control within Non-Home Domains

The third case is assessing a Domain where the user is not a member of the Enterprise where the
resource resides. The following table shows the access rights for each specific role at the resource
level when accessing a non-home Enterprise Domain.
Assigning Resource Access Rights

To set the access rights of an individual user to a resource in the Content Manager:

1. Choose a resource in the Content Manager that you want to change accessibility. Highlight the resource you want to modify access rights to in the left-hand panel of Content Manager.

2. Display the Access Control dialog box. There are two ways to do this in the Content Manager:
   - Click the Access Control button in the toolbar.
   - Right-click on the resource you selected and choose Access Control.

3. Add a user. Once in the Access Control dialog box, you may need to add a user to change their access rights. By default Everyone is granted Read, Write Resource, and Write Data rights to all resources. If you want to change Everyone’s rights or to add a user to change their privileges, you need to add the specific user to the Users list and modify their individual privileges.

   Click the Add button. The Add a User dialog box displays.

   Select a user for whom you want to modify the access rights to be different from those granted to Everyone from the list. Click OK. The user is added to the list of Users in the Access Control dialog box.
4. Assign permissions.
   Use the Allow and Deny checkboxes to grant or revoke Read, Write Resource, and Write Data permissions for a user. The symbols to the left of the access types change to show the user’s final permissions for a resource: a Green check for Allow, or a Red cross for Deny. In some cases the access type is Unknown, indicated by an empty checkbox. This means that the user’s access right is not explicitly set and other rules are used to decide the ultimate access right. These rules are provided in detail in the following section **Rules for Setting Up Access Rights to Resources on page 111.**

   **Note:** It is not possible to modify a user’s Write Data access either for Data Sources or for Data Adapters. To change permissions to these resources, change the users’ permissions to any Contents that reference them.

5. Click OK when done.
   The new permissions are assigned to the user for that resource.
Creating a Catalog

This section describes how create and organize your resources into a Catalog.

In this section:

- Understanding Catalogs ........................................... 116
- Planning Your Catalog Structure ............................... 117
- Creating a Catalog .................................................. 118
- Creating a Category .................................................. 119
- Creating a Reference to a Content .............................. 120
Understanding Catalogs

The Catalogs section of the Content Manager interface is where you can organize the Contents you have created from Data Sources and Data Adapters into a structure that is useful to the end users of the data.

Managing Your Content

You can organize your data and metadata using Catalogs, Categories, and Referenced Contents in the Content Manager. To do this you can create a Domain that becomes the repository to host all the Content Manager information. Within this Domain you can create Catalogs of information. These are then subdivided into Categories and Contents in a tree-like structure. The following diagram illustrates the hierarchy of a Catalog structure within a Domain, using the Public Library as an example.

Understanding Catalogs

A Catalog is the hierarchical grouping of Content within a Domain. It may consist of logical groupings of similar Contents, optionally grouped into categories.

There may be one or more Catalog entries at the root of the Domain, and there may be zero or more categories and Contents beneath it in a hierarchical structure, as illustrated in the example. [ ] denotes optional entries.

    <Catalog>.[Category]...[Category].<Content>.

A common example of a Catalog that contains categories is a public library directory. A library directory contains logical groupings of information such as Periodicals, Books, and Scientific Journals. These would be Catalogs with many categories beneath them. The Books Catalog can, in turn, contain categories such as Language, Reference, Biography, History, and so on.
Understanding Categories

Categories are a grouping of Contents and/or sub-categories. For example, in the library directory example, the language Category includes many sub-categories of language groupings; French, Spanish, German, and so on. Each of these could be categorized further into Reference, Audio Visual, History, Language, and Literature.

Understanding Contents

Contents can be considered a view of the Data Source. Once a Content has been set up it can be referenced as a leaf entry of a Catalog to form part of a company’s data organization. A Content also defines templates of criteria, as filters, for searching the data.

For example, in the Public Library Directory a Content would be the individual book or material listing, with all the information about that item such as title, author, identification number, publisher information, and any other relevant information. This is the most granular level of data organization in the Content Manager’s structure.

The benefit of a Content is that it can be referenced in several places. For example the same French Dictionaries Content could be found at

```
```

and

```
Books.Language.French.FrenchDictionaries
```

There is only one French Dictionaries Content, but it can be referenced in many different places in a Catalog.

Planning Your Catalog Structure

Before you create a Catalog hierarchy, you need to plan out how you want to organize your data in the Catalog hierarchy.

Plan the Catalog

Before you begin you need to know:

- Which users, services, require access to different Contents.
- How many Catalogs and categories you need to create.
- Who you want to see the data. Consider assigning resource access privileges. Refer to Understanding Resource Access Privileges in Chapter 7 on page 110 for information about this.
- How the Contents will be referenced by different end users, and their specific requirements.
Create the Catalog Hierarchy

Use the Content Manager tools to create a Catalog by:

- Creating a Catalog
- Creating a Category
- Creating a Reference to a Content

Creating a Catalog

A Catalog is the highest level of grouping of referenced Content within any Domain. You can have as many Catalogs in your data hierarchy as you need. A Catalog is a top-level Category that can contain multiple categories and referenced Contents.

1. Create a Catalog.
   There are three ways to create a Catalog:
   - Click the New Catalog button.
   
   New Catalog Button
   - Right-click on the Catalog folder in the Navigation Panel and choose New > Catalog.
   - Choose Catalog > New from the menu bar.
   The Input Name dialog box displays.

2. Enter a unique name for the new Catalog.

   New Catalog: Input Name Dialog Box
   Click OK.
   The new Catalog is added to the Catalogs folder in the Navigation Panel. The Catalog is identified by the Catalog icon next to it, as shown in the following example.
Creating a Category

A Category is a grouping of referenced Content within a Catalog in a Domain. You can have as many categories in your data hierarchy as you need.

Note: You must have first created a Catalog to be able to create a Category. Refer to Creating a Catalog on page 118.

1. Highlight the Catalog to which you want to add a Category. The Category icons are not activated unless a Catalog is selected.
2. Create a Category.
   There are three ways to create a Category:
   • Click the New Category button.
   • Right-click on the Catalogs folder in the Navigation Panel and choose New > Category.
   • Choose Category > New from the menu bar.
   The Input Name dialog box displays.
3. Enter a unique name for the new Category.

   New Category: Input Name Dialog Box

   Click OK.

   The new Category is added to the Catalogs folder in the Navigation Panel. The Category is identified by the Category icon displayed next to it as shown in the following example:

   Information Panel: New Category
Creating a Reference to a Content

When creating a Content in the Catalogs section of the Information Panel, you are actually creating a reference to a Content you set up in the Contents section of the Information Panel.

The Catalogs section lets you organize the Contents you have created in the Contents section into different configurations to suit the different requirements various end users may have.

You can create Contents anywhere in the Catalogs area. They may be created directly under the top Catalog folder level, within Categories, or both. You may create as many references to a Content as you need, in as many locations as you require.

1. Highlight the level in the Catalogs folder at which you want to create the reference to the Content.
2. Create a reference to a Content.
   There are three ways to create a reference to a Content:
   • Click the New Content button.
   • Right-click on the Catalogs folder in the Navigation Panel and choose New > Content.
   • Choose Content > New from the menu bar.
   
   **Note:** If you do not have a Catalog or Category highlighted and choose New > Content, you will create a new Content resource, not a reference to a Content. Refer to Creating a Data Content (Advanced) in Chapter 4 on page 58.

   The Add Content dialog box displays.
3. Select the original Content on which the referenced Content is based.

   **New Referenced Content: Input Name Dialog Box**
   The first drop-down list shows all the Contents you set up from Data Sources in the Contents folder of the Navigation Panel. Select the Content from this list that you want to reference with this Content.

4. Enter a name for the referenced Content.
   Referenced Contents may have the same name if they are in different categories or hierarchical levels. Referenced Contents must have unique names if they are at the same level, in the same Category or Catalog. The Content Manager prompts you to use a different name if you are not permitted to use the one you specified.
   
   Click OK.
The new referenced Content is added to the Catalogs folder in the Navigation Panel at the location you specified. The referenced Content is distinguished from the original Content by a yellow arrow on the Content icon displayed next to it. This is shown in the following example:

```
Domain [Domain2]
  Data Sources
  Content
  Data Adaptors
  Catalogs
    NEW_CATALOG
      NEW_CATEGORY
        NEW_CONTENT
```

*Information Panel: New Referenced Content*
If you are an existing Envinsa 3.0 user and are migrating to 4.0, you should read the following information carefully to ensure that you upgrade your 3.0 version successfully.

If you are an existing Envinsa 3.5 user and are migrating to 4.0, then any existing Domains need to be registered within the newly installed 4.0 Content Manager (refer to Registering a Domain in Chapter 2 on page 28). Domains are automatically converted to the proper format when they are registered.

In this section:

- Deploying Envinsa Version 4.0 Content Manager ........ 123
- Understanding Domains ....................................... 123
- Migrating Your 3.0 Domains to 4.0 ......................... 123
- Mapping of Previous Terms ................................. 124
Deploying Envinsa Version 4.0 Content Manager

It is recommended that you deploy the Envinsa 4.0 Content Manager into a different directory from that of version 3.0. If you deploy version 4.0 in the same location as version 3.0 it will be overwritten. You should keep your 3.0 Content Manager, so that you can continue working with the 3.0 Domains you do not want to upgrade, or to publish any resources you want to migrate to version 4.0.

Understanding Domains

In the Envinsa 3.0 Content Manager, Catalogs were identified by URLs. In the Envinsa 4.0 Content Manager, Domains (formerly Catalogs) are named. Named Domains, besides being accessed by their URLs, can also be accessed by their names, allowing an easy way to remember the Domains. Named Domains are registered to the Content Manager enabling them to be accessed by Web services. Each named Domain is identified by its name and the Enterprise to which it belongs. If a Domain does not belong to any Enterprise, it is a public Domain. A public Domain can be accessed without an Enterprise prefix. For more detailed information about accessing Domains refer to Understanding Domain Access Privileges in Chapter 7 on page 107.

Migrating Your 3.0 Domains to 4.0

Before you open the version 4.0 Content Manager, you should do the following:

1. Publish the 3.0 resources.
   If you want to use resources such as Contents, Data Adapters, and Data Sources you created in version 3.0, you must ensure they are published in the 3.0 Content Manager. If the resources are not published, but only stay as Global Definitions, they will never be available for use in version 4.0. Refer to the 3.0 Content Manager documentation for information on how to publish resources to make them public.

2. Log into the 4.0 Content Manager.
   Optionally create a new user in Enterprise Manager (Creating User Accounts in Chapter 2 on page 32) and log into the 4.0 Content Manager (Logging In in Chapter 2 on page 21).

3. Register the 3.0 Domain.
   Follow the instructions in Registering a Domain in Chapter 2 on page 28 to register the 3.0 Domain with the 4.0 Content Manager.

4. Open the 3.0 Domain.
   Follow the instructions in Opening a Domain in Chapter 2 on page 30 to select the 3.0 Domain to open.
5. Upgrade the 3.0 Domain (optional).
   Before the Content Manager opens the 3.0 Domain, it asks if you want to migrate the Domain
to version 4.0. If you choose to upgrade, the 3.0 Domain is imported into version 4.0 and from
this point on can only be used with the new Console. If you do not want to upgrade, select No,
and you will only be able to use this Domain with the 3.0 Console.

6. Assign data security.
   If you chose to migrate to 4.0, data security information is added to each resource in the
Domain. By default, everyone is granted all access to all the data. If you want to change this to
limit access, refer to Chapter 7: Data Security.

7. Repeat this process for every Domain you want to upgrade.

Do not use a previous version of the Content Manager to open a 3.0 Catalog that is migrated to a 4.0
Domain. Although, the 3.0 Content Manager is able to open the migrated Domain, you will not be able
to work with it properly.

Mapping of Previous Terms

This version of the Content Manager uses new definitions of some terms and concepts. This table
shows the term used in the previous version of the Content Manager, and the term used for this new
version. The old terms are no longer referenced in this documentation. If a term is not listed in the
following table, it means that its definition is the same as the previous version.

<table>
<thead>
<tr>
<th>Previous Term</th>
<th>New Term</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalog</td>
<td>Domain</td>
</tr>
<tr>
<td>Context</td>
<td>Category</td>
</tr>
<tr>
<td>Global Definitions</td>
<td>Content</td>
</tr>
<tr>
<td>Data Content</td>
<td>Catalogs</td>
</tr>
<tr>
<td>Content Definition</td>
<td>n/a</td>
</tr>
</tbody>
</table>
Index

A
Access Control button 14
Adding operators to filters 83
AND logical expression 95
Architecture 8

B
Batch Geocode button 14
Batch geocoding, overview 11
Button descriptions 13–15

C
Catalog
creating 118
creating a hierarchy 118
menu 16
planning the structure of 117–118
understanding 116–117
Category
creating 119
understanding 117
Close Domain button 13
Comparison Operator 96
Contains Operator 92
Content
creating 36
creating a reference to 120–121
creating, advanced procedure 58–62
managing, overview 116
menu 16
understanding 34, 117
Content Search 14
Copy button 13
Copying
resources using XML 75
Copying resources using XML ??–76
Creating
catalog 118
catalog hierarchy 118
category 119
parameters for direct queries 89
reference to a Content 120–121
Cut button 13

D
Data Adapter
creating, advanced procedure 63–66
menu 16
setting up 36
understanding 34
Data organization overview 9
Data querying
creating a filter 79–83
overview 11
understanding 78–79
Data Source
creating from a DBMS 38–40
creating from a file 37–38
creating, advanced procedure 49–53
defining 35
Generic XY set up 56
menu 16
Oracle set up 54
setting up examples 53–58
SQL Server set up 55
TAB setup 53
understanding 34
Deleting
domains 31
filters 86
De-Registering a domain 27
Direct queries, performing 89–91
Distance Operator 93
Domain
deleting 31
de-registering 27
opening 30
opening the sample 21
overview 10
registering 28
setting up 23–32
switching 30
understanding them 19
Dynamic filter
creating 82–83
description 78

E
Edit Filter button 14
Edit menu 15
Editing
filters 85
resources using XML 76
Enterprise
| Setting up | 23–32 |
| Understanding them | 19 |
| Enterprise domains, overview | 10 |
| Exporting filters | 88 |

**F**

| Features | 9–12 |
| File menu | 15 |
| Filter |  |
| Adding operators | 83 |
| Creating | 79–83 |
| Deleting | 86 |
| Direct query, overview | 78 |
| Dynamic, description | 78 |
| Editing | 85 |
| Exporting | 88 |
| Importing | 88 |
| Menu | 16 |
| Modifying | 83–87 |
| Populating | 79 |
| Removing from operators | 86 |
| Renaming | 87 |
| Static, description | 78 |
| Types | 78 |
| Workflow, overview | 79 |
| Framework, of Content Manager | 8 |

**G**

| Generic data source, JDBC driver setup | 56 |

**H**

| Help |  |
| Button | 15 |
| Menu | 16 |

**I**

| Importing, filters | 88 |
| Information panel, overview | 13 |
| Interface overview | 12–17 |

**J**

| JDBC driver |  |
| Generic XY data source | 56 |
| Oracle | 54 |
| SQL Server | 55 |
| JDBC sources, additional driver properties | 57 |

**L**

| Logging in as Administrator | 21 |
| Logical expression |  |
| AND | 95 |
| Example | 94 |
| NOT | 96 |
| OR | 95 |
| Logical operator | 94 |

**M**

| Menu descriptions | 15–17 |
| Multiple Document Interface (MDI), overview | 12 |

**N**

| Navigation panel, overview | 12 |
| Nearest Operator | 92 |
| New Catalog button | 14 |
| New Category button | 14 |
| New Content button | 14 |
| New Data Adapter button | 14 |
| New Data Source button | 14 |
| New Dynamic Filter button | 14 |
| New Static Filter button | 14 |
| NOT logical expression | 96 |

**O**

| Open Domain button | 13 |
| Opening a domain | 30 |
| Operator |  |
| AND | 95 |
| Comparison | 96 |
| Contains | 92 |
| Distance | 93 |
| Logical | 94 |
| Logical expression, example | 94 |
| Nearest | 92 |
| NOT | 96 |
| OR | 95 |
| Overlap | 93 |
| Rules for adding | 84 |
| Spatial | 92 |
| Understanding | 92–96 |
| OR logical expression | 95 |
| Oracle data source setup | 54 |
| Oracle JDBC driver | 54 |
| Overlap Operator | 93 |

**P**

| Parameters |  |
| Creating | 89 |
| Removing | 91 |
| Paste button | 14 |
| Planning |  |
| Catalog structure | 117–118 |
| Content structure | 22–23 |

**R**

| Redo button | 14 |
| Reference, creating to a Content | 120–121 |
| Refresh | 14 |
| Registering a domain | 28 |
| Removing |  |
| Filters from operators | 86 |
| Parameters from direct queries | 91 |
| Renaming filters | 87 |
Resources
  copying using XML 75–76
  editing using XML 76
  understanding 34–35
  workflow for creating 35
Rules for adding operators 84
Running Content Manager 20–22

S
Save All Resources button 13
Save Resource button 13
Security, overview 11
Spatial Operator 92
SQL Server data source setup 55
SQL Server JDBC driver 55
Static filter
  creating 80–81
  description 78
Switching a domain 30

T
TAB data source setup 53
Toolbars description 13–17
Tools menu 16

U
Undo button 14

V
Validate Filter button 14
View menu 16

W
Wizards
  Data Adapter 44–47
  Data Content 40–43
  Data Source 36–40
  overview 10

X
XML, copying resources using 75–76
XML, editing resources using 76
XY data source setup 56
XY JDBC driver 56