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The purpose of this guide is to assist you in getting the best possible output from your MapInfo
Professional software. We begin by covering the new print, import, and export features and
continue with preferences and printing options available in MapInfo Professional. Then we
give you some helpful tips and tricks and finally we help you trouble shoot issues you may
be experiencing with your own use of MapInfo Professional.
We have updated this document with new features and new resolutions to existing issues.
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Printing in MapInfo Professional
Before you start printing your map or your graphs, you may want to create a new layout
so you can arrange your graphs, maps, legends, titles, etc. for the best effect. Choose
Windows > New Layout Window to put together a more effective presentation. We
recommend that you use layout windows for printing because it ties directly to the
printer driver.
To print a map, layout, or graph from MapInfo Professional:
1. When you have your map or layout the way you want it, choose File > Print to
display the Print dialog box.
Note: When you print a layout, the Options button does not display. When you
print a graph, the Advanced button does not display.
2. Select the printer or plotter you want to use for this workspace from the Name
drop-down list. The properties that are available for this device are printer/plotter
dependent. Please check your device manufacturer's manual for property details.

Setting How Map Contents Print
Note: Any selections you make in the Properties options will override the selections made in the
preferences for the current print session.
3. Select the print range of your output and the number of copies you want in the appropriate fields.
4. To set further map print options, click the Options button to display the Map Print Options dialog
box.
Note: You cannot select these options for a layout.
5. Make your selections and click OK to return to the Print dialog box.
• Map Size–Select the size of the map in this group; the options are Window Size, Fit to Page, and
Custom. As you make selections, the Custom Scale, Custom Width and Custom Height entries
change.
• Window Size–Click this button to print the map as it displays on your computer screen.
• Fit to Page–Click this button to fit the map to the page size you selected in preferences.
• Custom–Click this button to enter your own custom scale, width, and height entries in the fields
provided.

Setting How Map Contents Print
In the Map Print Options dialog box , you have the option to determine the map contents that you want
to print; the options are Same as Window and Centered on Window. (To go there select File > Print
and click Options in the Print dialog box.)
• Same as Window – Click this button to print the map contents as it appears in the Map window, with
the same proportions and content as you see.
• Centered on Window – Click this button to center as much of the current map that fits on the page.
When you select this option, the image may print on more than one page depending upon fit. In general when you select this option, MapInfo Professional assumes you want to select the Fit to Page
radio button and selects this for you.

Setting Advanced Print Options
In the Advanced Printing Options dialog box , you can refine your print settings. (To go there select
File > Print and click Advanced in the Print dialog box.)
Note: You cannot select these options for a graph.
These options are the same as those you select in the Output Settings Preferences dialog box. Selecting
options here overrides the setting you selected in the Output Settings Preferences dialog box for the
current print session.

Output Method
There are three output methods.
• Print Directly to Device – Use this option to print your image file directly from MapInfo Professional.
This is the default setting and is same printing from all versions before 6.0.
• Print Using Enhanced Metafile (EMF) – Use this option to generate an enhanced metafile of your
MapInfo Professional image before sending it to the printer. This option takes advantage of current
technology to shrink the spool size and print your file quicker without sacrificing quality.
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• Print Using Offscreen Bitmap (OSBM) – Use this option to generate an offscreen bitmap of your
MapInfo Professional image before sending it to the printer. This option depends on the type of
translucent content in the map and enhanced rendering state of the window.

Print Border for Map Window
Select this check box to print a black border around the image you are printing. Clear this check box to
print the image without a border. This check box is selected by default.

Internal Handling for Printing Transparent Vector Fills and Symbols
Special programming has been added to handle transparent fill patterns and bitmaps for vector images
when you print. Select this check box to use this functionality or clear it to let the printer or plotter to
manage this type of work. This check box is selected by default.

Scale Patterns
Select this check box to print non-transparent fill patterns that look like what you see on your screen.
This check box is checked by default. Clear this check box to let the printer driver have exclusive control
over rendering the pattern fills.

Use ROP Method to Display Transparent Raster
Select this check box to allow the internal ROP (Raster Overlay by Pixel) to manage the transparent
pixels when printing raster images. Since the ROP Method is largely a display method, not all printers
and plotters can use it. We recommend that you experiment with this setting until you get the results you
want when printing raster images. This setting has no effect when printing vector layers. This check box
is cleared by default.

Print Raster in True Color When Possible
Select this check box to print your 24-bit raster or grid file images in true color. Make sure your printer
settings are greater than 256 colors. This check box is selected by default.

Dither Method
Click this drop-down list to convert a 24-bit image into 256 colors, using either Halftone or Error diffusion.
When you have completed these selections and returned to the Print dialog box, click OK to begin
printing.

Recommendations for Effective Pattern Scaling
When you are printing, find out what type of printer driver you are using. Many PCL6 and some HPGL
drivers handle fill pattern scaling and give you control over this feature. Turning off their scaling may be
the difference between what you see in print and what you see on your monitor. We recommend that
you try turning off your driver's scaling options and try ours first, because we have enhanced our method
to better meet your Map and Layout window requirements. To turn our pattern scaling options on, select
the Scale Patterns check box in the Output Preferences dialog box. Then try turning off our scaling
and turn theirs back on to see which you like better. Tests show that our scaling produces color output
that more closely matches your screen's display.
If you are printing to postscript drivers using LanguageLevel 2 or 3, we find that some of the Microsoft
drivers do not support pattern scaling. As a result, our scaling method may not help you. Microsoft re-
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Printing the Map to a File
commended that you reset the language level of the postscript driver to LanguageLevel 1 to remove this
restriction. We did find some exceptions to this condition. On Windows 2000 some HP Laser Jet and
Color Laser Jet postscript drivers using our scaling option printed correctly.

Printing the Map to a File
To print the current map to a file:
1. From the File menu, select Print.
The Print dialog box displays.
2. Select the Print to File check box.
3. Click OK.
The Print to File dialog box displays.
4. Type the name of the file you want to create in the field provided and click OK. Use the extension
.PRN to help you identify the file as a print file.

Printing the Map to a Layered PDF File
PDFs are capable of holding multiple pages of information in the same space through the use of Optional
Content Groups (OCG), which are more commonly known as layers. Layers in PDFs are very similar to
MapInfo Professional map layers.
Each layer may hold any portion of the document's objects and layers may be made visible or invisible,
showing or hiding their contained objects, in any combination. By selectively hiding layers, you reduce
distractions to concentrate on particular areas or types of objects. Layers can be organized into groups
and the visibility option can apply to all layers within a group as one step.
To print a Map window or a Layout window to a layered PDF:
1. From the File menu, select Print.
The Print dialog box displays.
2. From the Name drop-down list, select MapInfo PDF Printer. This PDF driver is installed with MapInfo
Professional.
•

Optionally, click Properties to set any printing preferences.

3. Click OK to print to a layered PDF file.
Note: It may take some time to process a large map with many layers.

When saving a Layout window to a layered PDF, each frame (such as map frame and legend frame)
becomes a layer in the PDF. You can also use a different PDF driver, not the MapInfo PDF Printer. Doing
so creates a static PDF map without layer information, so you do not have the ability to turn on or off
particular map layers.
Labels in a Map window save to a separate layer in the PDF with a name that includes the parent layer
name. Adornments save as a separate Adornments layer in the PDF. Annotations in a layout save as a
separate layer named Annotation in the PDF. An empty Cosmetic layer does not save to the PDF.
Restrictions when Printing to a Layered PDF
Embedded legends in Mapper windows that export to the PDF file do not toggle on or off in the PDF.
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General Printing Tips and Tricks
Good first steps in troubleshooting a printing problem are to make sure you have downloaded and installed
the latest patch for MapInfo Professional and are using the latest printer driver for your printer/operating
system. Exceptions are noted in this document.
Seeing Black Boxes Instead of Symbols when Printing to PDF?
Turn on Enable Postscript Simulation. In the Print dialog box (after selecting File > Print to PDF), click
the Properties button. In the MapInfo PDF Printer Properties dialog box, select the Advanced Options
tab and then select the Enable Postscript Simulation check box.
Compress the Size of Raster Maps when Printing to PDF Tip
Use one of the image compression options with the MapInfo PDF Printer to select how to compress
black and white or color images, or select to remove duplicate images, downsample high resolution images, and disable PNG/JPEG printing. On the Print dialog box (after selecting File > Print to PDF),
click the Properties button. In the MapInfo PDF Printer Properties dialog box, select the Image
Compression tab.
Save New Defaults and Save Time Printing to PDF
Don't select the same setting over and over again when printing to PDF. Save your setting once as the
default setting. From the Start menu, select the Control Panel and then Printers and Faxes. In the
Printers and Faxes screen, right-click MapInfo PDF Printer and select Printing Preferences. Make
your favorite setting and click OK to apply it as a default when you print to PDF.
Embedding MapInfo Professional Graphics Tip
When you embed a MapInfo map or graph in another application (such as Word or PowerPoint), click
outside the map/graph before you use the Print or Print Preview commands. This allows the container
application to take over previewing or printing properly. This is particularly true if you have just made
changes to the map or graph you are printing.
HP 755 Driver Suggestion
If you are having difficulties printing using this plotter model, try the plotter driver for the HP 650C (C2859B)
instead. In many cases, if you are having difficulty with a printer or plotter model and a similar model
exists, you can substitute the similar model's driver for the current one and get good results. For example,
you can use the printer driver for the HP 8500 DN Color LaserJet with the HP8550 color LaserJet driver).
Need for Speed When Using Fill Patterns?
Note that fill patterns on the first row of the Region Style dialog box (see next figure) are Windows
standard and tend to print faster. The other patterns are bitmaps MapInfo has created for your use. You
might want to consider this when you are selecting fill patterns.
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1 Use the fill patterns from this row for fast printing results.
Speed Still an Issue?
If you want to improve printer speed, and your printer has Fast, Normal, Best print quality options, we
suggest you select Fast.
If your image is large and you are printing at a resolution of 600 DPI or greater, your image may exceed
this limitation. To print the image, reduce the resolution of the printout or shrink the size of the image.
See also Printing Maps Larger than 1.6 Meters (63 Inches) on page 10.
Translucent Raster Maps?
You cannot print a translucent raster map or grid on Windows 9X platforms or export them to EMF or
WMF file formats. You need to use a non-metafile (such as .BMP or .TIF) format to export raster images
on Windows 9X.
Old Driver Works, New Driver Doesn't
When in doubt, if an older driver worked and the new one does not, go back to the older driver. For instructions on reinstalling older versions of printer drivers, see Hatch Patterns Printing as Black Polygons
on page 8.
Disk Space an Issue?
Make sure you have plenty of temporary disk space, particularly if you are using the Print using the Enhanced Metafile option. The system is trying to create a layered bitmap locally on disk.
Print Workspace Path with Map?
In some cases, you may want to print the path to a particular workspace with your output. Here is a quick
way to do this:
1. Choose Options > Show MapBasic Window to display the MapBasic window.
2. Open the workspace you want to print. The path and workspace name display in the MapBasic
window.
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3. Use Ctrl C or Edit > Copy to copy the path and workspace name from the MapBasic window.
4. Choose Window > New Layout Window to create a new Layout window.
5. Make the new Layout window active and use Ctrl V or Edit > Paste to paste the path into the Layout
window. The path may paste in the gray area of the Layout window and may be difficult to see.
6. Select and drag the path to the desired printable location.
Printing Globally? Spool Locally!
Try spooling print jobs locally rather than at the plotter. This allows the computer to rasterize your output
rather than the printer, which can be more efficient.
1.
2.
3.
4.

To set up local print job spooling, choose Start > Settings > Control Panel > Printers .
Right-click the printer and choose Properties to display the printer's properties.
Click the Advanced tab to display the advanced property options.
Click the Spool Print Documents button and Start printing after last page is spooled button.
Note: If you do not have administrative rights to your computer, you may not be able to use the
spooling option. Contact your IT department if you want to make this change to get their
support.

5. Click OK to save your changes.

Resolutions to Known Printing Issues
There are many variables that affect printing and plotting with any application, and MapInfo Professional
is no exception. MapInfo Professional does not provide its own printer drivers, it uses the existing ones
installed under the current Windows operating system. This section addresses specific printer/plotter
issues that have been uncovered by users and partners.

Platform Independent Issues
These issues occur regardless of operating system or hardware/software, except where specifically
noted. Look for the issue you are working with below and refer to the resolution.

Printing a Layout Window to Multiple Pages
Printers/Plotters: HP Designjet Printers
MapInfo Professional Versions: 4.x and later
Issue: How do you print a Layout window to multiple pages?
Resolution: With the Layout window active, choose Layout > Options to display the Layout Options
dialog box.
To make the layout page two pages wide and two pages tall, type 2 in the Layout Size Width and Height
fields. Then click OK.

Printing Guide
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Handling the "Unable to Save Window Contents" Message
Printers/Plotters: HP Designjet 1055CM
MapInfo Professional Versions: 7.0+
Issue: This issue comes up whenever users try to print a Layout window at 60 in. x 36 in. or larger due
to memory issues.
Resolution: In this circumstance, print directly to the device rather than create the Enhanced MetaFile
(EMF). Additionally we recommend that you use the appropriate HPGL driver for your printer and operating system. All current HP printer drivers are available at their web site, http://www.hp.com.

Hatch Patterns Printing as Black Polygons
Printers/Plotters: HP Designjet Series Plotters
MapInfo Professional Versions: All
Issue: When you print maps with hatch patterns, some regions display as solid black.
Resolution: According to Hewlett Packard support, the new HP printer driver (4.63) handles non-Windows
standard hatch patterns properly. We recommend that you download and install the new HP 4.63 driver
to resolve this problem.

Platform-Specific Issues
These issues pertain to particular operating systems and/or hardware except where specifically noted.
These issues are grouped by operating system.

Print output repeats itself every 2 to 4 cm using the HP 500, 800, 5000 Designjet
plotter when printing Rasters
We have two suggestions to working around this problem. First, try spooling the printer locally either
from the driver level or the printer level.
Note: You must have read/write rights to your printer and printer driver to resolve this issue.
To work around this problem, there is an advanced hidden setting that you can change within the properties of the driver. To prevent the printer from repeating itself every 2-4 cm. when printing rasters with
vector overlays:
1. Locate the printer driver's properties in the Control Panel. To get to this setting, right-click the
printer icon and choose Properties.
2. Click the Advanced tab. Select the following options:
• Select the Avoid out of memory option.
• If you are using the Windows 2000 or XP operating system, select a scaling factor of 100%.
3. From this dialog box, click the Printing Defaults button.
4. In this dialog box, select the About button. The About <Driver Name> dialog box displays.
5. Holding down the F8 key on your keyboard, click the OK button. The Special Options dialog box
displays:
6. Do one of the following and click OK:
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• If printing from Windows 98, clear the Enable RenderSmart check box.
• If printing from Windows 2000 or XP, clear the Enable SpoolSmart check box.
CAUTION: When you modify settings in this driver option box, make sure to note the original
settings in case you need to change them back. These were designed for HP Support Engineers
and not for general public use.
You can save these settings as a Quick Set to ensure that they run every time you print raster files.
1. Choose Start > Settings/Control Panel > Printers .
2. Right-click the appropriate plotter driver icon and choose Printing Preferences.
3. Set the preferences the way you want them in the hidden menu.
4. In the Quick Sets box, type a name for the selected settings (for example, "Raster Print Settings")
and click Save. All current driver settings (paper type, hidden menu settings, etc.) are saved under
the Quick Set name. The printer driver remembers these settings and they can be used for future
print jobs.
To print a raster map later with the same settings:
1. Choose File > Print to display the Print dialog box.
2. Choose the Properties button. The Properties dialog box displays.
3. Make sure the name you entered (as in "Raster Print Settings" in our example) displays in the Quick
Sets drop-down list and click OK. The Print dialog box redisplays.
4. Click OK to print.
Note: If you do not need this special setting in Quick Sets, remember to change this setting back to
the default machine setting.

Cannot Print with HP Designjet Printers (Driver 5.31 or 5.32).
When you attempt to use this driver one of these things happens:
• If you select the Maximum Performance option, you get memory error messages and the printer
prints only part of the image.
• If you select the Avoid out of memory option, the computer shuts down unexpectedly and displays
both an Out of Hard Disk Space message and an Out of Virtual Memory message.
The resolution of this issue is similar to Platform-Specific Issues on page 8. The dialog box is the
same.
To resolve this issue:
1. Choose FilePrint to display the Print dialog box.
2. Click the Advanced button at the bottom of this dialog box. The Advanced Printing Options dialog
box displays.
3. Select these options and click OK:
•
•
•
•

Print directly to the printer
Internal Handling for Transparent Vector Fills and Symbols
Use ROP Method to Display Transparent Raster
Print Raster in True Color When Possible

Printing Guide
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Enhancements Added in Earlier Versions
• Select the Half Tone dither method.
4. From the Control Panel, select Printers or Printers and Faxes and find the printer you want to print
from.
5. Right-click the printer you want to print to and select the Properties option. The Properties dialog
box displays.
6. Click the About button to display the About <Printer Driver> dialog box.
7. Holding down the F8 key on your keyboard, click the OK button. The Special Options dialog box
displays.
8. Do one of the following:
• If printing from Windows 98, clear the Enable RenderSmart check box.
• If printing from Windows 2000 or XP, clear the Enable SpoolSmart check box.

Printing Maps Larger than 1.6 Meters (63 Inches)
When you print a map that is larger than 1.6 meters or 63 inches in Normal or Best modes, often the
image is incomplete. Only the first 1.6 m or 63" prints.
To resolve this issue, do one of the following:
• Click the Advanced button and in the Print Quality options, select a lower print resolution (from 600
to 300 DPI or from 300 to 150 DPI).
• Set the Scale to fit option to 100% to divide the resolution rendering by 2.
When you use one of these alternatives you can print up to 3.2 meters (10.5 feet) at 300 DPI or up to
6.4 meters (21 feet) at 150 DPI.

Enhancements Added in Earlier Versions
MapInfo Professional 11.0
Saving Preferences for Georegistration Coordinate Units
You can select to store the bounds and coordinate systems of the map or layout view in your PDF file.
This type of file is called a Georegistered PDF. You can save preferences to set the georegistration coordinate units to either Use Map Units or Use Degrees. For more information and instructions on how
to do this, see Saving Preferences for Georegistration Coordinate Units in the Help System.

MapInfo Professional 10.5
New in this release are polygon mode printing, printing to an offscreen bitmap (OSBM), subdivide printing,
and printing to a PDF file.
Polygon Mode Printing
This release of MapInfo Professional introduces a new way of drawing complicated polygons, such as
those containing holes or many nodes through a User Interface. This was due to an issue with printing
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such objects using an Adobe PDF printer driver. It left visible seams and gaps in the image when the
PDF was printed. These seams and gaps werenot visible on screen nor when printed using other printer
drivers.
Printing with the new method means that large polygons are now rendered as-is not broken into smaller
polygons, as the older method does. Additionally, the new method uses different calls that specifically
support drawing polygons with holes. The older method manipulates the polygon with holes to draw as
a single polygon, which caused seams and gaps to appear in the PDF
Note: Because this issue does not affect all users of MapInfo Professional who print maps, we continue
to provide the original polygon drawing method.
Polygon Mode may be set for each of three types of drawing: on-screen, printing, and exporting. Select
the Polygon Mode check box from the Options > Preferences > Output Settings menu under the
Display tab, Printing tab, and Exporting tab.

Note: The setting is independent to output method and is not saved on per window basis. This setting
will not affect any other option's User Interface.

Printing to an Offscreen Bitmap (OSBM)
The Print using Offscreen Bitmap (OSBM) printing method renders a print job to offscreen bitmaps
prior to sending it to the printer or plotter. It is used when printing maps and layouts containing translucency
and/or anti-alias content, particularly for raster images. For details, see Printing Maps with Translucency
and Anti-Alias Smoothing on page 22. When printing, select File > Print and click Advanced to display
the Advanced Printing Options dialog box. Select the Print using Offscreen Bitmap (OSBM) check
box.
This printing process generates an Offscreen bitmap of your MapInfo Professional image before sending
it to the printer. Offscreen bitmap is invoked depending upon the type of translucent content in the map
and enhanced rendering state of the window. However, setting OSBM from this window means that
while printing Offscreen bitmaps (OSBM) will be selected regardless of the translucency and anti alias
settings.
Setting Print to an Offscreen Bitmap as your Default
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You can set this option as a default by selecting OptionsPreferencesOutput and then selecting Print
using Offscreen Bitmap (OSBM) under the Printing tab. This preference sets the default for all new
windows.
Subdivide Printing
In earlier versions of MapInfo Professional, there was an optional registry setting, called SubdividePrinting, to allow print jobs to be broken into multiple, smaller print requests. This was especially useful if
printing large raster/ translucent maps to large paper sizes. Now that option has been added as a preference. The preference is initialized using the registry setting if it existed.
Click Options > Preferences > Output Settings under the Printing tab. There is a check box for
Subdivide Printing. If selected, the print job is broken into multiple smaller print request. If unchecked,
the print is done in a single request.
Printing to PDF
Professional lets you save a map to a layered PDF file. Since Acrobat 6.0, PDFs are capable of holding
multiple pages of information in the same space through the use of Optional Content Groups (OCG),
which are more commonly known as layers. Layers in PDFs are very similar to MapInfo Professional
map layers.
Your PDF now displays layers in the same order as shown in the MapInfo Professional Layer Control
window, and it displays translucency. The MapInfo PDF Printer supports GeoRegistration, which stores
the bounds and coordinate systems of the map view in the PDF file. The PDF file also stores the attribute
data of the records on the map.
New in this release when saving to a PDF file:
• Print to PDF – Select File > Print to PDF to save your map, browser, graph, or layout to a PDF file.
This option is similar to Save As, and gives you the option to concatenate PDF files.
• MapInfo PDF Printer tool – The Main menu includes a new MapInfo PDF Printer tool, which is the
same as selecting File > Print to PDF to save your map, browser, graph, or layout to a PDF file.
• Translucency – You can create a layered PDF that includes translucent layers in MapInfo Professional
10.5.
• PDF Preferences – The MapInfo Professional Print dialog (select File > Print) now includes a PDF
button that displays after selecting MapInfo PDF Printer from the Name list. This button launches the
PDF Preferences dialog. From this dialog, you can make the following settings:
Layered PDF
Select to save layers for a map, as shown in the MapInfo Professional Layer Control window, to the
PDF file. When saving a Layout window, each frame, such as map frame and legend frame, becomes
a layer in the PDF.
Georegistered PDF
Select to store the bounds and coordinate systems of the map or layout view in the PDF file.
Add Attribute data to PDF
Select to store the attribute data of the records on the map in the PDF file.
Automatically open the PDF
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Select to have the PDF file open after it is generated.
Selecting the Layered PDF option in the PDF Preferences dialog box enables the Direct to Device
option, and disables using OSBM and EMF.
If you select the Print using EMF or Print using the Offscreen Bitmap (OBSM) output method and later
on select the Layered PDF from the PDF Preferences dialog box, then the output method forcibly
sets to Direct to Device. However, disabling the Layered PDF option resets the print output method
back to your original selection, EMF/ OSBM.
• Context Sensitive Help for the MapInfo PDF Printer – This version of the MapInfo PDF Printer includes documentation in the form of a help system. To access this help system, select File > Print
and click Properties in the Print dialog box. This opens the MapInfo PDF Printer Properties dialog
box, which now includes a Help button on each tab.

MapInfo Professional 10.0
MapInfo Professional lets you save a map to a layered PDF file, see Printing the Map to a Layered
PDF File on page 4.

MapInfo Professional 9.5.1
MapInfo Professional provides enhanced rendering capabilities in this release, including:
•
•
•
•
•
•

translucency of vector objects (map features, labels, themes, text, and layout objects)
smoothing (anti-aliasing) of text, vector and images
new drawing selection method
new export formats: EMF+ and EMF+Dual
use of offscreen bitmaps to draw layouts
printing improvements

Enhanced rendering is possible through Microsoft's GDI+, an operating system level capability that
provides two-dimensional vector graphics, imaging, and typography handling. GDI+ improves on
standard Windows Graphics Device Interface (GDI) by adding new features and optimizing existing
features.
Enhanced rendering in MapInfo Professional allows you to create translucent labels, themes, and layers,
as well as apply anti-aliasing to smooth the jagged edges of text, labels, lines, curves, region borders
and raster images. We also provide a new way of drawing selections and two new export formats as a
result of using the new enhanced rendering support.
Enhanced rendering covers the following topics:
•
•
•
•
•
•
•

Enabling Enhanced Rendering on page 14
Enabling Enhanced Rendering for New Windows on page 14
Enhancing Selection Drawing Style on page 15
Workspaces on page 16
Translucency on page 16
Anti-Aliasing on page 19
EMF+ and EMF+Dual Export Formats on page 20
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• Layout Drawing Improvements on page 21
• PrintOSBM Registry Setting on page 21
Enabling Enhanced Rendering
To take advantage of enhanced rendering in MapInfo Professional, you must turn on the capability. If
you do not turn on enhanced rendering, rendering is performed using the standard Windows Graphics
Device Interface (GDI).
Enhanced rendering does not mean that translucency and anti-aliasing are automatically applied.
Translucency and anti-alias settings must also be applied to generate the best looking maps. You will,
however, automatically have the improved selection drawing style (see Enhancing Selection Drawing
Style on page 15). Translucency and Anti-Aliasing are discussed under Translucency on page 16 and
Anti-Aliasing on page 19, respectively.
Enhanced rendering is supported for Map, Browser, and Layout windows. Enhanced rendering is not
available for other types of windows.
To enable enhanced rendering, set it in the Options dialog for the map (from the Map menu, select
Options), Browser or Layout windows, or through a MapBasic statement. It is controlled on a per window
basis.
Legends are drawn in the same mode as the associated Map window. So, if a map is in enhanced rendering mode, its legend is as well. There are no enhanced rendering options in the Legend Options
dialog.
Like the Map and Browser windows, enhanced rendering for Layout windows is enabled in its Options
dialog. This means that any annotations added to the layout, such as titles or watermarks will be drawn
using enhanced rendering. If you add Map and Browser windows that already are enabled for enhanced
rendering, enhanced rendering will be forced on for the Layout window. Enhanced rendering for the
Map and Browser windows have no affect on the Layout window, and vice versa. For more information,
see Translucency on page 16.
There is also a style preference to determine the initial enhanced rendering state for newly created
windows. See Enabling Enhanced Rendering for New Windows on page 14.
Note: MapInfo Professional 9.5 opens a workspace with enhanced rendering, but ignores the enhanced
rendering settings. Versions of MapInfo Professional prior to 9.5 cannot open a workspace with
enhanced rendering. See Workspaces on page 16.

Enabling Enhanced Rendering for New Windows
MapInfo Professional provides a Style preference to determine the default state of enhanced rendering
for newly created Map, Browser and Layout windows. Each window can be changed independently at
a later time. This preference is disabled by default to maintain backwards compatibility with earlier versions
of MapInfo Professional.
Note: These preferences control the state of new windows, not existing windows. This means if you
are opening old workspaces, they will open with enhanced rendering disabled, regardless of how
the Style preference is set.
To set enhanced rendering as a default style preference:
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1. On the Options menu, point to Preferences and click Styles to display the Styles Preferences
dialog box.
2. Select the Enable Enhanced Rendering check box and make your selections from the drop-down
lists.

Enhancing Selection Drawing Style
MapInfo Professional offers a selection drawing style that uses translucency through enhanced rendering.
This requires that the window is enabled for enhanced rendering, see Enabling Enhanced Rendering
for New Windows on page 14. This style method is useful when you need to select map objects, such
as points or regions, where they overlap or appear to draw on top of one another when you zoom out.
To control the translucency setting for the selection style, go to the Styles Preference dialog. The slider
is located in the Highlight Control group for that dialog.
If enhanced rendering is turned off, selections are drawn using an older selection method. This method,
under certain situations, causes overlapping objects to appear unselected.
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Enhanced Rendering Turned Off

Enhanced Rendering Turned On

Note: A particular selection style may not look ideal in either mode. You will have experiment with the
settings.

Workspaces
If you open a workspace that does not have enhanced rendering enabled and you wish to use the
translucency and anti-aliasing features, you must enable it on a per window basis using the Options
dialog for the Map, Browser or Layout window.
Note: Workspaces with enhanced rendering enabled can only be opened in MapInfo Professional 9.5
or later. Enhanced rendering must be disabled to open a workspace in an earlier version of
MapInfo Professional.

Translucency
One key capability of enhanced rendering is the ability to apply translucency to a map layer so that the
layer underneath is partially visible. This feature can be a very powerful analytical tool. For example,
translucency on a ranged theme provides two levels of information in a single view—the distribution of
data that matches some criteria, and the view below the ranged theme that offers a reference map to
that data.
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MapInfo Professional supports translucency for a wide variety of layer types, including vector objects,
labels, themes, raster and grid images, and annotations (cosmetic layer and graphic objects added to
layouts).
Translucent Layers
Translucency is controlled on a per layer basis. Each layer has its own translucency setting. Translucency
for map layers and themes is set in Layer Control using a slider control on the Display Options dialog.
Translucency for labels is set in the Label Options dialog. All objects in the same layer are drawn at
the same translucency level. Labels, themes and map objects in the same layer have independent
translucency settings. You can have multiple translucent layers in a Map window, each with its own
translucency value.
In order to use translucency in a Map or Layout window, you must enable enhanced rendering in the
appropriate window's Options dialog. Enhanced rendering can also be set as a Style preference for
new windows you create.
Keep in mind, when translucency is on (value > 0 percent), enhanced rendering is automatically enabled.
However, the reverse is not true. If translucency is turned off (value = 0 percent), enhanced rendering
will not be turned off. You can turn it off manually, if desired, by clearing the Enable Enhanced Rendering
check box in the Options dialog.
Note: There is a shortcut to enabling enhanced rendering if you are already in the Display Options
or Label Options dialogs. You can enable it by setting a translucency value of greater than 0.
This saves you from returning to the Map or Layout window Options dialog to enable it.
Translucency is also available for the Cosmetic Layer. Set translucency for the Cosmetic Layer just like
you would for another layer type, in Layer Control's Display Options dialog. The translucency setting
will be applied to the entire Cosmetic Layer.
Translucency for Layout Windows
Layout windows provide two levels of enhanced rendering:
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• Annotation-level enhanced rendering for graphic objects, such as titles or watermarks.
• Window-level enhanced rendering for the Maps, Legends and Browsers.
To set enhanced rendering for layout annotations for an already created layout, go to Layout > Options
and select the Enable Enhanced Rendering check box. You can also set smoothing settings here as
well. If you have yet to create the Layout, you can enable enhanced rendering as a preference for newly
created windows (Options > Preferences > Styles).
To set enhanced rendering for Map and Browser windows that you wish to display in a Layout window,
go to the appropriate window options dialog (Map or Browser) and check the Enable Enhanced Rendering check box. Adding these windows to the layout and enhanced rendering will continue for these
windows. To disable enhanced rendering for these frames, return to the appropriate Options dialog and
clear the check box.
Embedding a Map or Browser window with enhanced rendering on in a Layout window will also force
enhanced rendering on for the layout. This can be seen in the Options dialog (Layout > Options) when
the Enhanced Rendering check box is selected, but the control is disabled, preventing you from turning
it off.
Adjusting Translucency in a Layout
Translucency for annotations in a layout is controlled by a translucency slider in the Options dialog for
Layout windows.
To adjust the translucency of annotations in a Layout window go to Layout > Options and change the
value on the translucent slider. All annotations in the Layout window will be treated with the same
translucency setting. Annotations are objects you can add to a layout by using, for example, the Add
Symbol, Line, Polyline, or Text toolbar options.
To adjust the translucency for Map windows in a layout, you must return to its Map window and access
the Options dialog to reach the translucency slider.
Note: Translucency for annotation objects does not affect the translucency of maps in layout frames.
The contents of frames are drawn using that window's translucency settings. They are not drawn
using the Layout window translucency setting. The translucency slider on the Layout Options
dialog does not control the translucency of the maps.
Translucent Raster and Grid Images
Translucency for raster and grid images has been available in MapInfo Professional prior to this release.
The new aspect of image translucency is the added support through enhanced rendering. These images
can be drawn translucently with or without enhanced rendering enabled.
The advantage of using enhanced rendering is seen when a translucent raster or grid image is printed.
Enhanced rendering enabled forces MapInfo Professional to print to offscreen bitmaps, which typically
yields better looking results than if printed without enhanced rendering.
For raster images, there is no change to how you set translucency through the user interface or via
MapBasic commands. Set the translucency in the Adjust Image Styles dialog ( Layer Control > Display
Options > Style Override > Adjust Image Styles ).
Raster display options can also be controlled on a per table basis so that the image will open using those
particular settings by default. These are found under Table > Raster > Adjust Image Styles .
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For grid images, the translucency slider is an option in the Grid Appearance dialog. This dialog is
reachable from the Styles button in the Create Thematic Map Step 3 of 3 or the Modify Thematic Map
dialogs.
Anti-Aliasing
One aspect of enhanced rendering is the ability to employ an anti-aliasing process that removes the
jagged edges of text, labels, images, and vector lines and borders. Enabling enhanced rendering does
not automatically enable anti- aliasing (smoothing options are set to None by default). You must set it
in Style Preferences for the default state of newly created windows, or in the Options dialogs for individual
Map, Browser and Layout windows.
To open the Style Preferences dialog, on the Options menu, point to Preferences and click Styles.

To remove the appearance of jagged characters in horizontal and rotated labels and on custom text
objects in the window, select the Enable Enhanced Rendering check box and choose Anti-Alias from
the Smooth Text & Labels drop-down list. Smoothed text and labels look better on your map, but because
these objects require more rendering, it may take longer to display your map.
If you wish to smooth raster and grid images in your window, you can set the quality of the resolution.
Low Quality indicates there will be some image smoothing, but not at the expense of rendering performance. High Quality means that you want the highest amount of smoothing MapInfo Professional can
provide. This will cause your map to draw more slowly than the Low Quality option.
The third anti-alias setting applies to lines and borders. The following illustration shows the before and
after affects of anti-aliasing applied to the roads and labels in the Map window.
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Enhanced Rendering Off

Enhanced Rendering On, with smoothing options

EMF+ and EMF+Dual Export Formats
In order to take full advantage of enhanced rendering, MapInfo Professional provides EMF+ and EMF+Dual
image export formats. These are enhanced metafile vector image formats that support Windows GDI+
(Graphics Device Interface). Use these to save translucent maps instead of exporting to the older
metafile formats, such as EMF and WMF. Older formats do not support translucency very well, which
display images using translucency with a dithered, or speckled, appearance.
Choose EMF+ if you expect to bring your maps into an application that supports EMF+, such as Microsoft
Office 2007. Choose EMF+Dual (a combination of EMF and EMF+) if your maps may be used in applications that may or may not support EMF+, such as Microsoft's Office 2003 and Office 2007.
Note: EMF+Dual format will produce a larger file than EMF+. But it provides better compatibility with
older application that do not support EMF+.
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Layout Drawing Improvements
Beginning with this release, MapInfo Professional now prepares a layout for display by rasterizing the
contents to an offscreen bitmap, and displaying the entire layout once the bitmap is drawn. You will no
longer see a partial display of the Layout window. The drawing is done offscreen and is presented to
you when it is completely drawn.
This behavior applies to layout displays with or without enhanced rendering enabled.
PrintOSBM Registry Setting
This registry setting controls a new printing method that renders a print job to offscreen bitmaps prior to
sending it to the printer or plotter. This is used when printing maps and layouts containing translucency
and/or anti-alias content.
For instructions to set PrintOSBM, see Anti-Aliasing on page 19.

MapInfo Professional 9.5
PolygonMode
This release of MapInfo Professional introduces a new way of drawing complicated polygons, such as
those containing holes or many nodes. This was due to an issue with printing such objects using an
Adobe PDF printer driver. It left visible seams and gaps in the image when the PDF was printed. These
seams and gaps were not visible on screen nor when printed using other printer drivers.
Printing with the new method means that large polygons are now rendered as-is not broken into smaller
polygons, as the older method does. Additionally, the new method uses different calls that specifically
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support drawing polygons with holes. The older method manipulates the polygon with holes to draw as
a single polygon. This is what caused seams and gaps to appear in the PDF
Because this issue does not affect all users of MapInfo Professional who print maps, we continue to
provide the original polygon drawing method. You can control which method to use by changing the registry
setting PolygonMode=1 (default, renders using the new method), to PolygonMode=0 for the old method.
This setting is located in the system registry under HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common.
PrintOSBM
This registry setting controls a new printing method that renders a print job to offscreen bitmaps prior to
sending it to the printer or plotter. This is used when printing maps and layouts containing translucency
and/or anti-alias content. For details, see Printing Maps with Translucency and Anti-Alias Smoothing.
Printing Maps with Translucency and Anti-Alias Smoothing
MapInfo Professional provides a new printing method for maps and layouts containing translucent content
and anti-alias settings. This method renders the map or layout "behind the scenes" to an offscreen bitmap
prior to sending it to your printer or plotter. The use of offscreen bitmaps is invoked depending on the
type of translucent content in the map and the enhanced rendering state of the window, as follows:
• Invoked when your map or layout contains translucent vectors (such as map layers, themes, or labels)
and enhanced rendering has been enabled.
• Invoked if your map contains images with either High or Low Quality smoothing enabled.
• Invoked for translucent raster and grid images provided enhanced rendering is enabled.
You cannot control this print method through the Print dialog, as you can with Direct to Device or Print
to EMF. This is a registry setting called PrintOSBM, located under HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common. The values are dword:00000000 (auto) and dword:00000001
(forced on). Auto, the default, means that printing will use offscreen bitmaps only for the translucency
and anti-alias conditions listed above. Forced on means printing will use offscreen bitmaps regardless
of the translucency and anti-alias settings.
For translucent raster and grid images, you can also print using EMF when enhanced rendering is not
enabled.
Note: Direct printing to a printer or plotter does not support translucency.

Enabling the PrintOSBM Option Using Registration Files
To edit the registry, you will need Administrator privileges. If you do not have the required privileges,
then ask your System Administrator to assist you.
To enable the PrintOSBM option using registration files in the Knowledge Base document:
1. Go to the MapInfo Knowledge Base entry MapInfo Professional > Registry Settings > Enabling
Enabling the PrintOSBM option: http://testdrive.mapinfo.com/TechSupp/MIProd.nsf/2fa3e3416d06d61d85257125006b2533/b769a029109299ab8525754c00591ec9?OpenDocument
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Note: If you do not have Internet access, see Enabling the PrintOSBM Option Manually on page
23 for instructions.
2. Save the Print_OSBM_ON.reg and Print_OSBM_auto.reg files locally. Use Windows Explorer
to navigate to the registration files.
Note: We recommend you create a permanent directory in case you need to remove the registration
option later.
3. Double-click the Print_OSBM_ON.reg icon to add the new key to the registry. This option takes effect
the next time you open MapInfo Professional.
Disabling the PrintOSBM Option Using Registration Files
If you try this option and you want to remove this functionality, you can disable the registry entry by following these instructions.
Note: We assume that you have downloaded the registry files by following the instructions in Enabling
the PrintOSBM Option Using Registration Files on page 22.
To disable the PrintOSBM option using the downloaded registration file:
1. Go to the directory that contains the registration (.reg) files you downloaded earlier.
2. To remove the PrintOSBM option, double-click the Print_OSBM_auto.reg icon. The registry entry
is updated with the new value. This option takes effect the next time you open MapInfo Professional.
Enabling the PrintOSBM Option Manually
If you do not have access to the Internet, or you want to add this option manually, follow these instructions.
Before modifying the registry, make a backup:
1.
2.
3.
4.

Choose Start > Run and type the command regedit. Click OK to display the Registry Editor window.
In the HKEY_LOCAL_MACHINE entry, navigate to Software > MapInfo > MapInfo > Common .
Highlight the Common folder and then select File > Export.
In the Export Registry File dialog, specify a location and file name to backup to and then click Save.

To enable the PrintOSBM Print option by entering the registration key manually:
1.
2.
3.
4.

From the Edit menu, select New > DWORD Value. A new entry displays in the list.
Right-click the entry and select Rename. Rename the new entry PrintOSBM and press Enter.
Double-click the new entry to display the Edit DWORD Value dialog box.
To enable the PrintOSBM option, type 1 in the Value data field and click OK. This forces printing to
use off-screen bitmaps regardless of the translucency and anti-alias settings.
To disable this option, return to this dialog box, type 0 in the Value data field and click OK. This
causes printing to use off-screen bitmaps only for the translucency and anti-alias conditions.

This option takes effect the next time you open MapInfo Professional.
Note: You can also remove this regedit entry entirely to remove this option.
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EMF+ and EMF+Dual Export Formats
In order to take full advantage of enhanced rendering, MapInfo Professional provides two new image
export formats: EMF+ and EMF+Dual. These are enhanced metafile vector image formats that support
GDI+. Use these to save translucent maps instead of exporting to the older metafile formats (EMF and
WMF). Older formats do not support translucency very well, which display images using translucency
with a dithered, or speckled, appearance.
Choose EMF+ if you expect to bring your maps into an application that supports EMF+, such as Microsoft
Office 2007. Choose EMF+Dual (a combination of EMF and EMF+) if your maps may be used in applications that may or may not support EMF+, such as Microsoft's Office 2003 and Office 2007.
Note: EMF+Dual format will produce a larger file than EMF+. But it provides better compatibility with
older application that do not support EMF+.
Note: If you are printing a map/layout that contains a translucent image, you must select Print Using
Enhancement Metafile (EMF). The Print Directly to Device option does not support translucent
images.

MapInfo Professional Printing Guide Available in Help
Over the years, users have told us that the MapInfo Professional Printing Guide helps them print large
or complex maps or layouts. You can now access the MapInfo Professional Printing Guide, which contains
printing tips and tricks from our Quality Assurance department, in the Help System.
To access the Printing Guide in the Help System, choose Help > MapInfo Professional Help Topics
> Productivity Aids > MapInfo Professional 9.5 Printing Guide .

MapInfo Professional 9.0
Printing Large and Complex Output
If you have seen the Cannot Print error message when printing, you may be trying to print one or more
of the following:
• Large format (large page size) maps or layouts containing raster or grid layers that may be translucent
or transparent
In this case, many times the maps or layouts did not print at all, or if they did print, the translucent or
transparent layers did not print properly.
• Maps made up of multiple pages that contain borders
In this case multiple page maps with a border around the entire map would print with borders around
each page instead.
• Maps that contained labels that span more than one page
In this case, the labels would not print at all or would not print properly.
Largely, these issues were caused by the demand these print requests placed on the system resources
in your computer.
To resolve these issues we now offer an option that breaks down a print request into smaller blocks,
which reduces the demand on your system's resources. Each block is sent individually to the printer
driver. This change may allow you to print large and complex images that you could not print in the past.
We call this feature Subdivide Print. We limit the size of each block to 8192 x 8192 pixels.
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Caveat
During testing we discovered that many printer drivers handled this new option properly. However we
found that the output of some printer drivers resulted in gaps that display at the block boundaries.
Therefore we did not enable this option by default. Since these gaps may affect the quality of your final
output, we are giving you the ability to enable this option if or when you need it. At this time, we do not
have a workaround to remove these gaps.
Note: If you have both a postscript and a non-postscript version of your printer driver, we recommend
you try both to see which version gives you better results.
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