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Upgrading MapInfo Professional
For a list of new and enhanced features in this release, see the What’s New chapter in the MapInfo Professional User
Guide or MapInfo Professional Help.
To access the MapInfo Professional User Guide from the DiscStarter application, which launches when you insert the
MapInfo Professional DVD in to your machine's drive, click Online Reference > MapInfo Professional User Guide.

How to Uninstall the MapInfo Professional 12.0 Beta Release
Did you assist with the MapInfo Professional 12.0 Beta program? If you did, then before installing MapInfo Professional
you must first uninstall the MapInfo Professional Beta software. This is a two-step process that requires:
a. uninstalling the MapInfo Professional Beta using Add or Remove Programs in the Control Panel and
b. manually removing MapInfo Professional Beta files that are left behind.
To manually remove the MapInfo Professional Beta files left behind after uninstalling:
1. Locate the MapInfo Professional Beta files by searching for a folder called 1200 on your computer’s C drive. For
example:
On Windows XP
C:\Documents and
Settings\<user name>\Application Data\MapInfo\MapInfo\Professional\1200
On Windows 7
C:\Users\<user name>\AppData\Roaming\MapInfo\MapInfo\Professional\1200
2. Delete the 1200 folder and all of its contents.
You are now ready to install MapInfo Professional 12.0 to your computer.
Windows 8 and Windows 2012 users: If you have a previous version of MapInfo Professional 12.0 installed (a Beta
version), then you must reboot your machine after uninstalling the previous version and installing the latest release.
Rebooting correctly registers fonts on your machine, so that MapInfo Professional can locate and apply style types. If
you do not reboot, the fonts are not registered and MapInfo Professional closes unexpectedly when using the fonts.

Microsoft Warning for 64-Bit Version of Microsoft Office
If you do not have Microsoft Office installed on your machine, then MapInfo Professional 12.0 installs a Microsoft Office
2010 32-bit driver, so that MapInfo Professional can open Microsoft Access and Excel 2010 files.
If you already have the 64-bit 2010 Microsoft Office driver installed, and you do not have the 2007 32-bit driver
installed, then MapInfo Professional installs the Microsoft Office 2007 32-bit driver. You can still work with Microsoft
Access 2010 and Excel 2010, but you may see an error message if an incompatibility occurs.

L

Microsoft strongly recommends using the 32-bit (x86) versions of Office 2010, Project 2010, Visio 2010, and
SharePoint Designer 2010 applications as the default option for all platforms (including on a 64-bit operating
system).

Refer to 64-bit Editions of Office 2010 on page 8 for more details.

License Server Utility
If you have a previous version of the License Server Utility (LSU) installed to manage distributable licenses, then you
must upgrade to the latest License Server Utility, version 4.0. Using a previous version of the License Server Utility
with MapInfo Professional 12.0 will cause MapInfo Professional to become unresponsive.
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Using an incompatible version of the License Server Utility might result in the following issues while fetching licenses
for MapInfo Professional:
•
•

MapInfo Professional is unable to borrow a borrowable license.
MapInfo Professional is unable to activate a distributed license from the License Server.

If this occurs, contact your License Server administrator and have them upgrade the License Server to version 4.0.
After successfully borrowing or activating a license, if you again roll back to an older version of License Server Utility,
you con not transfer the borrowed/activated license back to License Server Utility. You will not see an error message
as the operation simply hangs.

Repairing MapInfo Professional from the .MSI file
On Windows 7 and Windows Server 2008, the repair process fails using the .msi file when the Microsoft User
Account Control (UAC) is turned on. Depending on the installation conditions one of two error messages displays and
the repair stops:
You have MapInfo Professional running, please close it and run setup again.
Or
MDAC 2.8 cannot be installed on this machine. MDAC 2.8 requires any one of the following configurations...
To work around this issue, do one of the following three things:
•
•
•

Shut off the UAC (User Account Control), this requires System Administrative privileges, reboot the machine, and
rerun the repair.
Run the original setup.exe file and then run the repair from maintenance mode.
Run the installed copy of the MapInfo Professional 12.0 .msi file as an administrator:
a. Go to C:\Windows\Installer and search for the MapInfo Professional 12.0 .msi file. It will have a name similar
to 8e95f1.msi, where the name is different for each machine.
b. Go to C:\Windows\System32 and find the cmd.exe file. Right click this file and select Run as Administrator
(this may require an administrator password).
c. Run the command C:\Windows\Installer\<nameofMiPro12.0.msi> and select Repair from maintenance
mode.

Disabling User Account Control (UAC) on Windows Vista/Server 2008
To disable UAC:
1. Launch MSCONFIG by from the Run menu.
2. In the System Configuration dialog box, click the Tools tab.
3. Scroll through the tools list to locate and then select Disable UAC.
4. Click Launch.
5. Click OK to close the dialog box.
6. Reboot the machine to have this change take effect.
Disabling User Account Control (UAC) on Windows 7/Server 2008 R2
1. Launch MSCONFIG from the Run menu.
2. In the System Configuration dialog box, click the Tools tab.
3. Click Change UAC Settings.
4. Click Launch.
5. Move the slider to Never Notify.
6. Click OK to close the dialog box.
7. Reboot the machine to have this change take effect.
MapInfo Professional 12.0 Release Notes

3

After repairing MapInfo Professional, follow the previous steps to turn UAC on again. We strongly recommend this
Windows security feature remain activate (remain turned on).

SQL Server Support
SQL Server 2008 on Vista
Vista is not a supported operating system with MapInfo Professional 12.0. If you choose to install to VISTA, then be
aware that SQL Server 2008 (SQL Server Spatial) provides a different ODBC driver for Windows Vista.
A Windows Vista user must use the x64 and Itanium versions of sqlncli.msi, which installs the 64-bit and 32-bit
versions of SQL Server Native Client, on your 64-bit Windows operating system
To download the appropriate sqlncli.msi, see http://msdn.microsoft.com/en-us/library/ms131321.aspx.

SQL Server 2012
If connecting to a SQL 2012 server with Windows 7 or higher, use the SQL Server Native Client 2012 (also known as
SQL Server Native Client 11.0). If connecting with Windows XP, this client is not supported and you will need the SQL
Server Native Client 10.0.

Bing Maps Expiration Date
Bing Maps has a limited license period, which is specific to each version of MapInfo Professional. Bing Maps and the
Add Bing Roads to Map and the Move Map to features cease working after this date:
•
•
•

MapInfo Professional 11.0 on January 1st 2013
MapInfo Professional 11.5 on January 1st 2014
MapInfo Professional 12.0 on January 1st 2015

Customers with a current maintenance package who would like to continue to use earlier version of MapInfo
Professional (11.0.x or 11.5.x) are entitled to use Bing services until January 1st 2015. For details, contact your
account representative.

Windows XP Support Expires in 2014
Microsoft has announced their retirement of the Windows XP operating system on April 8, 2014. MapInfo Professional
will continue to support this operating system for all MapInfo Professional 12.0.x releases, but will no longer support
this operating system for the MapInfo Professional 12.5 release in 2014.

Downloading Tools and Applications
Several tools and applications are available for download from the Pitney Bowes Software website at
www.mapinfo.com.

MapInfo
ProViewer

www.mapinfo.com/proviewer
MapInfo ProViewer lets anyone open, view and manipulate your MapInfo Professional maps,
tables and analyses with easy-to-use functionality including print, zoom, scroll, select objects,
measure distances and view details.
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MapBasic

www.mapinfo.com/mapbasic
The MapBasic development environment is a complete, BASIC-like programming language used
to create custom applications for use with MapInfo Professional or special MapInfo runtimes.
MapBasic allows you to customize the geographic functionality of MapInfo Professional, automate
repetitive operations and integrate MapInfo Professional with other applications.

EasyLoader

www.mapinfo.com/easyloader
EasyLoader lets you to upload MapInfo .tab files to a remote database, such as Oracle, SQL
Server, Microsoft Access, and PostgreSQL / PostGIS.

To install these downloads, unzip the download file in to your Temp folder (C:\Temp) and then launch the setup.exe. An
install wizard guides you through the installation process.

Locating Your Documentation
MapInfo Professional documentation, in the form of PDF files, installs with MapInfo Professional in to the
Documentation subfolder. You must have the Adobe Acrobat reader installed to view PDF files. To download a free
copy of the Adobe Acrobat Reader, go to http://www.adobe.com.
Installation Instructions are Available in the Install Guide on the DVD
For system requirements, installation instructions, and System Administrator notes for performing a workgroup
installation, see the MapInfo Professional Install Guide. You can view this document from the DiscStarter application,
which launches automatically when you insert the MapInfo Professional DVD in to your machine’s drive. From the
DiscStarter application:
•
•

click Online Reference > MapInfo Professional Install Guide, or
click Browse DVD. This launches an Explorer Window. Under the PDF_DOCS folder, double-click the
MapInfoProfessionalInstallGuide.pdf file.

Instructions for Activating your License are in the Install Guide
Instructions for activating your MapInfo Professional license are in the MapInfo Professional Install Guide. The same
information is also in the MapInfo Professional Licensing and Activation notes (ActivatingYourProduct.pdf).
The MapInfo Professional Data Directory Document is on the DVD
MapInfo Professional’s sample data comes with the MapInfo Professional Data Directory document, which describes
the sample data. You can view this document from the DiscStarter application, which launches automatically when you
insert the MapInfo Professional DVD in to your machine’s drive. From the DiscStarter application:
•
•

click Online Reference> MapInfo Professional Data Directory, or
click Browse DVD. This launches an Explorer Window. Under the PDF_DOCS folder, double-click the
MIProDataDirectory.pdf file.

All Documents Install with your Software
After installing MapInfo Professional, you can find documentation files under the Documentation folder where MapInfo
Professional is installed (for example, C:\Program Files (x86)\MapInfo\Professional\Documentation).
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Notes about this Release
This release provides a number of new features, enhancements, and new additions to MapInfo Professional.

New Features
For details about what is new in this release, see the section titled What’s New in the MapInfo Professional User Guide
or MapInfo Professional Help. This release provides the following new and updated features:

Improved Scale Bar Support
•

•

•

You can turn on or off automatic sizing, and enable transparency or choice of backgrounds for the scale bar. When
the automatic sizing is turned on the length of the scale bar will be calculated according to the new scale value. As
you zoom on the map, a new, adjusted scale value will be calculated relative to the originally requested scale bar
length.
The size of the scale bar adornment window will vary based on whether cartographic scale will be displayed on the
scale bar or not. The scale bar window will be smaller if the cartographic scale is not displayed. Select or clear the
Add Cartographic Scale check box to display or hide the cartographic scale.
The map scale and the cartographic scale in the scale bar show scientific notation only when the values are very
large or very small.

Better Placement of Curved Labels and Labels in Regions
•

•
•

You now have more control over how labels display, such as using abbreviations (table column or expression)
when labels are too long, auto reducing the font size to fit labels in regions, selecting fallback options to generate
rotated labels in places where curved labels do not fit, using callouts for labels that do not fit within regions, and the
ability to drag curved labels to reposition them.
The Layer Properties dialog box previews of your style selections, so that you can see your changes before
applying them to the map. The Label tool has more flexibility to place curved labels.
A new Adjust Labeling Priorities dialog box lets you control which layers are labeled, in cases where there is not
enough room to label all layers.

Enhancements when Working with Maps
•

•
•
•
•

In the Layer Control window there is a new Selectable Labels setting to make labels non-selectable, and a rightclick menu command to reset custom labels for only the layers you select instead of clearing all custom labels in
the map.
In the Legend Designer window long text descriptions now wrap within a legend frame, swatch sizes scale to match
the text when changing font size and you can specify the height and width of swatches.
You can now access more types of tile servers, including Tile Map Service (TMS) servers.
You can now change the map zoom to the nearest tile server level to display tile server images at an optimal zoom
level.
Support for additional coordinate systems, such as Extended Transverse Mercator Coordinate Systems, South
America Coordinate Systems, and Swedish Coordinate Systems.

More Control Over the Look of Printed Maps
•
•

You can now align selected frames in the Layout window relative to each other, both vertically and horizontally.
When printing a Map window, selecting the Centered on Window print option on the Map Print Options dialog box
prints the map at a different scale than what is in the Map window.

Productivity Gains
•

•

A product notifications window opens in a new session of MapInfo Professional to keep you up-to-date with
important news items and product update information. You can enable or disable the notifications from Options >
Preferences > Notifications.
The TAB file length limit has been extended. MapInfo tables (.TAB) have a limit of 250 columns and a limit of 254
characters in a column. The longest record that can be created is 63,500 bytes (250 x 254). Tables with record
lengths that exceed 4000 bytes, save with a version number of 1200. This feature will also enable you to open and
edit remote (RDB) tables with larger record lengths as both live cached and linked.
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•

Select Tools > Get MapBasic Utilities to launch a web page with a repository of MapBasic applications written by
people in the MapInfo Professional community and stay up-to-date with the latest developments.

Database and Data Access Enhancements
•

Support for PostGIS 2.0 and SQL Server 2012.
PostGIS 2.0 includes a new geography spatial data type, which MapInfo Professional is able to read.
Invalid geography is processed using the SQL Server 2012 MakeValid( ) function, so that the geography is valid.

•
•
•
•

•

Create new SQLite databases. You can save your MapInfo TAB file to a new SQLite database.
Open multiple DBMS tables when you select File > Open, and specify display styles and link or live options for
opening them.
Update to Feature Manipulation Engine (FME) 2013.
Update to the Universal Translator, which now uses FME 2013 Quick Translator. You can now translate ESRI
ArcSDE, ESRI Geodatabase (Personal Geodatabase) (.mdb), and Google Earth KML (.kmz, kml) formats. Plus,
the new Quick Translator window gives you more control over the translation process.
Added support for 16-bit MrSid format.

You also receive updates to the sample data provided with this release.

New and Updated Tools
•
•
•

Update to MapCAD, which includes new Orthogonal Polygon and Undershot/Overshot functionality and internal
calculation of the coordinate system based on the bounds.
A new PolyBuilder tool, which simplifies the conversion of a digitized linework (representing regions) into polygon
vector objects.
A new Table Structure Manager tool, which compares and edits multiple fields across multiple tables.

For more information about these tools, see the MapInfo Professional Help.

Licensing Improvements
•

•

In previous versions of MapInfo Professional, there were instances of broken licenses or licensing errors due to
antivirus software or disk-encryption software, or during an operating system upgrade. These issues have been
addressed by enhancing the licensing technology, so the number of broken licenses should significantly decrease.
The licensing server of MapInfo Professional has been upgraded. The upgrade contains enhanced reinstall
capabilities for node locked licenses. If your node locked license gets damaged or lost due to a machine crash,
operating system reinstall, or some other event, you can reactivate the license on the same machine. The new
capabilities recognize that the same machine is sending the activation request and provides the license without
affecting the number of available licenses.

Retiring Functionality
Envinsa Online Services (EOLS) Discontinued
Pitney Bowes Software’s hosted Envinsa Online Services (EOLS) have been discontinued. The Envinsa Online
Services link with MapInfo Professional 12.0 is no longer available to new customers.

OSM Roads Discontinued
In MapInfo Professional 12.0, the OSM Roads icon has been removed from the standard toolbar. Should you want to
continue working with OSM roads, the following files are provided to connect to an OSM-based tile server:
•
•

TileServer\OSMRoads.tab
TileServer\OSMRoads.xml
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Retired Labeling Options
The following option, which was located on the Layer Properties and Zoom Ranged Label Override dialog boxes under
the Label Display tab or Labeling Rules tab, has been retired or replaced:
•

Maximum number of labels – Enter the maximum number of labels that will display; labels are selected from the
designated table in the order in which they are entered in the table. For example, if the designated table is the
States table, and you enter 10, the first ten states listed in the table will be labeled.

Known Issues
Installing
Installing Sample Data on Windows 7 or Windows Server 2008
To work with the sample data after installation on Windows 7 or Windows Server 2008, you must install to a folder that
has permission to edit (read and write permission). Some folders, such as the Program Files folder, do not have write
permission by default when the User Account Control (UAC) is turned on. Consult with your system administrator prior
to installing the sample data.

64-bit Editions of Office 2010
Microsoft recommends installing a 32-bit version of Microsoft Office when you are dependent on using 32-bit
applications that interact with Office. In this case, MapInfo Professional is 32-bit application that requires 32-bit drivers
to work with Microsoft Office data, such as Access and Excel.
Microsoft offers detailed information at http://technet.microsoft.com/en-us/library/ee681792.aspx. This web posting
includes the following recommendations for which edition of Office 2010 to install:
•

•

If users in your organization depend on existing extensions to Office, such as ActiveX controls, third-party add-ins,
in-house solutions built on previous versions of Office, or 32-bit versions of programs that interface directly with
Office, we recommend that you install 32-bit Office 2010 (the default installation) on computers that are running
both 32-bit and 64-bit supported Windows operating systems.
If some users in your organization are Excel expert users who work with Excel spreadsheets that are larger than 2
gigabytes (GB), they can install the 64-bit edition of Office 2010. In addition, if you have in-house solution
developers, we recommend that those developers have access to the 64-bit edition of Office 2010 so that they can
test and update your in-house solutions on the 64-bit edition of Office 2010.

If you already have the 64-bit Microsoft Office driver installed, then MapInfo Professional 10.5.2 uses the Microsoft
Office 2010 32-bit driver installed with MapInfo Professional 11.5. You can still work with Microsoft Access and Excel
2010, but you may see an error message if an incompatibility occurs.
If you want to install an Office 64-bit application after installing MapInfo Professional 10.5.2, you must remove the 2010
Access database engine that was installed with MapInfo Professional 10.5.2. Follow the instructions provided in the
error message that you see from Microsoft:
Setup Error
You cannot install the 64-bit version of Office 2010, because you have 32-bit Office
products installed. These 32-bit products are not supported with 64-bit installations:
Microsoft Access database engine 2010 (English)
If you want to install 64-bit Office 2010, you must uninstall all 32-bit Office products first,
and then run setup.exe in the x64 folder. If you want to install 32-bit Office 2010, close
this Setup program and either go to the x86 folder at the root of your CD or DVD and run
setup.exe, or get the 32-bit Office 2010 from the same place you purchased 64-bit
Office 2010.

MapInfo Professional 12.0 Release Notes

8

To install the 64-bit Office 2010 application and then install the 32-bit Office 2010 driver:
1. From the Start menu, select Control Panel and then depending on your operating system select Add or Remove
Programs or Programs and Features.
2. From the list, select the Microsoft Access Database Engine 2010 driver and click Remove.
3. Install the 64-bit Office 2010 application on your computer.
4. Install the 32-bit Office 2010 driver on your computer.
You can download this driver from: http://www.microsoft.com/en-us/download/details.aspx?id=13255
You can now open all versions of Access and Excel files until version 2007 (Office 12) without issue. You can still work
with Access and Excel 2010 files, but you may see an error message if an incompatibility occurs.

Running on Windows 8
When running MapInfo Professional on Windows 8, you may see a display issue when moving the Map window, sizing
it, or restoring it from a maximized state. The Map window may leave pieces of itself drawn on other windows, usually
a docked window.
Workaround: If you encounter this issue, minimize MapInfo Professional or move the mouse over the docked window.
To quickly minimize and maximize MapInfo Professional, press the Windows Key + D to minimize the window and then
press D again to maximize the window (WIN+D+D).

Accessing a Premium Service License
If the License Server Utility has more than one serial number for the same product and version, then MapInfo
Professional can check out any one of them regardless of the serial number you entered during activation. If you have
a Premium Service and the License Server Utility selects a non-Premium serial number, then MapInfo Professional is
not available with Premium Services and vice versa.
This is applicable only when both product and version are the same—there are two serial numbers for MapInfo
Professional 11.5.
Workaround: Install the License Server Utility on two different machines, one with Premium Services serial number
activated and the other with non-Premium Services serial number activated.

Working with SQLite Databases
If a TAB file has Spatial Reference information in its metadata, MapInfo Professional will attempt to use this when
opening the table for a SQLite database without a map catalog. This is how a user-defined coordsys is stored if a table
is saved and a projection has to be chosen from the CSys picker dialog box. This information is also written into the
metadata and some data as well.
If using these files with a SQLIte database without a map catalog and the TAB file is saved in the database in a
different projection than specified in the TAB file Spatial Reference tags, the TAB file will not open correctly.
Workaround: Remove the lines that mention Spatial Reference from the TAB file. For example, remove the following:
"\Spatial
"\Spatial
"\Spatial
"\Spatial
"\Spatial
"\Spatial

Reference" = ""
Reference\Geographic" = ""
Reference\Geographic\Projection" = ""
Reference\Geographic\Projection\Name" = "Longitude / Latitude (WGS 84)"
Reference\Geographic\Projection\Clause" = "CoordSys Earth Projection 1, 104"
Reference\Geographic\Coordinate Units" = "degree"
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Working with PostGIS Databases
The Layer Properties dialog box opens slowly with some PostGIS layers in some cases.
Workaround: Select the Use Declare/Fetch check box when setting up your PostgreSQL data source. Selecting this
option does not cause any delay while opening the Layer Properties dialog box and also reduces the time taken to
open a PostGIS table.
You can check a PostGIS table’s .TAB file to determine if it is using the Declare/Fetch option. If the .TAB file’s
connection string specifies “UseDeclareFetch=0” it means the Use Declare/Fetch check box was not selected when
the .TAB was created. In this case you can reopen the database to recreate the .TAB file, or you can simply edit your
.TAB file’s connection string to “UseDeclareFetch=1”.
If the option Use Declare/Fetch is not used in a PostGIS layer, you may encounter a delay when opening the Layer
Properties dialog box. You can eliminate this delay by applying a style override to your layer. To apply a style override,
click the point, line, or region style sample to the left of the layer name, in the Layer Control window.

Working with the Legend Designer Window
MapInfo Professional generates an error when using the Legend Designer to add a Legend Text Frame if the text
includes a straight double quotation mark ( " ) instead of a smart double quotation mark ( “ and ” ). By default, MapInfo
Professional’s text editor creates straight quotes when you press the quotation key ( " ) on your keyboard.
Workaround: Repeat straight double quotation marks in the text of a Legend Text Frame to protect them in the
generated MapBasic command. As an example, instead of:
Version 12 "Delos" Legend Text Frame
Use:
Version 12 ""Delos"" Legend Text Frame
This workaround must be manually re-applied when modifying the Legend Text Frame via the Text Frame Properties
dialog, because the repeated quotation marks are lost during processing. As an alternative, replace the straight quotes
with smart quotes using the ALT key and the numeric keypad to specify the character code for the:
beginning quote: ALT + 0147
ending quote: ALT + 0148

Printing to PDF
Language Settings
When you change the language setting on the Configuration tab in the PDF Properties dialog box, the About tab
persists the previous language until you click the OK button.
In Windows 8, the Automatically Open the PDF check box is disabled in the PDF Preferences dialog box, even though
Adobe Reader 9.2 is installed in your system.
Workaround: Manually choose Adobe Reader 9.2 as the default PDF reader to enable the above option.

Password Protection
When you specify owner and user passwords on the Security tab in the Map Properties dialog box and then generate
a PDF of the map, opening the PDF from its location does not prompt you for the password. (You do not need a
password to open the PDF.)
However, if you specify owner and user passwords on the Security tab in the MapInfo PDF Printer Properties dialog
box and then generate a PDF of the map, opening the PDF prompts you for the password. (You must provide the
correct password to open the PDF.)
Workaround: You must password protect the PDF on the Security tab on the MapInfo PDF Printer Properties dialog
box and then open the PDF.
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Using the PolyBuilder Tool
MapInfo Professional Closes Unexpectedly
MapInfo Professional might close unexpectedly if you try to unload the PolyBuilder tool from Tools > Tool Manager or
run the tool using Tools > Run MapBasic Program, when the tool is already in session.
Workaround: Close the tool and unload it from the Tool Manager.

Message: No Error Flags Found
In the PolyBuilder tool, if you try to navigate through the endpoint flags for polygon errors using the View Next Error
Flag or the View Previous Error Flag buttons, you might encounter an error message, “No Error Flags Found”, even
though the line work or the text layer might have some errors.
Workaround: Rerun the tool and navigate through the errors using the error flag buttons.

Viewing Documentation
Please note the following when using your product’s online help:
•

Windows XP
MapInfo Professional online help includes images to illustrate some concepts. These images, especially text in the
image, may appear grainy and difficult to read on Windows XP if you are using an older version of Internet
Explorer. For optimal viewing, ensure that you have Microsoft Internet Explorer version 8 or higher installed on your
machine.

•

64-bit versions of Windows 7, Windows 8, Windows 2008 Server, and Windows 2012 Server
You may see the following message the first time you open a Help window. This is a known issue with the HLP
Help format on 64-bit operating systems. Click Yes to the prompt to open the product Help.
Why can’t I get Help from this program?
The Help for this program was created in Windows Help format, which depends on a
feature that isn’t included in this version of Windows. However, you can download a
program that will allow you to view Help create in the Windows Help format.
For more information, go to the Microsoft Help and Support website.
Some of the tools that install with MapInfo Professional use the HLP Help format, such as the 3D Graph wizard
(Window > New Graph Window).

Progress and Resolution of Outstanding Issues
The following issues have been corrected for this release.

MapInfo Professional
Issue Number
MIPRO-10798

Description and Resolution
When printing or creating a map, the cartographic scale on the scale bar changes with a different DPI being
used.
Resolution: Fixed.

MIPRO-10803

Changing the map units make the scale bar disappear in the Layout frame.
Resolution: Fixed.
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Issue Number
MIPRO-10926

Description and Resolution
Unable to remove decimal places in scale bar.
Resolution: Fixed. The scale value in the scale bar will now automatically remove any unnecessary trailing
zeros and decimal point. This will produce a more accurate value. For example, instead of showing a value
"150.0000", it will now show "150". And value "10.5000" will now display as "10.5".

MIPRO-14528

An error message appears when opening an MS Excel file, when applied a filter, in MapInfo Professional.
Resolution: Fixed.

MIPRO-14951

Opening ESRI SDE files by selecting Open > Universal Data randomizes table, which makes the data difficult
to view.
Resolution: Fixed.

MIPRO-15214

PDF batch printing closes unexpectedly after running for quite a while.
Resolution: Fixed.

MIPRO-17754

The Universal Translator generates an error when translating DXF file to TAB.
Resolution: Fixed.

MIPRO-18167

The scale bar disappears from the PDF when you place the scale bar in any position of the map, pan the map,
and print the map to PDF.
Resolution: Fixed.

MIPRO-18194

The GELink tool is unable to export very large amount of records to KML.
Resolution: Partially fixed.

MIPRO-18878

MapInfo Professional closes unexpectedly or freezes when a ranged thematic map is printed to PDF with the
Layered PDF option selected on the PDF Preferences dialog box.
Resolution: Fixed.

MIPRO-20337

Unable to open 16-bit MrSid files.
Resolution: Fixed. In MapInfo Professional 12.0, you will be able to open 16-bit MrSid images. You can also
open 16-bit MrSid images as 24-bit images. Other raster formats will not be affected by this.

MIPRO-21232

An error message appears when opening an MS Excel file in MapInfo Professional with a printing area defined.
Resolution: Fixed.

MIPRO-21687

Exporting a Layout produces an image with a different map scale in the scale bar than that of the original.
Resolution: Fixed. The extents have been incremented by 1 to fix the incorrect size of the Layout frame.

MIPRO-21707

A scale bar may cause the menu items on the tool bar to lose focus and not drop down.
Resolution: Fixed.

MIPRO-21729

MapInfo Professional displays an error when making a DBMS table mappable when it does not have a primary
key.
Resolution: Fixed.

MIPRO-21786

Printing a map with the Centered on Window option selected do not allow you to change the scale.
Resolution: Fixed.
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Issue Number
MIPRO-22512

Description and Resolution
Incorrect scale in the scale bar when copying a map window into MS Word. When you copy a map (Edit > Copy
Map Window) and paste into an MS Word document, the scale bar appears bigger in size and the scale is
different than that in the map.
Resolution: Fixed.

MIPRO-26265

You are unable to change the background of a legend in the Layout window.
Resolution: Fixed. You can now set an alternate fill for the layout frame background, or set the background to
NONE to make it transparent.

MIPRO-28891

When trying to edit a linked table to an MS Access database in MapInfo Professional and save the table, the
following error message appears:
Unable to read original record Operation canceled.
Resolution: Fixed. MS Access queries are now editable if they have a MI_PRINX column.

MIPRO-30777

Universal Translator closes unexpectedly when translating a DWG file in MapInfo Professional 11.5.1.
Resolution: Fixed.

MIPRO-31798

MapInfo Professional closes unexpectedly if the table structure for a cartographic text table stored in Oracle has
an incorrect data type.
Resolution: Fixed.

MIPRO-31827

Tile server layers do not allow styles to be set as grayscale. You cannot use the style override for a tile server
layer to set an image to grayscale or in color. In MapInfo Professional 11.5.x, both the Original Image and the
Grayscale radio buttons are disabled in the Adjust Image Styles dialog box.
Resolution: Fixed. Both the radio buttons are enabled now in the Adjust Image Styles dialog box so you can
override a style.

MIPRO-32199

There is an issue with the percent (%) symbol in the Legend Designer labels. If a special symbol ‘\%’ is used in
the description, the backsplash disappears and stays only ‘%’ when editing in the Legend Frame Properties
dialog box.
Resolution: Fixed.

MIPRO-32209

There is an issue with the Legend Designer window. The legend does not refresh when the layer visibility
changes.
Resolution: Fixed.

MIPRO-32542

WMS layers do not allow styles to be set as grayscale. Similar to a tile server layer, both the Original Image
and the Grayscale radio buttons are disabled in the Adjust Image Styles dialog box.
Resolution: Fixed.

MIPRO-33881

The statement Set Table <tablename> UserEdit Off does not affect the Editable icon on Layer Control. The icon
is still clickable even though MapBasic has disabled editing through the Set Table <tablename> UserEdit Off
statement or a Set Table <tablename> ReadOnly statement.
Resolution: Fixed. If a table has been designated non-editable through a Set Table statement, the layer’s
Editable checkbox is grayed out.

MIPRO-33944

A WMS layer does not render in MapInfo Professional.
Resolution: Fixed.
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Issue Number
MIPRO-33945

Description and Resolution
MapInfo Professional closes unexpectedly when generating a SQL SELECT query on a layout and then saving
the Layout window to a workspace.
The 11.5.3 Maintenance Release has a critical issue that affects workspaces.
Resolution: Fixed. This release ensures that you do not damage your existing workspaces when saving a
Layout window.

MIPRO-34049

Text with a halo background in a scale bar sometimes covers part of the scale bar.
Resolution: Fixed. The text in the scale bar was shifting down slightly when halo was turned on. Sometimes
this was causing the text to overwrite either the scale bar, or the background border of the scale bar window.
This has been fixed so that the text in the scale bar will stay in the same position whether halo is on or off.

MIPRO-34369

Selecting File > Save Window As to export a map containing a scale bar, incorrectly changes the size of the
scale bar when exporting to a resolution that is different from the screen resolution.
Resolution: Fixed.

MIPRO-34377

A Tile Server is unable to fetch the Bing capabilities with MIME type text/XML.
Resolution: Fixed. When using a proxy server to connect to the internet, it is possible that the proxy server may
return a different content type for a web response as opposed to when not using the proxy server. As a result
MapInfo Professional was failing to access the Bing maps because it was getting an incorrect response from the
server when retrieving the Bing capabilities. This issue has been resolved by relaxing the requirement on the
content type.

MIPRO-34471

SQL Server ODBC driver closes unexpectedly when updating date fields.
Resolution: For connections to SQL Server 2008, it is recommended to use the SQL Server Native Client
(version 10 or 11) ODBC driver, rather than the SQL Server 2008 driver. In MapInfo Professional, the DATE/
TIME fields are marked as read-only character fields when the source is read via the SQL Server 2008 driver.
This is a result of SQL Server 2008 driver (SQLSRV32.DLL) conversion of DATE and TIME source data types to
character strings, whereas the Native Client drivers (SQLNCLI1x.DLL) preserves the DATE and TIME data
types.

MIPRO-34490

When any point created on a cosmetic layer is exported using the Google Earth Utility tool, MapInfo
Professional closes unexpectedly, and the following error message appears:
(gelink.mb:477) Subscript out of range.
Resolution: Fixed.

EasyLoader
Issue Number
MIPRO-12309

Description and Resolution
A "structure is not the same" message displays when appending a native table with a MI_PRINX column in an
Oracle Spatial database with an OCI connection.
Resolution: Fixed.

MIPRO-12320

When uploading a table with no geometry into EasyLoader 11.5, the following error message appears:
Table cannot be Appended—It has a different table structure.
Resolution: Fixed.
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Issue Number
MIPRO-21730

Description and Resolution
Request to change the EasyLoader option named Grant Public Access to Table to make it more clear that
selecting this grants full access (with write permission) to the table.
Resolution: Fixed. The server table processing option Grant Public Access to Table has been changed to
Grant Public Full Access to Table.

MIPRO-32642

EasyLoader 12.0 is unable to import to “geography” data type in SQL Server 2008 SP2.
Resolution: Fixed. You will need to upgrade to SQL Server 2012. SQL Server 2012 uses the function
STIsValid( ) to check if a geography data type is well formed and recognized as a valid object based on its OGC
type. The MakeValid( ) function is also used that converts an invalid geography data type into a valid one.
In MapInfo Professional 12.0, you can use the extended spatial methods in SQL Server 2012 to manage valid
geography data types.
Refer to the SQL Server 2012 MSDN library for more information.

MapBasic
Issue Number
MIPRO-34515

Description and Resolution
MapBasic closes unexpectedly when trying to compile a program.
Resolution: Fixed. A MapBasic program with a Commit statement with a Type SQLServerSpatial Geometry or
Geography clause would cause the MapBasic to hang while compiling.
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