MapInfo Professional
Version 12.5

Printing Guide
The purpose of this guide is to assist you in getting the best possible output from your
MapInfo Professional software. We begin by covering the new print, import, and export
features and continue with preferences and printing options available in MapInfo
Professional. Then we give you some helpful tips and tricks and finally we help you trouble
shoot issues you may be experiencing with your own use of MapInfo Professional.
We have updated this document with new features and new resolutions to existing issues.
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Printing in MapInfo Professional

Printing in MapInfo Professional
Before you start printing your map, you may want to create a new layout so you can arrange your maps,
legends, titles for the best effect. On the Windows menu, point to New Layout Designer Window to
put together a more effective presentation. We recommend that you use Layout Designer windows for
printing because it ties directly to the printer driver.
To print a map or layout from MapInfo Professional:
1. When you have your map or layout the way you want it, on the File menu point to Print to display
the Print dialog box.
Note: When you print a layout, the Options and Advanced buttons do not display.
The Layout Designer window has buttons at the top of the window to access Page Setup, Print,
Print to PDF and Save Window As operations. These work just like the buttons in the application.
If an embedded window frame is active in the Layout Designer window, then the entire layout in the
Layout Designer window prints.
2. Select the printer or plotter you want to use for this workspace from the Name list. The properties
that are available for this device are printer/plotter dependent. Please check your device manufacturer's
manual for property details.
Note: Any selections you make in the Properties options overrides the selections made in the
preferences for the current print session.
3. If printing a map, select the print range of your output and the number of copies you want.
4. To set more print options, click the Options button to open the Map Print Options dialog box.
Note: You cannot select these options for a layout.
5. Make your selections and click OK to return to the Print dialog box.
• Map Size – Select the size of the map in this group; the options are Window Size, Fit to Page,
and Custom. As you make selections, the Custom Scale, Custom Width and Custom Height
entries change.
• Window Size – Click this button to print the map as it displays on your computer screen.
• Fit to Page – Click this button to fit the map to the page size you selected in preferences.
• Custom – Click this button to enter your own custom scale, width, and height entries in the fields
provided.

Setting How Layout Contents Print
The Layout Designer window can contain maps, browsers, legends, images, text, and shapes. Many
of the printing options necessary to print a Map window are automatically set when printing a Layout
Designer window. What you see in your printout will look the same as what you see in the layout on
your screen. Most of the contents of a layout print as vector or text, and not as raster.
When the Layout Designer window is active, you can print by pointing to Print or Print to PDF on the
File menu, or click these options on the toolbar. There are also buttons along the top of the Layout
Designer window for printing.
Only the contents of a layout that are within the margins (shown as grid lines on the layout) print. The
grid lines, guide lines, and frame selections that you see on a layout do not print.
The print operation uses the printer, page, and margins set on the Print dialog. If you change the printer
settings on this dialog when printing, then the layout canvas size changes after the print completes to
match the new settings. To see how changing the printer settings will affect your printout before you
print, use Page Setup to set page size, margins, orientation, and resolution.
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Printing Map Frames in a Layout Designer Window
When printing a Layout Designer window, map frames have some printing considerations. Each map
frame in the layout is independent of the other map frames in the same layout.
What You See is What You Get
When printing a layout, the map in the printout looks identical to the map in the layout on the screen (this
includes how the labels look).
Print OSBM
Off-Screen Bitmap (OSBM) automatically applies when printing a map frame that contains items or
options that require OSBM to preserve their appearance in print. Using OSBM processes each print tile
as a raster. This is an automatic setting that you cannot control when printing from a Layout Designer
window. Using OSBM applies when the Map has enhanced rendering turned on, and one or more visible
layers with:
• Translucent vectors.
• Images (such as raster, grid, WMS, or tile server) with transparency, translucency, or image smoothing.
Printing to a layered PDF does not use the Print OSBM method.
Subdivide Printing
You can turn on subdivide printing as a preference (on the Options menu, point to Preferences, Output
Settings, Printing, and then click Subdivide Printing). When subdivide printing is turned on and Print
OSBM is not being used, then each map in a Layout Designer window divides into smaller tiles while
printing. This reduces the amount memory required to process the print job, especially when the map
frame is large. When subdivide printing is off, then each map frame prints at once.
Translucent Images
If your map contains translucent images (usually raster, grid, WMS, or TileServer images) and Enhanced
Rendering is turned off, then it may not print as translucent. To make it print with translucency, on the
Map menu, point to Options. In the Map Options dialog box, check the Enable Enhanced Rendering
check box.

Printing of Items Other Than Map Frames
The non-map content in a Layout Designer window should be printed as vector and/or text. It should
not be rasterized.
The legend sample swatches convert to raster during print or export. Even though TrueType point symbols
are rendered as text on the screen, they convert to raster during printing or exporting.

Setting How Layout Content Exports
Normally, what you export looks identical to what is in the Layout Designer window. However, some
graphics and text may become blurry when you export a layout. To correct this, on the Options menu
point to Preferences and then click Output Settings. On the Output Preferences dialog box, under
the Exporting tab, select the Clarify Text check box. This corrects the issue, but may cause some
labels on the map to look slightly different in the export from what is in the layout.

Setting How Map Contents Print
In the Map Print Options dialog box, you have the option to determine the map contents that you want
to print; the options are Same as Window and Centered on Window. (To go there select File > Print
and click Options in the Print dialog box.)
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• Same as Window – Click this button to print the map contents as it appears in the Map window, with
the same proportions and content as you see.
• Centered on Window – Click this button to center as much of the current map that fits on the page.
When you select this option, the image may print on more than one page depending upon fit. In general
when you select this option, MapInfo Professional assumes you want to select the Fit to Page radio
button and selects this for you.

Setting Advanced Print Options
In the Advanced Printing Options dialog box, you can refine your print settings. (To go there on the
File menu point to Print and click Advanced in the Print dialog box.)
Note: You cannot select these options for a layout in a Layout Designer window.
These options are the same as those you select in the Output Settings Preferences dialog box. Selecting
options here overrides the setting you selected in the Output Settings Preferences dialog box for the
current print session.

Output Method
There are three output methods.
• Print Directly to Device – Use this option to print your image file directly from MapInfo Professional.
This is the default setting and is same printing from all versions before 6.0.
• Print Using Enhanced Metafile (EMF) – Use this option to generate an enhanced metafile of your
MapInfo Professional image before sending it to the printer. This option takes advantage of current
technology to shrink the spool size and print your file quicker without sacrificing quality.
• Print Using Offscreen Bitmap (OSBM) – Use this option to generate an offscreen bitmap of your
MapInfo Professional image before sending it to the printer. This option depends on the type of
translucent content in the map and enhanced rendering state of the window.

Print Border for Map Window
Select this check box to print a black border around the image you are printing. Clear this check box to
print the image without a border. This check box is selected by default.

Internal Handling for Printing Transparent Vector Fills and Symbols
Special programming has been added to handle transparent fill patterns and bitmaps for vector images
when you print. Select this check box to use this functionality or clear it to let the printer or plotter to
manage this type of work. This check box is selected by default.

Scale Patterns
Select this check box to print non-transparent fill patterns that look like what you see on your screen.
This check box is checked by default. Clear this check box to let the printer driver have exclusive control
over rendering the pattern fills.

Recommendations for Effective Pattern Scaling
When you are printing, find out what type of printer driver you are using. Many PCL6 and some HPGL
drivers handle fill pattern scaling and give you control over this feature. Turning off their scaling may be
the difference between what you see in print and what you see on your monitor. We recommend that
you try turning off your driver's scaling options and try ours first, because we have enhanced our method
to better meet your Map and Layout window requirements. To turn our pattern scaling options on, select
the Scale Patterns check box in the Output Preferences dialog box. Then try turning off our scaling
and turn theirs back on to see which you like better. Tests show that our scaling produces color output
that more closely matches your screen's display.
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If you are printing to postscript drivers using LanguageLevel 2 or 3, we find that some of the Microsoft
drivers do not support pattern scaling. As a result, our scaling method may not help you. Microsoft
recommended that you reset the language level of the postscript driver to LanguageLevel 1 to remove
this restriction.

Use ROP Method to Display Transparent Raster
Select this check box to allow the internal ROP (Raster Overlay by Pixel) to manage the transparent
pixels when printing raster images. Since the ROP Method is largely a display method, not all printers
and plotters can use it. We recommend that you experiment with this setting until you get the results you
want when printing raster images. This setting has no effect when printing vector layers. This check box
is cleared by default.

Print Raster in True Color When Possible
Select this check box to print your 24-bit raster or grid file images in true color. Make sure your printer
settings are greater than 256 colors. This check box is selected by default.

Dither Method
Click this drop-down list to convert a 24-bit image into 256 colors, using either Halftone or Error diffusion.
When you have completed these selections and returned to the Print dialog box, click OK to begin
printing.

Printing to a File
To print a map or a layout to a file:
1. From the File menu, select Print or Print to PDF to open the Print dialog box.
2. Select the Print to File check box.
3. Click OK to open the Print to File dialog box.
4. Type the name of the file you want to create in the field provided and click OK. Use the extension
.PRN to help you identify the file as a print file.

Printing to a Layered PDF File
PDFs are capable of holding multiple pages of information in the same space through the use of Optional
Content Groups (OCG), which are more commonly known as layers. Layers in PDFs are very similar to
MapInfo Professional map layers.
Each layer may hold any portion of the document's objects and layers may be made visible or invisible,
showing or hiding their contained objects, in any combination. By selectively hiding layers, you reduce
distractions to concentrate on particular areas or types of objects. Layers can be organized into groups
and the visibility option can apply to all layers within a group as one step.
To print a map or a layout to a layered PDF:
1. From the File menu, select Print or Print to PDF to open the Print dialog box.
2. From the Name list, select MapInfo PDF Printer. This is the PDF driver that installs with MapInfo
Professional.
Note: The Layered PDF option is only available when using the MapInfo PDF Printer.
Optionally, click Properties to set any printing preferences.
3. Click PDF to open the PDF Preferences dialog and check the Layered PDF check box.
Note: It may take some time to process a large map with many layers.
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When printing a layout in a Layout Designer window to a layered PDF, each frame (such as map,
browser, legend, image, text, and shapes frames) becomes a layer in the PDF. You can also use a
different PDF driver, not the MapInfo PDF Printer. Doing so creates a static PDF map without layer
information, so you do not have the ability to turn on or off particular map layers.
Labels in a Map window save to a separate layer in the PDF with a name that includes the parent layer
name. Adornments save as a separate Adornments layer in the PDF. An empty Cosmetic layer does
not save to the PDF.

General Printing Tips and Tricks
Good first steps in troubleshooting a printing problem are to make sure you have downloaded and
installed the latest patch for MapInfo Professional and are using the latest printer driver for your
printer/operating system. Exceptions are noted in this document.
Seeing Black Boxes Instead of Symbols when Printing to PDF?
If you are printing to the MapInfo PDF Printer, try turning on Enable Postscript Simulation. In the Print
dialog box (on the File menu, point to Print to PDF), click the Properties button. In the MapInfo PDF
Printer Properties dialog box, select the Advanced Options tab and then select the Enable Postscript
Simulation check box.
Compress the Size of Raster Maps when Printing to PDF Tip
Use one of the image compression options with the MapInfo PDF Printer to select how to compress
black and white or color images, or select to remove duplicate images, downsample high resolution
images, and disable PNG/JPEG printing. On the Print dialog box (on the File menu, point to Print to
PDF), click the Properties button. In the MapInfo PDF Printer Properties dialog box, select the Image
Compression tab.
Save New Defaults and Save Time Printing to PDF
Don't select the same setting over and over again when printing to PDF. Save your setting once as the
default setting. From the Start menu, select the Control Panel and then Printers and Faxes. In the
Printers and Faxes screen, right-click MapInfo PDF Printer and select Printing Preferences. Make
your favorite setting and click OK to apply it as a default when you print to PDF. As an example, turn on
Enable Postscript Simulation in the MapInfo PDF printer.
Embedding MapInfo Professional Graphics Tip
When you embed a MapInfo map or graph in another application (such as Word or PowerPoint), click
outside the map/graph before you use the Print or Print Preview commands. This allows the container
application to take over previewing or printing properly. This is particularly true if you have just made
changes to the map or graph you are printing.
Need for Speed When Using Fill Patterns?
Note that fill patterns on the first row of the Region Style dialog box (see next figure) are Windows
standard and tend to print faster. The other patterns are bitmaps MapInfo has created for your use. You
might want to consider this when you are selecting fill patterns.
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1 Use the fill patterns from this row for fast printing results.
Speed Still an Issue?
If you want to improve printer speed, and your printer has Fast, Normal, Best print quality options, we
suggest you select Fast.
If your image is large and you are printing at a resolution of 600 DPI or greater, your image may exceed
this limitation. To print the image, reduce the resolution of the printout or shrink the size of the image.
Translucent Raster Maps?
If your map contains translucent layers, then the output converts to a raster image to maintain the
translucency during the printing process. This also converts vector graphics and text to raster. To maintain
text and raster in the output, you must disable the translucency in the map. However, if you wish to
maintain translucency while printing, ensure the map has Enhanced Rendering turned on.
Old Driver Works, New Driver Doesn't
When in doubt, if an older driver worked and the new one does not, go back to the older driver.
Disk Space an Issue?
Make sure you have plenty of temporary disk space, particularly if you are printing large or complex
maps or layouts, and especially if they contain raster images and/or translucency.
Printing Globally? Spool Locally!
Try spooling print jobs locally rather than at the plotter. This allows the computer to rasterize your output
rather than the printer, which can be more efficient.
1.
2.
3.
4.

To set up local print job spooling, on the Start menu, point to Settings, Control Panel, Printers.
Right-click the printer and choose Properties to display the printer's properties.
Click the Advanced tab to display the advanced property options.
Click the Spool Print Documents button and Start printing after last page is spooled button.
Note: If you do not have administrative rights to your computer, you may not be able to use the
spooling option. Contact your IT department if you want to make this change to get their
support.

5. Click OK to save your changes.
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Enhancements Added in Different Versions
MapInfo Professional 12.5
New Layout Designer Window
MapInfo Professional 12.5 has a new Layout Designer window. Printing and exporting layouts from this
window has much better quality and it supports working with labels. How labels look in the output is now
identical to what you see in the layout, so labels in the embedded map frames within a Layout Designer
window look the same on the screen, in printouts, and in exported files. The Layout Designer window
maintains text and vector whenever possible, which minimizes rasterization and improves the output
quality.

MapInfo Professional 11.0
Saving Preferences for Georegistration Coordinate Units
You can select to store the bounds and coordinate systems of the map or layout view in your PDF file.
This type of file is called a Georegistered PDF. You can save preferences to set the georegistration
coordinate units to either Use Map Units or Use Degrees. For more information and instructions on
how to do this, see Saving Preferences for Georegistration Coordinate Units in the Help System.

MapInfo Professional 10.5
New in this release are polygon mode printing, printing to an offscreen bitmap (OSBM), subdivide printing,
and printing to a PDF file.
Polygon Mode Printing
This release of MapInfo Professional introduces a new way of drawing complicated polygons, such as
those containing holes or many nodes through a User Interface. This was due to an issue with printing
such objects using an Adobe PDF printer driver. It left visible seams and gaps in the image when the
PDF was printed. These seams and gaps were not visible on screen nor when printed using other printer
drivers.
Printing with the new method means that large polygons are now rendered as-is not broken into smaller
polygons, as the older method does. Additionally, the new method uses different calls that specifically
support drawing polygons with holes. The older method manipulates the polygon with holes to draw as
a single polygon, which caused seams and gaps to appear in the PDF
Note: Because this issue does not affect all users of MapInfo Professional who print maps, we continue
to provide the original polygon drawing method.
Polygon Mode may be set for each of three types of drawing: on-screen, printing, and exporting. Select
Polygon Mode on the Options menu, point to Preferences and click Output Settings to open the
Output Preferences dialog box. Polygon Mode is a check box on the Display, Printing, and Exporting
tabs.
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Note: The setting is independent to output method and is not saved on per window basis. This setting
will not affect any other option's User Interface.

Printing to an Offscreen Bitmap (OSBM)
The Print using Offscreen Bitmap (OSBM) printing method renders a print job to offscreen bitmaps
prior to sending it to the printer or plotter. It is used when printing maps and layouts containing translucency
and/or anti-alias content, particularly for raster images. When printing, on the File menu, point to Print
and click Advanced to open the Advanced Printing Options dialog box. Select the Print using
Offscreen Bitmap (OSBM) check box.
This printing process generates an Offscreen bitmap of your MapInfo Professional image before sending
it to the printer. Offscreen bitmap is invoked depending upon the type of translucent content in the map
and enhanced rendering state of the window. However, setting OSBM from this window means that
while printing Offscreen bitmaps (OSBM) will be selected regardless of the translucency and anti-alias
settings.
Setting Print to an Offscreen Bitmap as your Default
You can set this option as a default on the Options menu, point to Preferences and clicking Output
Settings to open the Output Preferences dialog box. On the Printing tab, select Print using Offscreen
Bitmap (OSBM) to sets the default for all new windows.
Subdivide Printing
In earlier versions of MapInfo Professional, there was an optional registry setting, called
SubdividePrinting, to allow print jobs to be broken into multiple, smaller print requests. This was
especially useful if printing large raster/ translucent maps to large paper sizes. Now that option has been
added as a preference. The preference is initialized using the registry setting if it existed.
On the Options menu, point to Preferences and click Output Settings to open the Output Preferences
dialog box. On the Printing tab there is a check box for Subdivide Printing. If checked, the print job is
broken into multiple smaller print request. If unchecked, the print is done in a single request.
Printing to PDF
Professional lets you save a map to a layered PDF file. Since Acrobat 6.0, PDFs are capable of holding
multiple pages of information in the same space through the use of Optional Content Groups (OCG),
which are more commonly known as layers. Layers in PDFs are very similar to MapInfo Professional
map layers.
Your PDF now displays layers in the same order as shown in the MapInfo Professional Layer Control
window, and it displays translucency. The MapInfo PDF Printer supports GeoRegistration, which stores
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the bounds and coordinate systems of the map view in the PDF file. The PDF file also stores the attribute
data of the records on the map.
New in this release when saving to a PDF file:
• Print to PDF – Select File > Print to PDF to save your map, browser, graph, or layout to a PDF file.
This option is similar to Save As, and gives you the option to concatenate PDF files.
• MapInfo PDF Printer tool – The Main menu includes a new MapInfo PDF Printer tool, which is the
same as selecting File > Print to PDF to save your map, browser, graph, or layout to a PDF file.
• Translucency – You can create a layered PDF that includes translucent layers in MapInfo Professional
10.5.
• PDF Preferences – The MapInfo Professional Print dialog (select File > Print) now includes a PDF
button that displays after selecting MapInfo PDF Printer from the Name list. This button launches the
PDF Preferences dialog. From this dialog, you can make the following settings:
Layered PDF
Select to save layers for a map, as shown in the MapInfo Professional Layer Control window, to the
PDF file. When saving a Layout window, each frame, such as map frame and legend frame, becomes
a layer in the PDF.
Georegistered PDF
Select to store the bounds and coordinate systems of the map or layout view in the PDF file.
Add Attribute data to PDF
Select to store the attribute data of the records on the map in the PDF file.
Automatically open the PDF
Select to have the PDF file open after it is generated.
Selecting the Layered PDF option in the PDF Preferences dialog box enables the Direct to Device
option, and disables using OSBM and EMF.
If you select the Print using EMF or Print using the Offscreen Bitmap (OBSM) output method and later
on select the Layered PDF from the PDF Preferences dialog box, then the output method forcibly
sets to Direct to Device. However, disabling the Layered PDF option resets the print output method
back to your original selection, EMF/ OSBM.
• Context Sensitive Help for the MapInfo PDF Printer – This version of the MapInfo PDF Printer
includes documentation in the form of a help system. To access this help system, select File > Print
and click Properties in the Print dialog box. This opens the MapInfo PDF Printer Properties dialog
box, which now includes a Help button on each tab.

MapInfo Professional 10.0
MapInfo Professional lets you save a map to a layered PDF file, see Printing to a Layered PDF File
on page 5.
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